summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-13 22:59:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:57:33 +0200
commit00eacac42f3b676022d6a0585bb9b375f8da3f06 (patch)
tree7d631a92dd3bc30f36781727a4e195fe5d1e8d96 /meta-filesystems
parenta246dd26a5af8f9b23a98756ce0bcfc21d91a17e (diff)
downloadmeta-openembedded-00eacac42f3b676022d6a0585bb9b375f8da3f06.tar.gz
recipes-utils: Add recipe for udevil
udevil is a command line Linux program which mounts and unmounts removable devices without a password. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch12
-rw-r--r--meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch32
-rw-r--r--meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb28
3 files changed, 72 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch b/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch
new file mode 100644
index 000000000..355e93a37
--- /dev/null
+++ b/meta-filesystems/recipes-utils/udevil/files/0001-udevil-0.4.3-fix-compile-with-gcc6.patch
@@ -0,0 +1,12 @@
1Fix compilation with GCC6
2
3--- a/src/device-info.c 2013-12-09 14:59:27.000000000 +0100
4+++ b/src/device-info.c 2017-03-13 07:06:25.506666680 +0100
5@@ -3,6 +3,7 @@
6 * contains code excerpts from udisks v1.0.4
7 ************************************************************************** */
8
9+#include <sys/stat.h>
10 #include "device-info.h"
11
12 static char *
diff --git a/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch b/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch
new file mode 100644
index 000000000..f014a0f53
--- /dev/null
+++ b/meta-filesystems/recipes-utils/udevil/files/0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch
@@ -0,0 +1,32 @@
1From 80b087193698632e525b90d45b4a49e61e343e1c Mon Sep 17 00:00:00 2001
2From: Krzysztof Kozlowski <krzk@kernel.org>
3Date: Thu, 13 Jul 2017 21:30:35 +0200
4Subject: [PATCH] etc: Makefile.am: Use systemd_unitdir instead of libdir
5
6Proper directory for installing systemd services is systemd_unitdir, not
7libdir.
8
9Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
10---
11 etc/Makefile.am | 6 +++---
12 1 file changed, 3 insertions(+), 3 deletions(-)
13
14diff --git a/etc/Makefile.am b/etc/Makefile.am
15index 9b6e7522c20f..6d663241a72f 100644
16--- a/etc/Makefile.am
17+++ b/etc/Makefile.am
18@@ -16,8 +16,8 @@ if ADD_SYSTEMD
19 test -f $(DESTDIR)/$(sysconfdir)/conf.d/devmon || $(INSTALL_DATA) \
20 $(srcdir)/systemd/devmon \
21 $(DESTDIR)/$(sysconfdir)/conf.d/devmon
22- test -d $(DESTDIR)/$(libdir)/systemd/system || \
23- mkdir -p -- $(DESTDIR)/$(libdir)/systemd/system
24+ test -d $(DESTDIR)/$(systemd_unitdir)/system || \
25+ mkdir -p -- $(DESTDIR)/$(systemd_unitdir)/system
26 $(INSTALL_DATA) $(srcdir)/systemd/devmon@.service \
27- $(DESTDIR)/$(libdir)/systemd/system/devmon@.service
28+ $(DESTDIR)/$(systemd_unitdir)/system/devmon@.service
29 endif
30--
312.11.0
32
diff --git a/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb b/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
new file mode 100644
index 000000000..c432e8546
--- /dev/null
+++ b/meta-filesystems/recipes-utils/udevil/udevil_0.4.4.bb
@@ -0,0 +1,28 @@
1SUMMARY = "A command line Linux program which mounts and unmounts removable devices"
2HOMEPAGE = "http://ignorantguru.github.io/udevil/"
3
4DEPENDS = "glib-2.0 \
5 glib-2.0-native \
6 intltool-native \
7 udev \
8"
9RDEPENDS_${PN} = "udev"
10
11LICENSE = "GPL-3.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
13
14inherit autotools systemd
15
16SRC_URI = "https://github.com/IgnorantGuru/udevil/raw/pkg/${PV}/udevil-${PV}.tar.xz \
17 file://0001-udevil-0.4.3-fix-compile-with-gcc6.patch \
18 file://0002-etc-Makefile.am-Use-systemd_unitdir-instead-of-libdi.patch \
19"
20
21SRC_URI[md5sum] = "dc1c489b603a0500a04dc7e1805ac1d9"
22SRC_URI[sha256sum] = "ce8c51fd4d589cda7be56e75b42188deeb258c66fc911a9b3a70a3945c157739"
23
24PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
25PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
26
27SYSTEMD_SERVICE_${PN} = "devmon@.service"
28SYSTEMD_AUTO_ENABLE = "disable"