summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-06-30 03:25:24 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:45:53 +0200
commit1cbd1bc195017312ba8cf670b340f61a2ac6207b (patch)
tree35c4cde17f4bd0a05d7f109a5f078d390fb47381 /meta-filesystems
parent65a4fce6d8ab6547d57985e0ee2a8e197aadca64 (diff)
downloadmeta-openembedded-1cbd1bc195017312ba8cf670b340f61a2ac6207b.tar.gz
unionfs-fuse: 0.26 -> 2.0
- Fix 0.26's do_compile failure by inheriting cmake and pkgconfig - Update upstream to github Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch32
-rw-r--r--meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb19
-rw-r--r--meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb18
3 files changed, 50 insertions, 19 deletions
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
new file mode 100644
index 000000000..bf363ca1b
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch
@@ -0,0 +1,32 @@
1From 449cec34c123b86b792627553c6ec7471d2ee7ed Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 30 Jun 2017 14:46:51 +0800
4Subject: [PATCH] support cross compiling
5
6Do not override OE CMAKE variables
7
8Upstream-Status: Pending
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11---
12 CMakeLists.txt | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16--- a/CMakeLists.txt
17+++ b/CMakeLists.txt
18@@ -10,9 +10,9 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
19 ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
20
21 # Select flags.
22-SET(CMAKE_C_FLAGS "-pipe -W -Wall -DFORTIFY_SOURCE=2")
23+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -DFORTIFY_SOURCE=2")
24 SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
25-SET(CMAKE_C_FLAGS_RELEASE "-O2")
26+SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2")
27 SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG")
28
29 if (UNIX AND APPLE)
30--
312.8.1
32
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb
deleted file mode 100644
index 25204293a..000000000
--- a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_0.26.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "A FUSE based implemention of unionfs"
2HOMEPAGE = "http://podgorny.cz/moin/UnionFsFuse"
3SECTION = "console/network"
4LICENSE = "BSD-3-Clause"
5DEPENDS = "fuse"
6LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8abab00b483a1b7943a32"
7
8SRC_URI = "http://podgorny.cz/unionfs-fuse/releases/${BP}.tar.xz"
9
10SRC_URI[md5sum] = "689c636484756f6f7a728ef354cbeac2"
11SRC_URI[sha256sum] = "8d5c9dcb51ecb9a9b03890e16d17e37d602b0c1f23ed6a9ddec2b0f719c9f662"
12
13do_install() {
14 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
15}
16
17RDEPENDS_${PN} += "bash"
18
19PNBLACKLIST[unionfs-fuse] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130648/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb
new file mode 100644
index 000000000..b89d8db15
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "A FUSE based implemention of unionfs"
2HOMEPAGE = "https://github.com/rpodgorny/unionfs-fuse"
3SECTION = "console/network"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8abab00b483a1b7943a32 \
6 file://LICENSE;md5=7e5a37fce17307066eec6b23546da3b3 \
7"
8
9SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master \
10 file://0001-support-cross-compiling.patch \
11"
12SRCREV = "c8d23a9a75f1a62988593671839e8a168a79f3e5"
13
14DEPENDS = "fuse"
15
16S = "${WORKDIR}/git"
17
18inherit cmake pkgconfig