summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-09-18 16:46:30 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:39:46 +0200
commit90eb8fa98076a56c0fae9692339f7f908f5465b6 (patch)
tree57356e71ecb5586dc54cfc75d01862af24878b18 /meta-filesystems
parent335d425c99466656f86769d53ca61f28f8018f1d (diff)
downloadmeta-openembedded-90eb8fa98076a56c0fae9692339f7f908f5465b6.tar.gz
fuse: upgrade to 2.9.4
Changes: * Remove 001-fix_exec_environment_for_mount_and_umount.patch which has been included in the new version * Add sysvinit and systemd support * For systemd, there is not a fuse.service since systemd provides sys-fs-fuse-connections.mount to mount the fuse control filesystem, so instead, only fuse.conf is added to modules-load.d to load the required fuse kernel module. * Add RDEPENDS on util-linux-mount * Add a patch to fix the return value of "--help" option Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/files/0001-fuse-fix-the-return-value-of-help-option.patch28
-rw-r--r--meta-filesystems/recipes-support/fuse/files/001-fix_exec_environment_for_mount_and_umount.patch63
-rw-r--r--meta-filesystems/recipes-support/fuse/files/fuse.conf1
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.4.bb (renamed from meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb)30
4 files changed, 54 insertions, 68 deletions
diff --git a/meta-filesystems/recipes-support/fuse/files/0001-fuse-fix-the-return-value-of-help-option.patch b/meta-filesystems/recipes-support/fuse/files/0001-fuse-fix-the-return-value-of-help-option.patch
new file mode 100644
index 000000000..577dbb5b2
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/files/0001-fuse-fix-the-return-value-of-help-option.patch
@@ -0,0 +1,28 @@
1From 2182c423c6cd235c052e6c420203f24ec9bcd6ab Mon Sep 17 00:00:00 2001
2From: Lu Chong <Chong.Lu@windriver.com>
3Date: Wed, 30 Oct 2013 15:27:00 +0800
4Subject: [PATCH] fuse: fix the return value of "--help" option
5
6Upstream-Status: Pending
7
8Signed-off-by: Lu Chong <Chong.Lu@windriver.com>
9---
10 util/fusermount.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/util/fusermount.c b/util/fusermount.c
14index b2e87d9..70d7c75 100644
15--- a/util/fusermount.c
16+++ b/util/fusermount.c
17@@ -1168,7 +1168,7 @@ static void usage(void)
18 " -q quiet\n"
19 " -z lazy unmount\n",
20 progname);
21- exit(1);
22+ exit(0);
23 }
24
25 static void show_version(void)
26--
271.7.9.5
28
diff --git a/meta-filesystems/recipes-support/fuse/files/001-fix_exec_environment_for_mount_and_umount.patch b/meta-filesystems/recipes-support/fuse/files/001-fix_exec_environment_for_mount_and_umount.patch
deleted file mode 100644
index 8332bfbb7..000000000
--- a/meta-filesystems/recipes-support/fuse/files/001-fix_exec_environment_for_mount_and_umount.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From cfe13b7a217075ae741c018da50cd600e5330de2 Mon Sep 17 00:00:00 2001
2From: Miklos Szeredi <mszeredi@suse.cz>
3Date: Fri, 22 May 2015 10:58:43 +0200
4Subject: [PATCH] libfuse: fix exec environment for mount and umount
5
6Found by Tavis Ormandy (CVE-2015-3202).
7
8Upstream-Status: Submitted
9Signed-off-by: Tudor Florea <tudor.florea@enea.com>
10
11---
12--- a/lib/mount_util.c
13+++ b/lib/mount_util.c
14@@ -95,10 +95,12 @@ static int add_mount(const char *prognam
15 goto out_restore;
16 }
17 if (res == 0) {
18+ char *env = NULL;
19+
20 sigprocmask(SIG_SETMASK, &oldmask, NULL);
21 setuid(geteuid());
22- execl("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
23- "-f", "-t", type, "-o", opts, fsname, mnt, NULL);
24+ execle("/bin/mount", "/bin/mount", "--no-canonicalize", "-i",
25+ "-f", "-t", type, "-o", opts, fsname, mnt, NULL, &env);
26 fprintf(stderr, "%s: failed to execute /bin/mount: %s\n",
27 progname, strerror(errno));
28 exit(1);
29@@ -146,10 +148,17 @@ static int exec_umount(const char *progn
30 goto out_restore;
31 }
32 if (res == 0) {
33+ char *env = NULL;
34+
35 sigprocmask(SIG_SETMASK, &oldmask, NULL);
36 setuid(geteuid());
37- execl("/bin/umount", "/bin/umount", "-i", rel_mnt,
38- lazy ? "-l" : NULL, NULL);
39+ if (lazy) {
40+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
41+ "-l", NULL, &env);
42+ } else {
43+ execle("/bin/umount", "/bin/umount", "-i", rel_mnt,
44+ NULL, &env);
45+ }
46 fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
47 progname, strerror(errno));
48 exit(1);
49@@ -205,10 +214,12 @@ static int remove_mount(const char *prog
50 goto out_restore;
51 }
52 if (res == 0) {
53+ char *env = NULL;
54+
55 sigprocmask(SIG_SETMASK, &oldmask, NULL);
56 setuid(geteuid());
57- execl("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
58- "--fake", mnt, NULL);
59+ execle("/bin/umount", "/bin/umount", "--no-canonicalize", "-i",
60+ "--fake", mnt, NULL, &env);
61 fprintf(stderr, "%s: failed to execute /bin/umount: %s\n",
62 progname, strerror(errno));
63 exit(1);
diff --git a/meta-filesystems/recipes-support/fuse/files/fuse.conf b/meta-filesystems/recipes-support/fuse/files/fuse.conf
new file mode 100644
index 000000000..a517c488f
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/files/fuse.conf
@@ -0,0 +1 @@
fuse
diff --git a/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.4.bb
index 2e2f7a198..8cc6dbd16 100644
--- a/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.4.bb
@@ -13,18 +13,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \ 13SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \
14 file://gold-unversioned-symbol.patch \ 14 file://gold-unversioned-symbol.patch \
15 file://aarch64.patch \ 15 file://aarch64.patch \
16 file://001-fix_exec_environment_for_mount_and_umount.patch \ 16 file://0001-fuse-fix-the-return-value-of-help-option.patch \
17 file://fuse.conf \
17" 18"
18SRC_URI[md5sum] = "33cae22ca50311446400daf8a6255c6a" 19SRC_URI[md5sum] = "ecb712b5ffc6dffd54f4a405c9b372d8"
19SRC_URI[sha256sum] = "0beb83eaf2c5e50730fc553406ef124d77bc02c64854631bdfc86bfd6437391c" 20SRC_URI[sha256sum] = "6be9c0bff6af8c677414935f31699ea5a7f8f5f791cfa5205be02ea186b97ce1"
20 21
21inherit autotools pkgconfig 22inherit autotools pkgconfig update-rc.d systemd
23
24INITSCRIPT_NAME = "fuse"
25
26SYSTEMD_SERVICE_${PN} = ""
22 27
23DEPENDS = "gettext-native" 28DEPENDS = "gettext-native"
24 29
25PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg" 30PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
26 31
27RRECOMMENDS_${PN} = "kernel-module-fuse" 32# Fusermount requires features from the util-linux version of mount.
33RDEPENDS_${PN} += "util-linux-mount"
34
35RRECOMMENDS_${PN} = "kernel-module-fuse libulockmgr fuse-utils"
28 36
29FILES_${PN} += "${libdir}/libfuse.so.*" 37FILES_${PN} += "${libdir}/libfuse.so.*"
30FILES_${PN}-dev += "${libdir}/libfuse*.la" 38FILES_${PN}-dev += "${libdir}/libfuse*.la"
@@ -41,4 +49,16 @@ DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
41 49
42do_install_append() { 50do_install_append() {
43 rm -rf ${D}${base_prefix}/dev 51 rm -rf ${D}${base_prefix}/dev
52
53 # systemd class remove the sysv_initddir only if systemd_system_unitdir
54 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
55 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then
56 rm -rf ${D}${sysconfdir}/init.d/
57 fi
58
59 # Install systemd related configuration file
60 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
61 install -d ${D}${sysconfdir}/modules-load.d
62 install -m 0644 ${WORKDIR}/fuse.conf ${D}${sysconfdir}/modules-load.d
63 fi
44} 64}