summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorQian Lei <qianl.fnst@cn.fujitsu.com>2014-12-17 17:03:29 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:58 +0100
commit617e044564caf90bf9c8cff19ded4eca3cda6c5c (patch)
tree943b739eb1116168add44160b1c61bb6687a4fb0 /meta-filesystems
parent935eb8fa8dc9172965ed01eaf001548b1d510fc0 (diff)
downloadmeta-openembedded-617e044564caf90bf9c8cff19ded4eca3cda6c5c.tar.gz
logfsprogs: Add new recipe
LogFS is a Linux log-structured and scalable flash file system, intended for use on large devices of flash memory. Logfsprogs is used to create LogFS file system. Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/logfsprogs/logfsprogs_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/logfsprogs/logfsprogs_git.bb b/meta-filesystems/recipes-filesystems/logfsprogs/logfsprogs_git.bb
new file mode 100644
index 000000000..32ebec83d
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/logfsprogs/logfsprogs_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "LogFS Programs: used to create LogFS file system"
2DESCRIPTION = "\
3LogFS is a Linux log-structured and scalable flash file system, intended \
4for use on large devices of flash memory. It is written by Jörn Engel and \
5in part sponsored by the CE Linux Forum. \
6LogFS is included in the mainline Linux kernel and was introduced in \
7version 2.6.34, released on May 16, 2010."
8HOMEPAGE = "https://github.com/prasad-joshi/logfsprogs"
9SECTION = "base"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://fsck.c;md5=3859dc73da97909ff1d0125e88a27e02"
12DEPENDS = "zlib"
13
14SRC_URI = "git://github.com/prasad-joshi/logfsprogs.git"
15SRCREV = "45b72c81ce3c6fa17ca19bafc207ea93e76312f4"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = "CC="${CC}" LD="${LD}" AR="${AR}""
20
21do_install () {
22 mkdir -p ${D}${bindir}
23 install -m 0755 ${S}/mklogfs ${D}${bindir}/mklogfs
24}
25
26BBCLASSEXTEND = "native nativesdk"