summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-01 22:05:27 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-01 23:20:22 -0700
commitedf94a6e8dd8d5c6942790488a501e0e4c628b20 (patch)
treeaa26fa1a69ca6731b96e9338e62d04dd27b9be64 /meta-filesystems
parentfe62e64c973730da0e385ddbbab8cdc3217e0e69 (diff)
downloadmeta-openembedded-edf94a6e8dd8d5c6942790488a501e0e4c628b20.tar.gz
httpfs2: Do not use S during compile/install tasks
Point to SOURCEFORGE_MIRROR instead of hardcoding one Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
index 0086551f6..5dc3ea663 100644
--- a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
+++ b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
@@ -8,18 +8,15 @@ inherit pkgconfig
8DEPENDS += "fuse" 8DEPENDS += "fuse"
9RDEPENDS:${PN} += "fuse" 9RDEPENDS:${PN} += "fuse"
10 10
11SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz" 11SRC_URI += "${SOURCEFORGE_MIRROR}/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
12SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1" 12SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
13 13
14S = "${WORKDIR}/httpfs2-${PV}" 14S = "${WORKDIR}/httpfs2-${PV}"
15 15
16do_compile() { 16do_compile() {
17 cd ${S} 17 oe_runmake -C ${S} httpfs2
18 oe_runmake httpfs2
19} 18}
20 19
21do_install() { 20do_install() {
22 cd ${S} 21 install -Dm 0755 ${S}/httpfs2 ${D}${bindir}/httpfs2
23 install -d ${D}${bindir}
24 install -m 0755 httpfs2 ${D}${bindir}
25} 22}