diff options
author | Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> | 2022-05-29 10:40:50 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-29 06:39:14 -0700 |
commit | 59ae457c38eeb830f617d1ce55f3879f37c07bc5 (patch) | |
tree | 2de5faaf5aaca77f7d76db66f78c6394271f2b90 /meta-filesystems | |
parent | 397f4f054fd3600f7305055c724607973f5f5511 (diff) | |
download | meta-openembedded-59ae457c38eeb830f617d1ce55f3879f37c07bc5.tar.gz |
xfstests: add new recipe
File system QA test suite
Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r-- | meta-filesystems/recipes-utils/xfstests/xfstests_git.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_git.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_git.bb new file mode 100644 index 000000000..868fa0330 --- /dev/null +++ b/meta-filesystems/recipes-utils/xfstests/xfstests_git.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "File system QA test suite" | ||
2 | LICENSE = "GPL-2.0-only" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038" | ||
4 | |||
5 | SRCREV_FORMAT = "xfstests_unionmount" | ||
6 | |||
7 | SRC_URI = "\ | ||
8 | git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \ | ||
9 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ | ||
10 | " | ||
11 | |||
12 | SRCREV_xfstests = "37881397f1aa62df3c63468049c80b301b0e89eb" | ||
13 | SRCREV_unionmount = "cec4c51a3bf8ba80bb99fc74b302749d4e3d2f1d" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit autotools-brokensep useradd | ||
18 | |||
19 | DEPENDS += "xfsprogs acl" | ||
20 | RDEPENDS:${PN} += "\ | ||
21 | bash \ | ||
22 | bc \ | ||
23 | coreutils \ | ||
24 | e2fsprogs \ | ||
25 | e2fsprogs-tune2fs \ | ||
26 | e2fsprogs-resize2fs \ | ||
27 | libcap-bin \ | ||
28 | overlayfs-progs \ | ||
29 | perl \ | ||
30 | python3 \ | ||
31 | python3-core \ | ||
32 | xfsprogs \ | ||
33 | acl \ | ||
34 | " | ||
35 | |||
36 | USERADD_PACKAGES = "${PN}" | ||
37 | # these users are necessary to run the tests | ||
38 | USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2" | ||
39 | |||
40 | EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root" | ||
41 | |||
42 | # install-sh script in the project is outdated | ||
43 | # we use the one from the latest libtool to solve installation issues | ||
44 | # It looks like the upstream is not interested in having it fixed :( | ||
45 | # https://www.spinics.net/lists/fstests/msg16981.html | ||
46 | do_configure:prepend() { | ||
47 | cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B} | ||
48 | } | ||
49 | |||
50 | do_install:append() { | ||
51 | unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite | ||
52 | install -d ${D}/usr/xfstests/unionmount-testsuite/tests | ||
53 | install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests | ||
54 | install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir | ||
55 | install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir | ||
56 | install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir | ||
57 | } | ||
58 | |||
59 | FILES:${PN} += "\ | ||
60 | /usr/xfstests \ | ||
61 | " | ||