summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-01-21 07:22:31 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit3272db6afe936eea457153502ce2d76a286413ef (patch)
tree2ea472ddde4e18df01c53ca92223f30d898a1268 /meta-filesystems
parenta804b0c1bbdc3273a41fbd4aeb5cc3b7d1ffc6b5 (diff)
downloadmeta-openembedded-3272db6afe936eea457153502ce2d76a286413ef.tar.gz
fatcat: Add recipe
fatcat is a tool designed to manipulate FAT filesystems, in order to explore, extract, repair, recover and forensic them. It currently supports FAT12, FAT16 and FAT32. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/fatcat/fatcat/0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch37
-rw-r--r--meta-filesystems/recipes-utils/fatcat/fatcat_1.1.0.bb18
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/fatcat/fatcat/0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch b/meta-filesystems/recipes-utils/fatcat/fatcat/0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch
new file mode 100644
index 000000000..fd8e22abc
--- /dev/null
+++ b/meta-filesystems/recipes-utils/fatcat/fatcat/0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch
@@ -0,0 +1,37 @@
1From 14ef83291096e019ebc48040cf63530a2574a26d Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Sun, 19 Jan 2020 16:03:21 +0000
4Subject: [PATCH] Use unistd.h not argp.h for all POSIX systems
5
6getopt(3) is found in unistd.h on all POSIX systems and we make no use
7of any of the GNU specific argp extensions. Include unistd.h directly to
8allow building with musl on linux, whilst retaining compatibility with
9glibc and other unices.
10
11Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
12Upstream-status: Pending
13---
14 src/fatcat.cpp | 8 ++------
15 1 file changed, 2 insertions(+), 6 deletions(-)
16
17diff --git a/src/fatcat.cpp b/src/fatcat.cpp
18index ce23ca07bb99..b4427e465bde 100644
19--- a/src/fatcat.cpp
20+++ b/src/fatcat.cpp
21@@ -1,14 +1,10 @@
22 #include <stdlib.h>
23-#include<string.h>
24-#ifdef __APPLE__
25-#include <unistd.h>
26-#else
27+#include <string.h>
28 #ifdef __WIN__
29 #include <ctype.h>
30 #include "xgetopt/xgetopt.h"
31 #else
32-#include <argp.h>
33-#endif
34+#include <unistd.h>
35 #endif
36
37 #include <stdio.h>
diff --git a/meta-filesystems/recipes-utils/fatcat/fatcat_1.1.0.bb b/meta-filesystems/recipes-utils/fatcat/fatcat_1.1.0.bb
new file mode 100644
index 000000000..c72671739
--- /dev/null
+++ b/meta-filesystems/recipes-utils/fatcat/fatcat_1.1.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "FAT filesystems explore, extract, repair, and forensic tool"
2DESCRIPTION = "This tool is designed to manipulate FAT filesystems, in order to \
3explore, extract, repair, recover and forensic them. It currently supports \
4FAT12, FAT16 and FAT32."
5HOMEPAGE = "https://github.com/Gregwar/fatcat"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=57fbbfebd0dd1d6ff21b8cecb552a03f"
9
10SRC_URI = "git://github.com/Gregwar/fatcat.git \
11 file://0001-Use-unistd.h-not-argp.h-for-all-POSIX-systems.patch \
12 "
13
14SRCREV = "b923172d97c578297964c062e3a92799e2a9eca4"
15
16S = "${WORKDIR}/git"
17
18inherit cmake