summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-13 08:32:22 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:08 -0700
commit29de5fbc5e0f61033f9a4f145b3494edc7d3c58c (patch)
tree8df9d0193ac91d1046dff8d7271e945746e3c2fe /meta-filesystems
parent620ef0206fecb1a8e990fced8618ac4ef0b0c79d (diff)
downloadmeta-openembedded-29de5fbc5e0f61033f9a4f145b3494edc7d3c58c.tar.gz
owfs: Fix build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch44
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch b/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch
new file mode 100644
index 000000000..6426ecb24
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch
@@ -0,0 +1,44 @@
1From a812202d22a2861318b8e39f1cd74cd222f8e76f Mon Sep 17 00:00:00 2001
2From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
3Date: Tue, 9 Jun 2020 11:30:38 +0300
4Subject: [PATCH] Fix compilation with GCC10
5
6Fixed compilation with -fno-common, which enabled in GCC 10 by default.
7See https://bugs.gentoo.org/707438.
8
9Upstream-Status: Backport [https://github.com/owfs/owfs/pull/62]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 module/owserver/src/c/owserver.c | 2 ++
13 module/owserver/src/include/owserver.h | 2 +-
14 2 files changed, 3 insertions(+), 1 deletion(-)
15
16diff --git a/module/owserver/src/c/owserver.c b/module/owserver/src/c/owserver.c
17index db29988e..2ed29161 100644
18--- a/module/owserver/src/c/owserver.c
19+++ b/module/owserver/src/c/owserver.c
20@@ -36,6 +36,8 @@
21
22 #include "owserver.h"
23
24+pthread_mutex_t persistence_mutex ;
25+
26 /* --- Prototypes ------------ */
27 static void SetupAntiloop(int argc, char **argv);
28
29diff --git a/module/owserver/src/include/owserver.h b/module/owserver/src/include/owserver.h
30index 8be582f0..a257ed02 100644
31--- a/module/owserver/src/include/owserver.h
32+++ b/module/owserver/src/include/owserver.h
33@@ -18,7 +18,7 @@
34 #include "ow.h"
35 #include "ow_connection.h"
36
37-pthread_mutex_t persistence_mutex ;
38+extern pthread_mutex_t persistence_mutex ;
39 #define PERSISTENCELOCK _MUTEX_LOCK( persistence_mutex ) ;
40 #define PERSISTENCEUNLOCK _MUTEX_UNLOCK( persistence_mutex ) ;
41
42--
432.28.0
44
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
index 414084449..7f56c88fc 100644
--- a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
@@ -12,6 +12,7 @@ DEPENDS = "fuse virtual/libusb0"
12SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47" 12SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47"
13SRC_URI = "git://github.com/owfs/owfs \ 13SRC_URI = "git://github.com/owfs/owfs \
14 file://0001-Add-build-rule-for-README.patch \ 14 file://0001-Add-build-rule-for-README.patch \
15 file://0001-Fix-compilation-with-GCC10.patch \
15 file://owhttpd \ 16 file://owhttpd \
16 file://owserver \ 17 file://owserver \
17 " 18 "