summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:31:01 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commiteefdbbec6c9c176ac6060ec33303b45660fd4e32 (patch)
tree445a149466547c56a7aee245d6be77033c550591 /meta-filesystems
parent6a13d57d0da17ee36749b9d98f745e10dfe26c27 (diff)
downloadmeta-openembedded-eefdbbec6c9c176ac6060ec33303b45660fd4e32.tar.gz
xfsprogs: move to meta-filesystems and upgrade
- Move xfsprogs from meta-oe to meta-filesystems - Upgrade xfsprogs to 3.1.11 [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch93
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch205
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb56
3 files changed, 354 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch b/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch
new file mode 100644
index 000000000..760109506
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/files/drop-configure-check-for-aio.patch
@@ -0,0 +1,93 @@
1xfsprogs: drop configure check for aio
2
3It's unused and breaks compilation with uclibc.
4
5Upstream-Status: Pending
6Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
7---
8 configure.ac | 6 +++---
9 m4/Makefile | 1 -
10 m4/package_aiodev.m4 | 36 ------------------------------------
11 3 files changed, 3 insertions(+), 40 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index b968977..4e2a263 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -47,6 +47,9 @@ AC_ARG_ENABLE(lib64,
18 enable_lib64=yes)
19 AC_SUBST(enable_lib64)
20
21+librt="-lrt"
22+AC_SUBST(librt)
23+
24 #
25 # If the user specified a libdir ending in lib64 do not append another
26 # 64 to the library names.
27@@ -92,9 +95,6 @@ AC_PACKAGE_GLOBALS(xfsprogs)
28 AC_PACKAGE_UTILITIES(xfsprogs)
29 AC_MULTILIB($enable_lib64)
30
31-AC_PACKAGE_NEED_AIO_H
32-AC_PACKAGE_NEED_LIO_LISTIO
33-
34 AC_PACKAGE_NEED_UUID_H
35 AC_PACKAGE_NEED_UUIDCOMPARE
36
37diff --git a/m4/Makefile b/m4/Makefile
38index 654a4fb..d282f0a 100644
39--- a/m4/Makefile
40+++ b/m4/Makefile
41@@ -14,7 +14,6 @@ CONFIGURE = \
42
43 LSRCFILES = \
44 manual_format.m4 \
45- package_aiodev.m4 \
46 package_blkid.m4 \
47 package_globals.m4 \
48 package_libcdev.m4 \
49diff --git a/m4/package_aiodev.m4 b/m4/package_aiodev.m4
50index 490d9c8..8b13789 100644
51--- a/m4/package_aiodev.m4
52+++ b/m4/package_aiodev.m4
53@@ -1,37 +1 @@
54-#
55-# Check if we have a libaio.h installed
56-#
57-AC_DEFUN([AC_PACKAGE_WANT_AIO],
58- [ AC_CHECK_HEADERS(libaio.h, [ have_aio=true ], [ have_aio=false ])
59- AC_SUBST(have_aio)
60- ])
61-
62-#
63-# Check if we have an aio.h installed
64-#
65-AC_DEFUN([AC_PACKAGE_NEED_AIO_H],
66- [ AC_CHECK_HEADERS(aio.h)
67- if test $ac_cv_header_aio_h = no; then
68- echo
69- echo 'FATAL ERROR: could not find a valid <aio.h> header.'
70- exit 1
71- fi
72- ])
73-
74-#
75-# Check if we have the lio_listio routine in either libc/librt
76-#
77-AC_DEFUN([AC_PACKAGE_NEED_LIO_LISTIO],
78- [ AC_CHECK_FUNCS(lio_listio)
79- if test $ac_cv_func_lio_listio = yes; then
80- librt=""
81- else
82- AC_CHECK_LIB(rt, lio_listio,, [
83- echo
84- echo 'FATAL ERROR: could not find a library with lio_listio.'
85- exit 1],[-lpthread])
86- librt="-lrt"
87- fi
88- AC_SUBST(librt)
89- ])
90
91--
921.8.1.2
93
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch b/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch
new file mode 100644
index 000000000..e761db371
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/files/remove-install-as-user.patch
@@ -0,0 +1,205 @@
1remove install as user
2
3Upstream-Status: Inappropriate [configuration]
4
5Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
6---
7 include/buildmacros | 2 +-
8 include/install-sh | 95 ++++++++---------------------------------------------
9 2 files changed, 14 insertions(+), 83 deletions(-)
10
11diff --git a/include/buildmacros b/include/buildmacros
12index 7a01880..0840d55 100644
13--- a/include/buildmacros
14+++ b/include/buildmacros
15@@ -30,7 +30,7 @@ OBJECTS = $(ASFILES:.s=.o) \
16 $(LFILES:.l=.o) \
17 $(YFILES:%.y=%.tab.o)
18
19-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
20+INSTALL = $(TOPDIR)/install-sh
21
22 IMAGES_DIR = $(TOPDIR)/all-images
23 DIST_DIR = $(TOPDIR)/dist
24diff --git a/include/install-sh b/include/install-sh
25index c952a71..b9d66f7 100755
26--- a/include/install-sh
27+++ b/include/install-sh
28@@ -24,11 +24,11 @@
29 # set set | yes yes
30 #
31 _usage() {
32- echo "Usage: $prog [-o owner] [-g group] [-m mode] -d directory"
33- echo "or $prog [-D] [-o owner] [-g group] [-m mode] file directory/file"
34- echo "or $prog [-o owner] [-g group] [-m mode] file [file ...] directory"
35+ echo "Usage: $prog [-m mode] -d directory"
36+ echo "or $prog [-m mode] file directory/file"
37+ echo "or $prog [-m mode] file [file ...] directory"
38 echo "or $prog -S file target (creates \"target\" symlink)"
39- echo "or $prog -T lt_arg [-o owner] [-g group] [-m mode] libtool.lai directory"
40+ echo "or $prog -T lt_arg [-m mode] libtool.lai directory"
41 echo ""
42 echo "The \$DIST_MANIFEST and \$DIST_ROOT environment variables affect the"
43 echo "behaviour of this command - see comments in the script."
44@@ -38,32 +38,6 @@ _usage() {
45 exit 1
46 }
47
48-_chown ()
49-{
50- _st=255
51- if [ $# -eq 3 ] ; then
52- chown $1:$2 $3
53- _st=$?
54- if [ $_st -ne 0 ] ; then
55- if [ $REAL_UID != '0' ] ; then
56- if [ ! -f $DIST_ROOT/.chown.quiet ] ; then
57- echo '==============================================='
58- echo Ownership of files under ${DIST_ROOT:-/}
59- echo cannot be changed
60- echo '==============================================='
61- if [ -n "$DIST_ROOT" ] ; then
62- touch $DIST_ROOT/.chown.quiet
63- fi
64- fi
65- _st=0
66- fi
67- fi
68- fi
69-
70- return $_st
71-}
72-
73-
74 _manifest ()
75 {
76 echo $* | sed -e 's/\/\//\//g' >>${DIST_MANIFEST:-/dev/null}
77@@ -77,9 +51,6 @@ Sflag=false
78 Tflag=false
79 DIRMODE=755
80 FILEMODE=644
81-OWNER=`id -u`
82-GROUP=`id -g`
83-REAL_UID=$OWNER
84
85 # default is to install and don't append manifest
86 INSTALL=true
87@@ -94,24 +65,16 @@ MANIFEST=:
88
89 if $INSTALL
90 then
91- CP=cp; LN=ln; MKDIR=mkdir; CHMOD=chmod; CHOWN=_chown
92+ CP=cp; LN=ln; MKDIR=mkdir; CHMOD=chmod;
93 else
94- CP=true; LN=true; MKDIR=true; CHMOD=true; CHOWN=true
95+ CP=true; LN=true; MKDIR=true; CHMOD=true;
96 fi
97
98-[ -n "$DIST_ROOT" -a $REAL_UID -ne 0 ] && CHOWN=true
99-
100-while getopts "Dcm:d:S:o:g:T:" c $*
101+while getopts "Dcm:d:S:T:" c $*
102 do
103 case $c in
104 c)
105 ;;
106- g)
107- GROUP=$OPTARG
108- ;;
109- o)
110- OWNER=$OPTARG
111- ;;
112 m)
113 DIRMODE=`expr $OPTARG`
114 FILEMODE=$DIRMODE
115@@ -146,18 +109,7 @@ then
116 # first usage
117 #
118 $MKDIR -p $dir
119- status=$?
120- if [ $status -eq 0 ]
121- then
122- $CHMOD $DIRMODE $dir
123- status=$?
124- fi
125- if [ $status -eq 0 ]
126- then
127- $CHOWN $OWNER $GROUP $dir
128- status=$?
129- fi
130- $MANIFEST d $DIRMODE $OWNER $GROUP ${dir#$DIST_ROOT}
131+ $MANIFEST d $DIRMODE ${dir#$DIST_ROOT}
132 elif $Sflag
133 then
134 #
135@@ -203,7 +155,7 @@ then
136 install_name=$target/$solib
137 $CP $solib $install_name
138 status=$?
139- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$solib ${install_name#$DIST_ROOT}
140+ $MANIFEST f $FILEMODE $HERE/$solib ${install_name#$DIST_ROOT}
141 break
142 fi
143 done
144@@ -254,7 +206,7 @@ then
145 install_name=$target/$old_library
146 $CP $old_library $install_name
147 status=$?
148- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$old_library ${install_name#$DIST_ROOT}
149+ $MANIFEST f $FILEMODE $HERE/$old_library ${install_name#$DIST_ROOT}
150 ;;
151 *)
152 echo "$prog: -T $lt_install invalid"
153@@ -267,7 +219,6 @@ then
154 if [ $status -eq 0 ]
155 then
156 $CHMOD $FILEMODE $install_name
157- $CHOWN $OWNER $GROUP $install_name
158 fi
159 ;;
160 esac
161@@ -292,23 +243,10 @@ else
162 then
163 if [ -f $dir/$f ]
164 then
165- $CHMOD $FILEMODE $dir/$f
166- status=$?
167- if [ $status -eq 0 ]
168- then
169- $CHOWN $OWNER $GROUP $dir/$f
170- status=$?
171- fi
172- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$f ${dir#$DIST_ROOT}/$f
173+ $MANIFEST f $FILEMODE $HERE/$f ${dir#$DIST_ROOT}/$f
174 else
175 $CHMOD $FILEMODE $dir
176- status=$?
177- if [ $status -eq 0 ]
178- then
179- $CHOWN $OWNER $GROUP $dir
180- status=$?
181- fi
182- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$dir ${dir#$DIST_ROOT}
183+ $MANIFEST f $FILEMODE $HERE/$dir ${dir#$DIST_ROOT}
184 fi
185 fi
186 else
187@@ -334,14 +272,7 @@ else
188 status=$?
189 if [ $status -eq 0 ]
190 then
191- $CHMOD $FILEMODE $dir/$f
192- status=$?
193- if [ $status -eq 0 ]
194- then
195- $CHOWN $OWNER $GROUP $dir/$f
196- status=$?
197- fi
198- $MANIFEST f $FILEMODE $OWNER $GROUP $HERE/$f ${dir#$DIST_ROOT}/$f
199+ $MANIFEST f $FILEMODE $HERE/$f ${dir#$DIST_ROOT}/$f
200 fi
201 [ $status -ne 0 ] && break
202 done
203--
2041.8.1.2
205
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
new file mode 100644
index 000000000..ceb0ddf16
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
@@ -0,0 +1,56 @@
1DESCRIPTION = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
7DEPENDS = "util-linux"
8
9SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz \
10 file://remove-install-as-user.patch \
11 file://drop-configure-check-for-aio.patch \
12"
13
14SRC_URI[md5sum] = "de9f1f45026c2f4e0776058d429ff4b6"
15SRC_URI[sha256sum] = "adf4980177b5c890c1ca86b9c0e3e4d69a3f95bfc01746844280c2393cf4d6be"
16
17inherit autotools
18
19PACKAGES =+ "${PN}-fsck ${PN}-mkfs libhandle"
20
21RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs"
22
23FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
24FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
25FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
26
27EXTRA_OECONF = "--enable-gettext=no"
28do_configure () {
29 # Prevent Makefile from calling configure without arguments,
30 # when do_configure gets called for a second time.
31 rm -f include/builddefs include/platform_defs.h
32 # Recreate configure script.
33 rm -f configure
34 oe_runmake configure
35 # Configure.
36 export DEBUG="-DNDEBUG"
37 gnu-configize --force
38 oe_runconf
39}
40
41LIBTOOL = "${HOST_SYS}-libtool"
42EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
43TARGET_CC_ARCH += "${LDFLAGS}"
44PARALLEL_MAKE = ""
45
46do_install () {
47 export DIST_ROOT=${D}
48 oe_runmake install
49 # needed for xfsdump
50 oe_runmake install-dev
51 rm ${D}${base_libdir}/libhandle.a
52 rm ${D}${base_libdir}/libhandle.la
53 rm ${D}${base_libdir}/libhandle.so
54 rm ${D}${libdir}/libhandle.so
55 ln -s ../..${base_libdir}/libhandle.so.1 ${D}${libdir}/libhandle.so
56}