summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:30:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commit893b425a9a0e431f78edd8540a187e3386d8fb06 (patch)
tree5a6974cc903999c350af719bc45f228c5f693d22 /meta-filesystems
parent1f0a8aed7871a171bd67392efcfaa829d1073e60 (diff)
downloadmeta-openembedded-893b425a9a0e431f78edd8540a187e3386d8fb06.tar.gz
meta-filesystems creation
This layer contains filesystem related recipes. [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/COPYING.MIT17
-rw-r--r--meta-filesystems/README138
-rw-r--r--meta-filesystems/conf/layer.conf10
3 files changed, 165 insertions, 0 deletions
diff --git a/meta-filesystems/COPYING.MIT b/meta-filesystems/COPYING.MIT
new file mode 100644
index 000000000..89de35479
--- /dev/null
+++ b/meta-filesystems/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-filesystems/README b/meta-filesystems/README
new file mode 100644
index 000000000..d2716f8f1
--- /dev/null
+++ b/meta-filesystems/README
@@ -0,0 +1,138 @@
1This README file contains information on the contents of the
2filesystems layer.
3
4Please see the corresponding sections below for details.
5
6
7Dependencies
8============
9
10This layer depends on:
11
12 URI: git://git.openembedded.org/bitbake
13 branch: master
14
15 URI: git://git.openembedded.org/openembedded-core
16 layers: meta
17 branch: master
18
19 URI: git://git.openembedded.org/meta-openembedded
20 layers: meta-oe
21 branch: master
22
23Patches
24=======
25
26Please submit any patches against the filesystems layer to the
27OpenEmbedded development mailing list (openembedded-devel@lists.openembedded.org)
28with '[meta-filesystems]' in the subject.
29
30Maintainers List:
31 physfs Andreas Müller <schnitzeltony@googlemail.com>
32
33 fuse Koen Kooi <koen@dominion.thruhere.net>
34 Philip Balister <philip@balister.org>
35 hongxu jia <hongxu.jia@windriver.com>
36
37 ifuse Sander van Grieken <sander@outrightsolutions.nl>
38 Koen Kooi <koen@dominion.thruhere.net>
39
40 sshfs-fuse Philip Balister <philip@balister.org>
41 Koen Kooi <koen@dominion.thruhere.net>
42
43 owfs Otavio Salvador <otavio@ossystems.com.br>
44 Koen Kooi <koen@dominion.thruhere.net>
45 hongxu jia <hongxu.jia@windriver.com>
46
47 ntfs-3g-ntfsprogs Otavio Salvador <otavio@ossystems.com.br>
48 hongxu jia <hongxu.jia@windriver.com>
49
50 cramfs Koen Kooi <koen@dominion.thruhere.net>
51
52 smbnetfs Sander van Grieken <sander@outrightsolutions.nl>
53 Koen Kooi <koen@dominion.thruhere.net>
54
55 fuse-exfat hongxu jia <hongxu.jia@windriver.com>
56
57 exfat-utils hongxu jia <hongxu.jia@windriver.com>
58
59 f2fs-tools Martin Jansa <Martin.Jansa@gmail.com>
60 Koen Kooi <koen@dominion.thruhere.net>
61
62 xfsprogs Koen Kooi <koen@dominion.thruhere.net>
63 hongxu jia <hongxu.jia@windriver.com>
64
65When sending single patches, please use something like:
66
67 git send-email -1 -M \
68 --to openembedded-devel@lists.openembedded.org \
69 --subject-prefix=meta-filesystems][PATCH
70
71
72Table of Contents
73=================
74
75 I. Adding the filesystems layer to your build
76 II. Misc
77
78
79I. Adding the filesystems layer to your build
80=================================================
81
82In order to use this layer, you need to make the build system aware of
83it.
84
85Assuming the filesystems layer exists at the top-level of your
86yocto build tree, you can add it to the build system by adding the
87location of the filesystems layer to bblayers.conf, along with any
88other layers needed. e.g.:
89
90 BBLAYERS ?= " \
91 /path/to/yocto/meta \
92 /path/to/yocto/meta-oe \
93 /path/to/yocto/meta-filesystems \
94 "
95
96
97II. Misc
98========
99
100 --- physfs ---
101 A library to provide abstract access to various archives
102
103 --- fuse ---
104 Filesystem in Userspace (FUSE) is a simple interface for userspace programs
105 to export a virtual filesystem to the Linux kernel.
106
107 --- ifuse ---
108 A fuse filesystem to access the contents of an iPhone or iPod Touch
109
110 --- sshfs-fuse ---
111 A filesystem client based on the SSH File Transfer Protocol
112
113 --- owfs ---
114 An easy way to use the 1-Wire file system
115
116 --- ntfs-3g-ntfsprogs ---
117 The ntfs-3g is a freely available read/write NTFS driver for Linux and
118 ntfsprogs includes utilities for doing all required tasks to NTFS partitions.
119
120 --- cramfs ---
121 Builds cramfs filesystems for embedded systems
122
123 --- smbnetfs ---
124 SMBNetFS is a Linux/FreeBSD filesystem that allow you to use samba/microsoft
125 network in the same manner as the network neighborhood in Microsoft Windows.
126
127 --- fuse-exfat ---
128 A read and write exFAT driver for FUSE
129
130 --- exfat-utils ---
131 Utilities to create, check, label and dump exFAT filesystem
132
133 --- f2fs-tools ---
134 Tools needed for creating and managing f2fs partitions
135
136 --- xfsprogs ---
137 It provides XFS filesystem utilities.
138
diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf
new file mode 100644
index 000000000..c0bbd7821
--- /dev/null
+++ b/meta-filesystems/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have recipes-* directories, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "filesystems-layer"
9BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/"
10BBFILE_PRIORITY_filesystems-layer = "6"