summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-14 06:30:59 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:31 +0200
commit6a13d57d0da17ee36749b9d98f745e10dfe26c27 (patch)
tree09660fa05d9ca188d4dc3d5ace35aa87f478dfee /meta-filesystems
parent5972198b0f23ca7a248247b0c8a91e565eaa30c2 (diff)
downloadmeta-openembedded-6a13d57d0da17ee36749b9d98f745e10dfe26c27.tar.gz
owfs: move to meta-filesystems and upgrade
- Move owfs from meta-oe to meta-filesystems - Upgrade owfs to 2.9p1 [YOCTO #4178] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rwxr-xr-xmeta-filesystems/recipes-filesystems/owfs/owfs/owhttpd60
-rwxr-xr-xmeta-filesystems/recipes-filesystems/owfs/owfs/owserver59
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb70
3 files changed, 189 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd b/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd
new file mode 100755
index 000000000..5d74d13d9
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs/owhttpd
@@ -0,0 +1,60 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owhttpd"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWHTTPD" != "yes" ]
16then
17 exit 0
18fi
19
20
21startdaemon(){
22 echo -n "Starting ${DAEMON}: "
23 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
24 echo "done"
25}
26
27stopdaemon(){
28 echo -n "Stopping ${DAEMON}: "
29 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
30 echo "done"
31}
32
33
34
35case "$1" in
36 start)
37 startdaemon
38 ;;
39 stop)
40 stopdaemon
41 ;;
42 force-reload)
43 stopdaemon
44 startdaemon
45 ;;
46 restart)
47 stopdaemon
48 startdaemon
49 ;;
50 reload)
51 stopdaemon
52 startdaemon
53 ;;
54 *)
55 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
56 exit 1
57 ;;
58esac
59
60exit 0
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs/owserver b/meta-filesystems/recipes-filesystems/owfs/owfs/owserver
new file mode 100755
index 000000000..b69ea53e3
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs/owserver
@@ -0,0 +1,59 @@
1#!/bin/sh
2
3PATH=/sbin:/bin:/usr/bin
4
5DAEMON="owserver"
6
7test -f /usr/bin/${DAEMON} || exit 0
8
9if test -f /etc/default/${DAEMON} ; then
10. /etc/default/${DAEMON}
11else
12:
13fi
14
15if [ "$START_OWSERVER" != "yes" ]
16then
17 exit 0
18fi
19
20startdaemon(){
21 echo -n "Starting ${DAEMON}: "
22 start-stop-daemon --start -x /usr/bin/${DAEMON} -- ${CMDLINE} --pid_file /var/run/${DAEMON}.pid
23 echo "done"
24}
25
26stopdaemon(){
27 echo -n "Stopping ${DAEMON}: "
28 start-stop-daemon --stop -p /var/run/${DAEMON}.pid
29 echo "done"
30}
31
32
33
34case "$1" in
35 start)
36 startdaemon
37 ;;
38 stop)
39 stopdaemon
40 ;;
41 force-reload)
42 stopdaemon
43 startdaemon
44 ;;
45 restart)
46 stopdaemon
47 startdaemon
48 ;;
49 reload)
50 stopdaemon
51 startdaemon
52 ;;
53 *)
54 echo "Usage: ${DAEMON} { start | stop | restart | reload }" >&2
55 exit 1
56 ;;
57esac
58
59exit 0
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb b/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb
new file mode 100644
index 000000000..b46940e9b
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs_2.9p1.bb
@@ -0,0 +1,70 @@
1SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2 & LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=a0bc427f423a41220ab79a0b392218bd \
8 file://COPYING.LIB;md5=865c4bd642d9e04f43925ad7e929ae87"
9
10DEPENDS = "fuse virtual/libusb0"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/owfs/owfs-${PV}.tar.gz \
13 file://owhttpd \
14 file://owserver "
15SRC_URI[md5sum] = "56ba145be208002e58775a7203369851"
16SRC_URI[sha256sum] = "9d22dbff72d235476688c02669f7171b23e21dffadf40bbdd3b8263908218424"
17
18inherit autotools update-rc.d
19
20EXTRA_OECONF = " \
21 --with-fuseinclude=${STAGING_INCDIR} \
22 --with-fuselib=${STAGING_LIBDIR} \
23 --enable-owfs \
24 --enable-owhttpd \
25 --enable-cache \
26 --enable-mt \
27 --enable-w1 \
28 --disable-swig \
29 --disable-owtcl \
30 --disable-owphp \
31 --disable-owpython \
32 --disable-owperl \
33"
34
35do_install_prepend() {
36 install -d ${D}${sysconfdir}/default/
37 install -d ${D}${sysconfdir}/init.d/
38 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
39 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
40}
41
42PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
43
44DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
45DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
46DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
47DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
48DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
49DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
50DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
51DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
52DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
53
54FILES_owftpd = "${bindir}/owftpd"
55FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
56FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
57FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
58 ${bindir}/owdir ${bindir}/owpresent \
59 ${bindir}/owget ${bindir}/owside"
60FILES_owmon = "${bindir}/owmon"
61FILES_owtap = "${bindir}/owtap"
62FILES_libowcapi = "${libdir}/libowcapi-*"
63FILES_libow = "${libdir}/libow-*"
64FILES_libownet = "${libdir}/libownet-*"
65
66INITSCRIPT_PACKAGES = "owhttpd owserver"
67INITSCRIPT_NAME_owserver = "owserver"
68INITSCRIPT_NAME_owhttpd = "owhttpd"
69INITSCRIPT_PARAMS_owserver = "defaults 20"
70INITSCRIPT_PARAMS_owhttpd = "defaults 21"