diff options
author | Changqing Li <changqing.li@windriver.com> | 2019-08-30 15:06:46 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-30 06:45:52 -0700 |
commit | 0433f28ee975eb4637b51ac16fc6751fae19634e (patch) | |
tree | 6577c4161ab27dacabd9857c131b76bd6b29ba8e /meta-filesystems/recipes-utils | |
parent | 2c67dcf650e3d778cce86ce8296342bdfd26c428 (diff) | |
download | meta-openembedded-0433f28ee975eb4637b51ac16fc6751fae19634e.tar.gz |
xfsprogs: support usrmerge
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils')
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/files/0001-support-usrmerge.patch | 40 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb | 7 |
2 files changed, 45 insertions, 2 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/0001-support-usrmerge.patch b/meta-filesystems/recipes-utils/xfsprogs/files/0001-support-usrmerge.patch new file mode 100644 index 000000000..84f4f88e5 --- /dev/null +++ b/meta-filesystems/recipes-utils/xfsprogs/files/0001-support-usrmerge.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From e81633a276dd6a9f919e5e5c15481ac50a8e485d Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Fri, 30 Aug 2019 14:59:06 +0800 | ||
4 | Subject: [PATCH] support usrmerge | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe-specific] | ||
7 | |||
8 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
9 | --- | ||
10 | configure.ac | 7 +++---- | ||
11 | 1 file changed, 3 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/configure.ac b/configure.ac | ||
14 | index 4b7e4c8..f1afbd6 100644 | ||
15 | --- a/configure.ac | ||
16 | +++ b/configure.ac | ||
17 | @@ -110,8 +110,7 @@ AC_ARG_ENABLE(libicu, | ||
18 | # If the user specified a libdir ending in lib64 do not append another | ||
19 | # 64 to the library names. | ||
20 | # | ||
21 | -base_libdir=`basename "$libdir"` | ||
22 | -case $base_libdir in | ||
23 | +case `basename "$libdir"` in | ||
24 | lib64) | ||
25 | enable_lib64=no | ||
26 | esac | ||
27 | @@ -125,8 +124,8 @@ esac | ||
28 | # | ||
29 | case $exec_prefix:$prefix in | ||
30 | NONE:NONE | NONE:/usr | /usr:*) | ||
31 | - root_sbindir='/sbin' | ||
32 | - root_libdir="/${base_libdir}" | ||
33 | + root_sbindir="${base_sbindir}" | ||
34 | + root_libdir="${base_libdir}" | ||
35 | ;; | ||
36 | *) | ||
37 | root_sbindir="${sbindir}" | ||
38 | -- | ||
39 | 2.7.4 | ||
40 | |||
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb index bed80a615..5ab1d028f 100644 --- a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb +++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ | |||
11 | file://0001-build-Check-for-sync_file_range-libc-function.patch \ | 11 | file://0001-build-Check-for-sync_file_range-libc-function.patch \ |
12 | file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \ | 12 | file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \ |
13 | file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \ | 13 | file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \ |
14 | file://0001-support-usrmerge.patch \ | ||
14 | " | 15 | " |
15 | SRC_URI[md5sum] = "5ca3f79e76e3fb984a03d1b42a2e60ba" | 16 | SRC_URI[md5sum] = "5ca3f79e76e3fb984a03d1b42a2e60ba" |
16 | SRC_URI[sha256sum] = "7b500e148cebd08f99e37cf744c7843817b37e7be2a32c4dc57d6ea16e3019ae" | 17 | SRC_URI[sha256sum] = "7b500e148cebd08f99e37cf744c7843817b37e7be2a32c4dc57d6ea16e3019ae" |
@@ -68,6 +69,8 @@ do_install_append() { | |||
68 | rm ${D}${libdir}/*.la | 69 | rm ${D}${libdir}/*.la |
69 | rmdir --ignore-fail-on-non-empty ${D}${libdir} | 70 | rmdir --ignore-fail-on-non-empty ${D}${libdir} |
70 | 71 | ||
71 | ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a | 72 | if [ ${libdir} != ${base_libdir} ];then |
72 | ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so | 73 | ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a |
74 | ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so | ||
75 | fi | ||
73 | } | 76 | } |