diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-19 23:47:00 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-22 16:04:14 +0200 |
commit | 11d98126c99a36c637ba9af01b0f888169f10550 (patch) | |
tree | b96c5a3187e934eb4869484957d5fabbee266ec9 /meta-filesystems/recipes-utils | |
parent | 67a13d6e9248073ccd8f6debfd5162ef0169e827 (diff) | |
download | meta-openembedded-11d98126c99a36c637ba9af01b0f888169f10550.tar.gz |
xfsprogs: Remove .la files in ${libdir}
Delete .la files and remove ${libdir} if empty
Fix build with musl
Use --ignore-fail-on-non-empty with rmdir
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils')
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch | 58 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb | 5 |
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch b/meta-filesystems/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch new file mode 100644 index 000000000..951a1442c --- /dev/null +++ b/meta-filesystems/recipes-utils/xfsprogs/files/0001-define-__-prefixed-version-of-intXY_t-types.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 2b4714123cdecb558babb76074d0ab945bf5b177 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 16 Jun 2017 18:59:10 -0700 | ||
4 | Subject: [PATCH] define __ prefixed version of intXY_t types | ||
5 | |||
6 | This is required since musl does not define them | ||
7 | unlike glibc | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | include/linux.h | 29 +++++++++++++++++++++++++++++ | ||
14 | 1 file changed, 29 insertions(+) | ||
15 | |||
16 | diff --git a/include/linux.h b/include/linux.h | ||
17 | index 6a676ca..6976d83 100644 | ||
18 | --- a/include/linux.h | ||
19 | +++ b/include/linux.h | ||
20 | @@ -40,6 +40,35 @@ | ||
21 | # undef fsxattr | ||
22 | #endif | ||
23 | |||
24 | +#ifndef loff_t | ||
25 | +#define loff_t off_t | ||
26 | +#endif | ||
27 | +#ifndef __uint8_t | ||
28 | +#define __uint8_t uint8_t | ||
29 | +#endif | ||
30 | +#ifndef __uint16_t | ||
31 | +#define __uint16_t uint16_t | ||
32 | +#endif | ||
33 | +#ifndef __uint32_t | ||
34 | +#define __uint32_t uint32_t | ||
35 | +#endif | ||
36 | +#ifndef __uint64_t | ||
37 | +#define __uint64_t uint64_t | ||
38 | +#endif | ||
39 | + | ||
40 | +#ifndef __int8_t | ||
41 | +#define __int8_t int8_t | ||
42 | +#endif | ||
43 | +#ifndef __int16_t | ||
44 | +#define __int16_t int16_t | ||
45 | +#endif | ||
46 | +#ifndef __int32_t | ||
47 | +#define __int32_t int32_t | ||
48 | +#endif | ||
49 | +#ifndef __int64_t | ||
50 | +#define __int64_t int64_t | ||
51 | +#endif | ||
52 | + | ||
53 | static __inline__ int xfsctl(const char *path, int fd, int cmd, void *p) | ||
54 | { | ||
55 | return ioctl(fd, cmd, p); | ||
56 | -- | ||
57 | 2.13.1 | ||
58 | |||
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb index f7e10cdfb..50ab9872e 100644 --- a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb +++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_4.10.0.bb | |||
@@ -7,7 +7,8 @@ LIC_FILES_CHKSUM = "file://doc/COPYING;md5=102f7fec3d53c7c8f0b7baf9bf9d76a8" | |||
7 | DEPENDS = "util-linux util-linux-native" | 7 | DEPENDS = "util-linux util-linux-native" |
8 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ | 8 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ |
9 | file://link_needed_libs.patch \ | 9 | file://link_needed_libs.patch \ |
10 | " | 10 | file://0001-define-__-prefixed-version-of-intXY_t-types.patch \ |
11 | " | ||
11 | SRC_URI[md5sum] = "ddbb04493addf014db07a7e2b96b2804" | 12 | SRC_URI[md5sum] = "ddbb04493addf014db07a7e2b96b2804" |
12 | SRC_URI[sha256sum] = "d8cb9ab2c686699d37914354ce3992b4aff3677093cbce06ad18bf798da8a8a7" | 13 | SRC_URI[sha256sum] = "d8cb9ab2c686699d37914354ce3992b4aff3677093cbce06ad18bf798da8a8a7" |
13 | 14 | ||
@@ -54,4 +55,6 @@ do_configure_prepend () { | |||
54 | 55 | ||
55 | do_install_append() { | 56 | do_install_append() { |
56 | oe_runmake 'DESTDIR=${D}' install install-dev | 57 | oe_runmake 'DESTDIR=${D}' install install-dev |
58 | rm ${D}${libdir}/*.la | ||
59 | rmdir --ignore-fail-on-non-empty ${D}${libdir} | ||
57 | } | 60 | } |