summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
new file mode 100644
index 000000000..fcf8f12bb
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.1.11.bb
@@ -0,0 +1,56 @@
1SUMMARY = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
7DEPENDS = "util-linux"
8
9SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${BP}.tar.gz \
10 file://remove-install-as-user.patch \
11 file://drop-configure-check-for-aio.patch \
12"
13
14SRC_URI[md5sum] = "de9f1f45026c2f4e0776058d429ff4b6"
15SRC_URI[sha256sum] = "adf4980177b5c890c1ca86b9c0e3e4d69a3f95bfc01746844280c2393cf4d6be"
16
17inherit autotools-brokensep
18
19PACKAGES =+ "${PN}-fsck ${PN}-mkfs libhandle"
20
21RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs"
22
23FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
24FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
25FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
26
27EXTRA_OECONF = "--enable-gettext=no"
28do_configure () {
29 # Prevent Makefile from calling configure without arguments,
30 # when do_configure gets called for a second time.
31 rm -f include/builddefs include/platform_defs.h
32 # Recreate configure script.
33 rm -f configure
34 oe_runmake configure
35 # Configure.
36 export DEBUG="-DNDEBUG"
37 gnu-configize --force
38 oe_runconf
39}
40
41LIBTOOL = "${HOST_SYS}-libtool"
42EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
43TARGET_CC_ARCH += "${LDFLAGS}"
44PARALLEL_MAKE = ""
45
46do_install () {
47 export DIST_ROOT=${D}
48 oe_runmake install
49 # needed for xfsdump
50 oe_runmake install-dev
51 rm ${D}${base_libdir}/libhandle.a
52 rm ${D}${base_libdir}/libhandle.la
53 rm ${D}${base_libdir}/libhandle.so
54 rm ${D}${libdir}/libhandle.so
55 ln -s ../..${base_libdir}/libhandle.so.1 ${D}${libdir}/libhandle.so
56}