summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-07-06 16:34:32 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-06 07:28:04 -0700
commit1661f17003ef3de96f6f59d9409b3decff8ea6bf (patch)
treed9ca7603a840a3712986f66f83948ca832de1f83 /meta-filesystems/recipes-filesystems
parentc7beb2bb43edb2c5c5b3f4372924001e78f9c4fa (diff)
downloadmeta-openembedded-1661f17003ef3de96f6f59d9409b3decff8ea6bf.tar.gz
sshfs-fuse: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/run-ptest3
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.0.bb16
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/run-ptest b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.0.bb b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.0.bb
index bf9c34dc9..47c9a64aa 100644
--- a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.0.bb
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.0.bb
@@ -10,4 +10,18 @@ SRC_URI = "git://github.com/libfuse/sshfs"
10SRCREV = "a7e1038203c856cc7e052d439d1da49fe131339f" 10SRCREV = "a7e1038203c856cc7e052d439d1da49fe131339f"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13inherit meson 13inherit meson ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS_${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 bash \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/test
26 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
27}