summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2020-02-14 17:42:52 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-14 17:11:40 -0800
commitba3e92238b32e18c3df83952b5d4e4de60933d1e (patch)
treebdd88edf7f4e58232fcf06c90b4dca7c38ae9928 /meta-filesystems/recipes-filesystems
parent69c0e0d84282d16b9e33de744ce2876e29392f53 (diff)
downloadmeta-openembedded-ba3e92238b32e18c3df83952b5d4e4de60933d1e.tar.gz
ntfs-3g-ntfsprogs: Make it support usrmerge properly
An attempt to solve the problem that some files are installed to /sbin even though the usrmerge distro feature is enabled was made in commit 97c0af59 ("ntfs-3g-ntfsprogs: support usrmerge"). However, it merely just removed the problematic files, which meant that the package was rendered unusable. Solve the problem properly by moving all files that are installed in /sbin to ${base_sbindir} instead. Also clear up a cryptic comment. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-Make-build-support-usrmerge.patch43
-rw-r--r--meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb15
2 files changed, 11 insertions, 47 deletions
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-Make-build-support-usrmerge.patch b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-Make-build-support-usrmerge.patch
deleted file mode 100644
index fce10b999..000000000
--- a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-Make-build-support-usrmerge.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 33f678bf74367aab8ddc2858a9f7797455ea9b9f Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Thu, 29 Aug 2019 10:21:58 +0800
4Subject: [PATCH] Make build support usrmerge
5
6Upstream-Status: Inappropriate[oe-specific]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 ntfsprogs/Makefile.am | 2 --
11 src/Makefile.am | 3 ---
12 2 files changed, 5 deletions(-)
13
14diff --git a/ntfsprogs/Makefile.am b/ntfsprogs/Makefile.am
15index f4f9d1b..1f6a673 100644
16--- a/ntfsprogs/Makefile.am
17+++ b/ntfsprogs/Makefile.am
18@@ -165,8 +165,6 @@ extras: libs $(EXTRA_PROGRAMS)
19
20 if ENABLE_MOUNT_HELPER
21 install-exec-hook:
22- $(INSTALL) -d $(DESTDIR)/sbin
23- $(LN_S) -f $(sbindir)/mkntfs $(DESTDIR)/sbin/mkfs.ntfs
24
25 install-data-hook:
26 $(INSTALL) -d $(DESTDIR)$(man8dir)
27diff --git a/src/Makefile.am b/src/Makefile.am
28index 8d98408..d0a6a45 100644
29--- a/src/Makefile.am
30+++ b/src/Makefile.am
31@@ -66,9 +66,6 @@ endif
32
33 if ENABLE_MOUNT_HELPER
34 install-exec-local: install-rootbinPROGRAMS
35- $(MKDIR_P) "$(DESTDIR)/sbin"
36- $(LN_S) -f "$(rootbindir)/ntfs-3g" "$(DESTDIR)/sbin/mount.ntfs-3g"
37- $(LN_S) -f "$(rootbindir)/lowntfs-3g" "$(DESTDIR)/sbin/mount.lowntfs-3g"
38
39 install-data-local: install-man8
40 $(LN_S) -f ntfs-3g.8 "$(DESTDIR)$(man8dir)/mount.ntfs-3g.8"
41--
422.7.4
43
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
index 1559bfd3f..6f5cb6cee 100644
--- a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
+++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
@@ -8,7 +8,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
8 8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \ 9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \ 10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
11 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-Make-build-support-usrmerge.patch','',d)} \
12" 11"
13S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}" 12S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
14SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c" 13SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
@@ -35,10 +34,18 @@ FILES_ntfsprogs = "${base_sbindir}/* ${bindir}/* ${sbindir}/*"
35FILES_libntfs-3g = "${libdir}/*${SOLIBS}" 34FILES_libntfs-3g = "${libdir}/*${SOLIBS}"
36 35
37do_install_append() { 36do_install_append() {
38 # Standard mount will execute the program /sbin/mount.TYPE 37 # Standard mount will execute the program /sbin/mount.TYPE when called.
39 # when called. Add the symbolic to let mount could find ntfs. 38 # Add a symbolic link to let mount find ntfs.
40 ln -sf mount.ntfs-3g ${D}/${base_sbindir}/mount.ntfs 39 ln -sf mount.ntfs-3g ${D}${base_sbindir}/mount.ntfs
41 rmdir ${D}${libdir}/ntfs-3g 40 rmdir ${D}${libdir}/ntfs-3g
41
42 # Handle when usrmerge is in effect. Some files are installed to /sbin
43 # regardless of the value of ${base_sbindir}.
44 if [ "${base_sbindir}" != /sbin ] && [ -d ${D}/sbin ]; then
45 mkdir -p ${D}${base_sbindir}
46 mv ${D}/sbin/* ${D}${base_sbindir}
47 rmdir ${D}/sbin
48 fi
42} 49}
43 50
44# Satisfy the -dev runtime dependency 51# Satisfy the -dev runtime dependency