diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-10-23 19:22:02 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-24 08:28:55 +0200 |
commit | 9f21b18da323b1aca5cf49619ff353872c87f008 (patch) | |
tree | bd898fad8ee6975e7de1c9569eee852f037698cf /meta-efl | |
parent | 415c49a0c7ba008ed26f6639dd57a96fa9b986e1 (diff) | |
download | meta-openembedded-9f21b18da323b1aca5cf49619ff353872c87f008.tar.gz |
epdfview: Sync with Debian 0.1.8-3 patches
This includes the patches in use in Debian package to fix color
inversion and other minor issues.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl')
6 files changed, 101 insertions, 14 deletions
diff --git a/meta-efl/recipes-efl/efl/epdfview/browser_command.patch b/meta-efl/recipes-efl/efl/epdfview/browser_command.patch new file mode 100644 index 000000000..75e45e0ab --- /dev/null +++ b/meta-efl/recipes-efl/efl/epdfview/browser_command.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/Config.cxx b/src/Config.cxx | ||
6 | index 28f37ab..bc58819 100644 | ||
7 | --- a/src/Config.cxx | ||
8 | +++ b/src/Config.cxx | ||
9 | @@ -22,7 +22,7 @@ | ||
10 | using namespace ePDFView; | ||
11 | |||
12 | // Constants | ||
13 | -static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "firefox %s"; | ||
14 | +static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "x-www-browser %s"; | ||
15 | static const gchar *DEFAULT_OPEN_FILE_FOLDER = NULL; | ||
16 | static const gchar *DEFAULT_SAVE_FILE_FOLDER = NULL; | ||
17 | static const gboolean DEFAULT_SHOW_STATUSBAR = TRUE; | ||
diff --git a/meta-efl/recipes-efl/efl/epdfview/fix-format.patch b/meta-efl/recipes-efl/efl/epdfview/fix-format.patch new file mode 100644 index 000000000..8ad5b97ca --- /dev/null +++ b/meta-efl/recipes-efl/efl/epdfview/fix-format.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/gtk/MainView.cxx b/src/gtk/MainView.cxx | ||
6 | index b983bff..f87de28 100644 | ||
7 | --- a/src/gtk/MainView.cxx | ||
8 | +++ b/src/gtk/MainView.cxx | ||
9 | @@ -634,8 +634,9 @@ MainView::showErrorMessage (const gchar *title, const gchar *body) | ||
10 | GTK_DIALOG_DESTROY_WITH_PARENT, | ||
11 | GTK_MESSAGE_ERROR, | ||
12 | GTK_BUTTONS_OK, | ||
13 | + "%s", | ||
14 | title); | ||
15 | - gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), | ||
16 | + gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), "%s", | ||
17 | body); | ||
18 | gtk_dialog_run (GTK_DIALOG (errorDialog)); | ||
19 | gtk_widget_destroy (errorDialog); | ||
diff --git a/meta-efl/recipes-efl/efl/epdfview/glib-2.32.patch b/meta-efl/recipes-efl/efl/epdfview/glib-2.32.patch deleted file mode 100644 index e08584c01..000000000 --- a/meta-efl/recipes-efl/efl/epdfview/glib-2.32.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | diff -uNr epdfview-0.1.8.orig/src/gtk/StockIcons.h epdfview-0.1.8/src/gtk/StockIcons.h | ||
2 | --- epdfview-0.1.8.orig/src/gtk/StockIcons.h 2011-05-28 12:24:57.000000000 +0200 | ||
3 | +++ epdfview-0.1.8/src/gtk/StockIcons.h 2012-04-30 07:48:08.528285594 +0200 | ||
4 | @@ -18,8 +18,6 @@ | ||
5 | #if !defined (__STOCK_ICONS_H__) | ||
6 | #define __STOCK_ICONS_H__ | ||
7 | |||
8 | -#include <glib/gmacros.h> | ||
9 | - | ||
10 | G_BEGIN_DECLS | ||
11 | |||
12 | // ePDFView stock icons. | ||
diff --git a/meta-efl/recipes-efl/efl/epdfview/glib-single-include.patch b/meta-efl/recipes-efl/efl/epdfview/glib-single-include.patch new file mode 100644 index 000000000..84a491386 --- /dev/null +++ b/meta-efl/recipes-efl/efl/epdfview/glib-single-include.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | diff --git a/src/gtk/StockIcons.h b/src/gtk/StockIcons.h | ||
6 | index c142a7a..58fcf2e 100644 | ||
7 | --- a/src/gtk/StockIcons.h | ||
8 | +++ b/src/gtk/StockIcons.h | ||
9 | @@ -18,7 +18,7 @@ | ||
10 | #if !defined (__STOCK_ICONS_H__) | ||
11 | #define __STOCK_ICONS_H__ | ||
12 | |||
13 | -#include <glib/gmacros.h> | ||
14 | +#include <glib.h> | ||
15 | |||
16 | G_BEGIN_DECLS | ||
17 | |||
diff --git a/meta-efl/recipes-efl/efl/epdfview/swap-colors.patch b/meta-efl/recipes-efl/efl/epdfview/swap-colors.patch new file mode 100644 index 000000000..282bfb184 --- /dev/null +++ b/meta-efl/recipes-efl/efl/epdfview/swap-colors.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Imported from Debian 0.1.8-3 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | Index: trunk/src/PDFDocument.cxx | ||
6 | =================================================================== | ||
7 | --- trunk/src/PDFDocument.cxx (revision 361) | ||
8 | +++ trunk/src/PDFDocument.cxx (revision 367) | ||
9 | @@ -21,4 +21,5 @@ | ||
10 | #include <poppler.h> | ||
11 | #include <unistd.h> | ||
12 | +#include <algorithm> | ||
13 | #include "epdfview.h" | ||
14 | |||
15 | @@ -33,4 +34,22 @@ | ||
16 | static PageMode convertPageMode (gint pageMode); | ||
17 | static gchar *getAbsoluteFileName (const gchar *fileName); | ||
18 | + | ||
19 | +namespace | ||
20 | +{ | ||
21 | + void | ||
22 | + convert_bgra_to_rgba (guint8 *data, int width, int height) | ||
23 | + { | ||
24 | + using std::swap; | ||
25 | + | ||
26 | + for (int y = 0; y < height; y++) | ||
27 | + { | ||
28 | + for (int x = 0; x < width; x++) | ||
29 | + { | ||
30 | + swap(data[0], data[2]); | ||
31 | + data += 4; | ||
32 | + } | ||
33 | + } | ||
34 | + } | ||
35 | +} | ||
36 | |||
37 | /// | ||
38 | @@ -651,4 +670,5 @@ | ||
39 | cairo_destroy(context); | ||
40 | cairo_surface_destroy (surface); | ||
41 | + convert_bgra_to_rgba(renderedPage->getData (), width, height); | ||
42 | #else // !HAVE_POPPLER_0_17_0 | ||
43 | // Create the pixbuf from the data and render to it. | ||
diff --git a/meta-efl/recipes-efl/efl/epdfview_0.1.8.bb b/meta-efl/recipes-efl/efl/epdfview_0.1.8.bb index c16137e81..53951e1d2 100644 --- a/meta-efl/recipes-efl/efl/epdfview_0.1.8.bb +++ b/meta-efl/recipes-efl/efl/epdfview_0.1.8.bb | |||
@@ -5,14 +5,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | |||
5 | SECTION = "x11/applications" | 5 | SECTION = "x11/applications" |
6 | DEPENDS = "gtk+ poppler" | 6 | DEPENDS = "gtk+ poppler" |
7 | 7 | ||
8 | PR = "r2" | 8 | PR = "r3" |
9 | 9 | ||
10 | EXTRA_OECONF += "--without-cups" | 10 | EXTRA_OECONF += "--without-cups" |
11 | 11 | ||
12 | inherit autotools gettext | 12 | inherit autotools gettext |
13 | 13 | ||
14 | SRC_URI = "http://www.emma-soft.com/projects/${BPN}/chrome/site/releases/${BP}.tar.bz2 \ | 14 | SRC_URI = "http://www.emma-soft.com/projects/${BPN}/chrome/site/releases/${BP}.tar.bz2 \ |
15 | file://glib-2.32.patch \ | 15 | file://browser_command.patch \ |
16 | file://fix-format.patch \ | ||
17 | file://glib-single-include.patch \ | ||
18 | file://swap-colors.patch \ | ||
16 | " | 19 | " |
17 | SRC_URI[md5sum] = "e50285b01612169b2594fea375f53ae4" | 20 | SRC_URI[md5sum] = "e50285b01612169b2594fea375f53ae4" |
18 | SRC_URI[sha256sum] = "948648ae7c9d7b3b408d738bd4f48d87375b1196cae1129d6b846a8de0f2f8f0" | 21 | SRC_URI[sha256sum] = "948648ae7c9d7b3b408d738bd4f48d87375b1196cae1129d6b846a8de0f2f8f0" |