diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-31 21:18:57 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-23 23:21:16 +0100 |
commit | f88e671b36b86d9ff43a3c38f7ebb800d69eadf0 (patch) | |
tree | 9309ffeeace4ef3bf58a68e051079cc553a0658b /meta-efl | |
parent | f696e1bdb10f7b2cb139bf9048e478d9f10c5e17 (diff) | |
download | meta-openembedded-f88e671b36b86d9ff43a3c38f7ebb800d69eadf0.tar.gz |
enjoy: switch from svn to newer git and update dependency from edbus2 to eldbus
* edbus2 was renamed to eldbus and is now included in efl source tree
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/e17/enjoy/0001-always-use-position-as-percent-and-define-a-1-second.patch | 14 | ||||
-rw-r--r-- | meta-efl/recipes-efl/e17/enjoy_git.bb (renamed from meta-efl/recipes-efl/e17/enjoy_svn.bb) | 12 |
2 files changed, 12 insertions, 14 deletions
diff --git a/meta-efl/recipes-efl/e17/enjoy/0001-always-use-position-as-percent-and-define-a-1-second.patch b/meta-efl/recipes-efl/e17/enjoy/0001-always-use-position-as-percent-and-define-a-1-second.patch index 45f02b730..09624503b 100644 --- a/meta-efl/recipes-efl/e17/enjoy/0001-always-use-position-as-percent-and-define-a-1-second.patch +++ b/meta-efl/recipes-efl/e17/enjoy/0001-always-use-position-as-percent-and-define-a-1-second.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From ac4c8a57e8a042acd4b8ff803d3d3574b0e7a7fb Mon Sep 17 00:00:00 2001 | 1 | From 751505501e0db31cf766ec0ae95a6968b4d1eb93 Mon Sep 17 00:00:00 2001 |
2 | From: Alban Browaeys <prahal@yahoo.com> | 2 | From: Alban Browaeys <prahal@yahoo.com> |
3 | Date: Wed, 5 Sep 2012 02:58:26 +0000 | 3 | Date: Wed, 5 Sep 2012 02:58:26 +0000 |
4 | Subject: [PATCH] always use position as percent and define a 1 seconds | 4 | Subject: [PATCH] always use position as percent and define a 1 seconds |
@@ -7,12 +7,12 @@ Subject: [PATCH] always use position as percent and define a 1 seconds | |||
7 | Fix "reverb" effect: ie loop between setting the slider to match | 7 | Fix "reverb" effect: ie loop between setting the slider to match |
8 | the position and handling slider to position (seek). | 8 | the position and handling slider to position (seek). |
9 | --- | 9 | --- |
10 | data/themes/default.edc | 8 +++----- | 10 | data/themes/default.edc | 8 +++----- |
11 | src/bin/win.c | 28 ++++++++++++++++++++++------ | 11 | src/bin/win.c | 28 ++++++++++++++++++++++------ |
12 | 2 files changed, 25 insertions(+), 11 deletions(-) | 12 | 2 files changed, 25 insertions(+), 11 deletions(-) |
13 | 13 | ||
14 | diff --git a/data/themes/default.edc b/data/themes/default.edc | 14 | diff --git a/data/themes/default.edc b/data/themes/default.edc |
15 | index 65efddf..27bb9e4 100644 | 15 | index ebf8ba4..7a906b1 100644 |
16 | --- a/data/themes/default.edc | 16 | --- a/data/themes/default.edc |
17 | +++ b/data/themes/default.edc | 17 | +++ b/data/themes/default.edc |
18 | @@ -186,7 +186,6 @@ collections { | 18 | @@ -186,7 +186,6 @@ collections { |
@@ -42,7 +42,7 @@ index 65efddf..27bb9e4 100644 | |||
42 | } else if (type == MSG_INT && id == MSG_SHUFFLE) { | 42 | } else if (type == MSG_INT && id == MSG_SHUFFLE) { |
43 | external_param_set_bool(PART:"buttons.shuffle", "state", getarg(2)); | 43 | external_param_set_bool(PART:"buttons.shuffle", "state", getarg(2)); |
44 | } else if (type == MSG_INT && id == MSG_LOOP) { | 44 | } else if (type == MSG_INT && id == MSG_LOOP) { |
45 | @@ -687,7 +685,7 @@ collections { | 45 | @@ -689,7 +687,7 @@ collections { |
46 | source: "progress.slider"; | 46 | source: "progress.slider"; |
47 | signal: "changed"; | 47 | signal: "changed"; |
48 | script { | 48 | script { |
@@ -52,7 +52,7 @@ index 65efddf..27bb9e4 100644 | |||
52 | } | 52 | } |
53 | program { | 53 | program { |
54 | diff --git a/src/bin/win.c b/src/bin/win.c | 54 | diff --git a/src/bin/win.c b/src/bin/win.c |
55 | index 63951db..ad93ab5 100644 | 55 | index 2f65953..428e268 100644 |
56 | --- a/src/bin/win.c | 56 | --- a/src/bin/win.c |
57 | +++ b/src/bin/win.c | 57 | +++ b/src/bin/win.c |
58 | @@ -194,8 +194,8 @@ _win_play_eval(Win *w) | 58 | @@ -194,8 +194,8 @@ _win_play_eval(Win *w) |
@@ -129,5 +129,5 @@ index 63951db..ad93ab5 100644 | |||
129 | } | 129 | } |
130 | 130 | ||
131 | -- | 131 | -- |
132 | 1.7.7 | 132 | 1.8.5.2 |
133 | 133 | ||
diff --git a/meta-efl/recipes-efl/e17/enjoy_svn.bb b/meta-efl/recipes-efl/e17/enjoy_git.bb index d1c3855e2..bc3168e6a 100644 --- a/meta-efl/recipes-efl/e17/enjoy_svn.bb +++ b/meta-efl/recipes-efl/e17/enjoy_git.bb | |||
@@ -1,10 +1,10 @@ | |||
1 | SUMMARY = "Enjoy music player" | 1 | SUMMARY = "Enjoy music player" |
2 | LICENSE = "LGPLv3" | 2 | LICENSE = "LGPLv3" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" |
4 | DEPENDS = "evas ecore edje elementary emotion lightmediascanner edbus2 gst-plugins-good" | 4 | DEPENDS = "evas ecore edje elementary emotion lightmediascanner eldbus gst-plugins-good" |
5 | SRCREV = "${EFL_SRCREV}" | ||
6 | PV = "0.0+svnr${SRCPV}" | ||
7 | 5 | ||
6 | SRCREV = "aa8fec69e885eec048a849c2b34059ec58404e02" | ||
7 | PV = "0.1.0+gitr${SRCPV}" | ||
8 | 8 | ||
9 | #1st needed for all formats | 9 | #1st needed for all formats |
10 | #2nd needed for mp3 playback | 10 | #2nd needed for mp3 playback |
@@ -20,12 +20,10 @@ RDEPENDS_${PN} += "\ | |||
20 | 20 | ||
21 | inherit e gettext | 21 | inherit e gettext |
22 | SRC_URI = " \ | 22 | SRC_URI = " \ |
23 | ${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep \ | 23 | git://git.enlightenment.org/apps/enjoy.git \ |
24 | file://0001-always-use-position-as-percent-and-define-a-1-second.patch \ | 24 | file://0001-always-use-position-as-percent-and-define-a-1-second.patch \ |
25 | " | 25 | " |
26 | S = "${WORKDIR}/${SRCNAME}" | 26 | S = "${WORKDIR}/git" |
27 | |||
28 | PR = "r1" | ||
29 | 27 | ||
30 | FILES_${PN} += "${datadir}/icons/" | 28 | FILES_${PN} += "${datadir}/icons/" |
31 | 29 | ||