diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-03-31 09:14:18 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-31 12:56:35 +0200 |
commit | c5e512ae752cfef92f418c0c787c6371d3fa743c (patch) | |
tree | d2529324c68bd8e0b9e581f2b8c9b3e9db2462a3 /meta-efl | |
parent | b6aa2bfbf6fd51ada0fb7d5f44bbafbba796a73c (diff) | |
download | meta-openembedded-c5e512ae752cfef92f418c0c787c6371d3fa743c.tar.gz |
python-efl: import from meta-shr
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
8 files changed, 122 insertions, 0 deletions
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb new file mode 100644 index 000000000..0b876083a --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-ecore_svn.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "python-evas ecore" | ||
6 | RDEPENDS_${PN} += "python-evas" | ||
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb new file mode 100644 index 000000000..d6144e9b2 --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-edbus_svn.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "edbus python-dbus" | ||
6 | RDEPENDS_${PN} += "python-dbus" | ||
7 | SRCNAME = "python-e_dbus" | ||
diff --git a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch new file mode 100644 index 000000000..3b0cdc627 --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jan Luebbe <jluebbe@debian.org> | ||
3 | Date: Sat, 9 Aug 2008 18:30:04 +0200 | ||
4 | Subject: [PATCH] fix unicode conversion | ||
5 | |||
6 | --- | ||
7 | edje/edje.c_edje_object.pxi | 11 +++++++---- | ||
8 | 1 files changed, 7 insertions(+), 4 deletions(-) | ||
9 | |||
10 | diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi | ||
11 | index 0f4da68..21c237e 100644 | ||
12 | --- a/edje/edje.c_edje_object.pxi | ||
13 | +++ b/edje/edje.c_edje_object.pxi | ||
14 | @@ -415,17 +415,20 @@ | ||
15 | else: | ||
16 | raise TypeError("func must be callable or None") | ||
17 | |||
18 | - def part_text_set(self, char *part, char *text): | ||
19 | - edje_object_part_text_set(self.obj, part, text) | ||
20 | + def part_text_set(self, char *part, text): | ||
21 | + cdef char *s | ||
22 | + u = text.encode("utf8") | ||
23 | + s = u | ||
24 | + edje_object_part_text_set(self.obj, part, s) | ||
25 | |||
26 | def part_text_get(self, char *part): | ||
27 | - "@rtype: str" | ||
28 | + "@rtype: unicode" | ||
29 | cdef const_char_ptr s | ||
30 | s = edje_object_part_text_get(self.obj, part) | ||
31 | if s == NULL: | ||
32 | return None | ||
33 | else: | ||
34 | - return s | ||
35 | + return s.decode("utf8") | ||
36 | |||
37 | def part_text_select_all(self, char *part): | ||
38 | edje_object_part_text_select_all(self.obj, part) | ||
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb new file mode 100644 index 000000000..581cc1c49 --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-edje_svn.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "edje python-evas" | ||
6 | RDEPENDS_${PN} += "python-evas" | ||
7 | |||
8 | SRC_URI += "file://0001-fix-unicode-conversion.patch" | ||
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc new file mode 100644 index 000000000..f81630576 --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-efl.inc | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "${PN} bindings" | ||
2 | LICENSE = "BSD" | ||
3 | AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>" | ||
4 | # NOTE: Due to a bug in distutils, even if we don't use pyrex but cython, | ||
5 | # we need to build pyrex otherwise cython doesn't get called to build | ||
6 | # the extension modules. | ||
7 | DEPENDS = "python-cython-native python-pyrex-native python-numeric eina" | ||
8 | RDEPENDS_${PN} += "python-lang" | ||
9 | PV = "0.7.3+svnr${SRCPV}" | ||
10 | PR = "ml1" | ||
11 | |||
12 | # necessary to let the call for python-config succeed | ||
13 | export BUILD_SYS | ||
14 | export HOST_SYS | ||
15 | |||
16 | inherit e-base autotools pkgconfig distutils-base | ||
17 | |||
18 | SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};proto=http" | ||
19 | S = "${WORKDIR}/${SRCNAME}" | ||
20 | |||
21 | |||
22 | do_configure_prepend() { | ||
23 | # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly | ||
24 | sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac | ||
25 | } | ||
26 | |||
27 | do_install_append() { | ||
28 | if [ -e examples ]; then | ||
29 | for i in `find examples -name "*.edc"`; do | ||
30 | cd ${S}/`dirname $i` | ||
31 | echo "Generating .edj file for $i..." | ||
32 | edje_cc `basename $i` | ||
33 | echo "Removing sources in this directory..." | ||
34 | rm -f *.edc *.png *.ttf *.jpeg | ||
35 | done | ||
36 | cd ${S} | ||
37 | install -d ${D}${datadir}/${PN}/ | ||
38 | cp -a examples ${D}${datadir}/${PN}/ | ||
39 | find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf | ||
40 | fi | ||
41 | } | ||
42 | |||
43 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug" | ||
44 | |||
45 | PACKAGES += "${PN}-examples" | ||
46 | FILES_${PN}-examples = "${datadir}/${PN}/examples" | ||
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb new file mode 100644 index 000000000..e7f18ecfb --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-elementary_svn.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv3" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "elementary python-evas" | ||
6 | RDEPENDS_${PN} += "python-evas python-ecore python-edje" | ||
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb new file mode 100644 index 000000000..ae2eb4c66 --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-emotion_svn.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "emotion python-evas" | ||
6 | RDEPENDS_${PN} += "python-ecore" | ||
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb new file mode 100644 index 000000000..8ec9c41dc --- /dev/null +++ b/meta-efl/recipes-devtools/python/python-evas_svn.bb | |||
@@ -0,0 +1,5 @@ | |||
1 | require python-efl.inc | ||
2 | LICENSE = "LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | ||
4 | SRCREV = "${EFL_SRCREV}" | ||
5 | DEPENDS += "evas" | ||