summaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-09-24 18:10:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:27:51 +0200
commit45ec2034575e849e9b583d4f051c43ce5dfcedb4 (patch)
treeb30a734dab9ec0aff40ca30abbc8db44998bf85f /meta-efl
parentd2213eeb153fb0d8e4baf628fd62bef122f0d740 (diff)
downloadmeta-openembedded-45ec2034575e849e9b583d4f051c43ce5dfcedb4.tar.gz
webkit-efl: fix build with cmake-3*
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/0005-Fix-the-build-with-cmake-3.patch104
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb1
2 files changed, 105 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0005-Fix-the-build-with-cmake-3.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0005-Fix-the-build-with-cmake-3.patch
new file mode 100644
index 000000000..7e8e295c7
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/0005-Fix-the-build-with-cmake-3.patch
@@ -0,0 +1,104 @@
1From a00a7097b85567ae6eb7a00b3ce7ef021841203c Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Thu, 24 Sep 2015 18:03:52 +0200
4Subject: [PATCH 5/5] Fix the build with cmake 3
5
6* the same issue as in GTK port:
7 https://bugs.webkit.org/show_bug.cgi?id=141796
8 http://trac.webkit.org/changeset/180502
9
10* otherwise linking fails with couple undefined symbols
11| CMakeFiles/WebKit2.dir/PluginProcess/unix/PluginProcessMainUnix.cpp.o: In function `WebKit::webkitXError(_XDisplay*, XErrorEvent*)':
12| ewebkit/Source/WebKit2/PluginProcess/unix/PluginProcessMainUnix.cpp:63: undefined reference to `XGetErrorText'
13| CMakeFiles/WebKit2.dir/PluginProcess/unix/PluginProcessMainUnix.cpp.o: In function `WebKit::PluginProcessMain::parseCommandLine(int, char**)':
14| ewebkit/Source/WebKit2/PluginProcess/unix/PluginProcessMainUnix.cpp:102: undefined reference to `XSetErrorHandler'
15| ewebkit/Source/WebKit2/PluginProcess/unix/PluginProcessMainUnix.cpp:102: undefined reference to `XSetErrorHandler'
16| CMakeFiles/WebKit2.dir/WebProcess/efl/WebProcessMainEfl.cpp.o: In function `WebKit::WebProcessMain::platformInitialize()':
17| ewebkit/Source/WebKit2/WebProcess/efl/WebProcessMainEfl.cpp:67: undefined reference to `XSetExtensionErrorHandler'
18| ewebkit/Source/WebKit2/WebProcess/efl/WebProcessMainEfl.cpp:67: undefined reference to `XSetExtensionErrorHandler'
19| CMakeFiles/WebKit2.dir/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp.o: In function `WebKit::NetscapePlugin::platformPostInitializeWindowed(bool, unsigned long)':
20| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:170: undefined reference to `XFlush'
21| CMakeFiles/WebKit2.dir/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp.o: In function `WebKit::NetscapePlugin::platformPostInitializeWindowless()':
22| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:195: undefined reference to `XGetVisualInfo'
23| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:199: undefined reference to `XFree'
24| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:202: undefined reference to `XCreateColormap'
25| CMakeFiles/WebKit2.dir/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp.o: In function `WebKit::NetscapePlugin::platformDestroy()':
26| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:251: undefined reference to `XFreeColormap'
27| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:255: undefined reference to `XFreePixmap'
28| CMakeFiles/WebKit2.dir/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp.o: In function `WebKit::NetscapePlugin::platformGeometryDidChange()':
29| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:293: undefined reference to `XCreatePixmap'
30| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:286: undefined reference to `XFreePixmap'
31| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:295: undefined reference to `XSync'
32| CMakeFiles/WebKit2.dir/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp.o: In function `WebKit::NetscapePlugin::platformPaint(WebCore::GraphicsContext*, WebCore::IntRect const&, bool)':
33| ewebkit/Source/WebKit2/WebProcess/Plugins/Netscape/x11/NetscapePluginX11.cpp:343: undefined reference to `XSync'
34| collect2: error: ld returned 1 exit status
35| Source/WebKit2/CMakeFiles/WebKit2.dir/build.make:16145: recipe for target 'lib/libewebkit2.so.1.11.0' failed
36| make[2]: *** [lib/libewebkit2.so.1.11.0] Error 1
37
38Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
39---
40 Source/WebCore/PlatformEfl.cmake | 1 +
41 Source/WebKit2/PlatformEfl.cmake | 3 +++
42 Source/cmake/OptionsEfl.cmake | 1 +
43 Tools/WebKitTestRunner/PlatformEfl.cmake | 1 +
44 4 files changed, 6 insertions(+)
45
46diff --git a/Source/WebCore/PlatformEfl.cmake b/Source/WebCore/PlatformEfl.cmake
47index 41ffc15..63b7861 100644
48--- a/Source/WebCore/PlatformEfl.cmake
49+++ b/Source/WebCore/PlatformEfl.cmake
50@@ -404,6 +404,7 @@ if (WTF_USE_3D_GRAPHICS)
51 )
52 endif ()
53
54+ find_package(X11 REQUIRED)
55 list(APPEND WebCore_LIBRARIES
56 ${X11_X11_LIB}
57 )
58diff --git a/Source/WebKit2/PlatformEfl.cmake b/Source/WebKit2/PlatformEfl.cmake
59index 8c66d1b..d96f0bd 100644
60--- a/Source/WebKit2/PlatformEfl.cmake
61+++ b/Source/WebKit2/PlatformEfl.cmake
62@@ -331,12 +331,15 @@ if (ENABLE_SECCOMP_FILTERS)
63 endif ()
64
65 if (ENABLE_ECORE_X)
66+ find_package(X11 REQUIRED)
67 list(APPEND WebProcess_LIBRARIES
68 ${ECORE_X_LIBRARIES}
69 ${X11_Xext_LIB}
70 )
71 list(APPEND WebKit2_LIBRARIES
72 ${ECORE_X_LIBRARIES}
73+ ${X11_X11_LIB}
74+ ${X11_Xext_LIB}
75 )
76 endif ()
77
78diff --git a/Source/cmake/OptionsEfl.cmake b/Source/cmake/OptionsEfl.cmake
79index 8585f19..1aa9002 100644
80--- a/Source/cmake/OptionsEfl.cmake
81+++ b/Source/cmake/OptionsEfl.cmake
82@@ -181,6 +181,7 @@ endif ()
83
84 if (WTF_OS_UNIX)
85 set(ENABLE_X11_TARGET ON)
86+ find_package(X11 REQUIRED)
87 add_definitions(-DXP_UNIX)
88 endif (WTF_OS_UNIX)
89
90diff --git a/Tools/WebKitTestRunner/PlatformEfl.cmake b/Tools/WebKitTestRunner/PlatformEfl.cmake
91index 1873279..a905f2a 100644
92--- a/Tools/WebKitTestRunner/PlatformEfl.cmake
93+++ b/Tools/WebKitTestRunner/PlatformEfl.cmake
94@@ -53,6 +53,7 @@ list(APPEND WebKitTestRunnerInjectedBundle_LIBRARIES
95 )
96
97 if (ENABLE_ECORE_X)
98+ find_package(X11 REQUIRED)
99 list(APPEND WebKitTestRunner_INCLUDE_DIRECTORIES
100 ${ECORE_X_INCLUDE_DIRS}
101 )
102--
1032.6.0
104
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb b/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
index 068c0d977..07cbd89d0 100644
--- a/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_1.11.0.bb
@@ -5,6 +5,7 @@ SRC_URI += "\
5 file://0002-WebKitHelpers.cmake-Add-Wno-error-deprecated-declara.patch \ 5 file://0002-WebKitHelpers.cmake-Add-Wno-error-deprecated-declara.patch \
6 file://0003-FEBlendNEON.h-fix-missing-semicolon.patch \ 6 file://0003-FEBlendNEON.h-fix-missing-semicolon.patch \
7 file://0004-Fix-the-build-with-EFL-1.12-https-bugs.webkit.org-sh.patch \ 7 file://0004-Fix-the-build-with-EFL-1.12-https-bugs.webkit.org-sh.patch \
8 file://0005-Fix-the-build-with-cmake-3.patch \
8" 9"
9SRC_URI[md5sum] = "90fa970ebf8646319d292c2bb5bff5db" 10SRC_URI[md5sum] = "90fa970ebf8646319d292c2bb5bff5db"
10SRC_URI[sha256sum] = "d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7" 11SRC_URI[sha256sum] = "d8d21e27f4a21cd77c41914548c184ddb98693ba23851aa66c8e51c0be4b90b7"