diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-20 10:54:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:58 +0200 |
commit | b4a83a31c78735be6f08597015613ae9c0eaec5d (patch) | |
tree | 56009f991fb9c7ff01004e8db6af422f2d157dce /meta-efl | |
parent | 0a3cc0aafde4627516db7702abb5c5e8382352fb (diff) | |
download | meta-openembedded-b4a83a31c78735be6f08597015613ae9c0eaec5d.tar.gz |
webkit-efl: Fix type-limits warning
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
3 files changed, 34 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch index 864b9c914..c769c7fbb 100644 --- a/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch +++ b/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch | |||
@@ -20,7 +20,7 @@ index 409931c..345b346 100644 | |||
20 | + # FIXME: When we use -fno-tree-dce to support the jsCStack branch merge, build error occurs due to the uninitialization. Temporarily we set | 20 | + # FIXME: When we use -fno-tree-dce to support the jsCStack branch merge, build error occurs due to the uninitialization. Temporarily we set |
21 | + # uninitialized as build warning in order to support the jsCStack merge. https://bugs.webkit.org/show_bug.cgi?id=127777. | 21 | + # uninitialized as build warning in order to support the jsCStack merge. https://bugs.webkit.org/show_bug.cgi?id=127777. |
22 | + set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter -Wno-error=uninitialized ${OLD_COMPILE_FLAGS}") | 22 | + set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter -Wno-error=uninitialized ${OLD_COMPILE_FLAGS}") |
23 | + # | /OE/build/shr-core/tmp-eglibc/work/arm920tt-oe-linux-gnueabi/webkit-efl/2.3.2+svnr159807-r0/webkit-efl/Source/JavaScriptCore/runtime/JSDataViewPrototype.cpp:161:104: error: cast from 'uint8_t* {aka unsigned char*}' to 'JSC::FloatTypedArrayAdaptor<double, JSC::GenericTypedArrayView<JSC::Float64Adaptor>, JSC::JSGenericTypedArrayView<JSC::Float64Adaptor>, (JSC::TypedArrayType)9u>::Type* {aka double*}' increases required alignment of target type [-Werror=cast-align] | 23 | + # | /OE/build/shr-core/tmp-eglibc/work/arm920tt-oe-linux-gnueabi/webkit-efl/2.3.2+svnr159807-r0/webkit-efl/Source/JavaScriptCore/runtime/JSDataViewPrototype.cpp:161:104: error: cast from 'uint8_t* {aka unsigned char*}' to 'JSC::FloatTypedArrayAdaptor<double, JSC::GenericTypedArrayView<JSC::Float64Adaptor>, JSC::JSGenericTypedArrayView<JSC::Float64Adaptor>, (JSC::TypedArrayType)9u>::Type* {aka double*}' increases required alignment of target type [-Werror=cast-align] |
24 | + set(OLD_COMPILE_FLAGS "-Wno-error=cast-align -Wno-error=array-bounds -Wno-error=deprecated-declarations ${OLD_COMPILE_FLAGS}") | 24 | + set(OLD_COMPILE_FLAGS "-Wno-error=cast-align -Wno-error=array-bounds -Wno-error=deprecated-declarations ${OLD_COMPILE_FLAGS}") |
25 | endif () | 25 | endif () |
26 | 26 | ||
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0004-WebMemorySamplerLinux-Fix-type-limits-warning.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0004-WebMemorySamplerLinux-Fix-type-limits-warning.patch new file mode 100644 index 000000000..f30987ba3 --- /dev/null +++ b/meta-efl/recipes-efl/webkit/webkit-efl/0004-WebMemorySamplerLinux-Fix-type-limits-warning.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From ed7972510df191d9fabe7aff2f688cbc45f0c955 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Sun, 20 Jul 2014 10:52:17 +0200 | ||
4 | Subject: [PATCH] WebMemorySamplerLinux: Fix type-limits warning | ||
5 | |||
6 | * otherwise it fails with: | ||
7 | webkit-efl/2.3.4+svnr164189-r0/efl-webkit/Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp:70:16: | ||
8 | error: comparison is always false due to limited range of data type [-Werror=type-limits] | ||
9 | | if (ch == EOF || (isASCIISpace(ch) && index)) // Break on non-initial ASCII space. | ||
10 | | ^ | ||
11 | |||
12 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
13 | --- | ||
14 | Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp b/Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp | ||
18 | index 7cb70d4..6bb78d8 100644 | ||
19 | --- a/Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp | ||
20 | +++ b/Source/WebKit2/Shared/linux/WebMemorySamplerLinux.cpp | ||
21 | @@ -67,7 +67,7 @@ static inline String nextToken(FILE* file) | ||
22 | unsigned int index = 0; | ||
23 | while (index < maxBuffer) { | ||
24 | char ch = fgetc(file); | ||
25 | - if (ch == EOF || (isASCIISpace(ch) && index)) // Break on non-initial ASCII space. | ||
26 | + if (isASCIISpace(ch) && index) // Break on non-initial ASCII space. | ||
27 | break; | ||
28 | if (!isASCIISpace(ch)) { | ||
29 | buffer[index] = ch; | ||
30 | -- | ||
31 | 2.0.0 | ||
32 | |||
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_2.3.4+svnr164189.bb b/meta-efl/recipes-efl/webkit/webkit-efl_2.3.4+svnr164189.bb index 65418ca9a..748ecea11 100644 --- a/meta-efl/recipes-efl/webkit/webkit-efl_2.3.4+svnr164189.bb +++ b/meta-efl/recipes-efl/webkit/webkit-efl_2.3.4+svnr164189.bb | |||
@@ -5,6 +5,7 @@ SRC_URI = "\ | |||
5 | file://0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch \ | 5 | file://0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch \ |
6 | file://0002-ARMAssembler.h-Don-t-generate-BKPT-and-BLX-for-armv4.patch \ | 6 | file://0002-ARMAssembler.h-Don-t-generate-BKPT-and-BLX-for-armv4.patch \ |
7 | file://0003-Fix-linking-issue.patch \ | 7 | file://0003-Fix-linking-issue.patch \ |
8 | file://0004-WebMemorySamplerLinux-Fix-type-limits-warning.patch \ | ||
8 | " | 9 | " |
9 | SRC_URI[md5sum] = "731513fc042ec8e03840bc1ab6a66771" | 10 | SRC_URI[md5sum] = "731513fc042ec8e03840bc1ab6a66771" |
10 | SRC_URI[sha256sum] = "660aefd65c0e5c6494eaec30539cda5f40fbdff17f28e7e83d341b245227cccd" | 11 | SRC_URI[sha256sum] = "660aefd65c0e5c6494eaec30539cda5f40fbdff17f28e7e83d341b245227cccd" |