summaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-22 21:13:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-26 21:37:37 +0100
commitba8b86175ee3d11fec13d521f77da137c91be150 (patch)
tree30f54e921cdbd56e2cc0d7d1aa1b5a87f759a136 /meta-efl
parentadef0b1b84c92ae57402e7fcb85f50df18a85ad5 (diff)
downloadmeta-openembedded-ba8b86175ee3d11fec13d521f77da137c91be150.tar.gz
epdf: make it build again and get out of blacklist-exile
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/efl/epdf/0001-remove-antialias-functions-poppler-has-dropped-them-.patch132
-rw-r--r--meta-efl/recipes-efl/efl/epdf/0002-epdf_poppler_postscript.cpp-fix-build-for-poppler-AP.patch45
-rw-r--r--meta-efl/recipes-efl/efl/epdf_svn.bb8
3 files changed, 181 insertions, 4 deletions
diff --git a/meta-efl/recipes-efl/efl/epdf/0001-remove-antialias-functions-poppler-has-dropped-them-.patch b/meta-efl/recipes-efl/efl/epdf/0001-remove-antialias-functions-poppler-has-dropped-them-.patch
new file mode 100644
index 000000000..728ffa6e3
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/epdf/0001-remove-antialias-functions-poppler-has-dropped-them-.patch
@@ -0,0 +1,132 @@
1From 6691ac5fcbac0e766d4410ae649a13957ae85289 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 22 Oct 2015 16:27:52 +0200
4Subject: [PATCH 1/2] remove antialias functions - poppler has dropped them in
5 the API
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10The functions removed were not used.
11
12Upstream-Status: pending
13
14Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
15---
16 src/lib/epdf_main.h | 45 -----------------------------------
17 src/lib/mupdf/epdf_mupdf_main.c | 18 --------------
18 src/lib/poppler/epdf_poppler_main.cpp | 21 ----------------
19 3 files changed, 84 deletions(-)
20
21diff --git a/src/lib/epdf_main.h b/src/lib/epdf_main.h
22index 54a57ca..0a79bad 100644
23--- a/src/lib/epdf_main.h
24+++ b/src/lib/epdf_main.h
25@@ -29,49 +29,4 @@ EAPI int epdf_shutdown();
26 */
27 EAPI const char *epdf_backend_version_get (void);
28
29-/**
30- * @brief Return the state of fonts antialiasing in Poppler
31- *
32- * @return EINA_TRUE if fonts antialiasing enabled, EINA_FALSE otherwise.
33- *
34- * Return EINA_TRUE if the state of fonts antialiasing is enabled in
35- * Poppler, EINA_FALSE otherwise.
36- *
37- * @ingroup Epdf_Main
38- */
39-EAPI Eina_Bool epdf_fonts_antialias_get (void);
40-
41-/**
42- * @brief Sets fonts antialiasing mode in Poppler
43- *
44- * @param on EINA_TRUE to enable fonts antialiasing, EINA_FALSE to disable
45- *
46- * Set @p on to EINA_TRUE to enable fonts antialiasing in Poppler,
47- * EINA_FALSE to disable it.
48- */
49-EAPI void epdf_fonts_antialias_set (Eina_Bool on);
50-
51-/**
52- * @brief Return the state of lines antialiasing in Poppler
53- *
54- * @return EINA_TRUE if lines antialiasing enabled, EINA_FALSE otherwise.
55- *
56- * Return EINA_TRUE if the state of lines antialiasing is enabled in
57- * Poppler, EINA_FALSE otherwise.
58- *
59- * @ingroup Epdf_Main
60- */
61-EAPI Eina_Bool epdf_lines_antialias_get (void);
62-
63-/**
64- * @brief Sets lines antialiasing mode in Poppler
65- *
66- * @param on EINA_TRUE to enable lines antialiasing, EINA_FALSE to disable
67- *
68- * Set @p on to EINA_TRUE to enable lines antialiasing in Poppler,
69- * EINA_FALSE to disable it.
70- */
71-EAPI void epdf_lines_antialias_set (Eina_Bool on);
72-
73-
74 #endif /* __EPDF_MAIN_H__ */
75diff --git a/src/lib/mupdf/epdf_mupdf_main.c b/src/lib/mupdf/epdf_mupdf_main.c
76index 17bb830..27c6de2 100644
77--- a/src/lib/mupdf/epdf_mupdf_main.c
78+++ b/src/lib/mupdf/epdf_mupdf_main.c
79@@ -37,21 +37,3 @@ epdf_backend_version_get (void)
80 {
81 return "0.5";
82 }
83-
84-Eina_Bool epdf_fonts_antialias_get(void)
85-{
86- return EINA_TRUE;
87-}
88-
89-void epdf_fonts_antialias_set(Eina_Bool on)
90-{
91-}
92-
93-Eina_Bool epdf_lines_antialias_get(void)
94-{
95- return EINA_TRUE;
96-}
97-
98-void epdf_lines_antialias_set(Eina_Bool on)
99-{
100-}
101diff --git a/src/lib/poppler/epdf_poppler_main.cpp b/src/lib/poppler/epdf_poppler_main.cpp
102index 9841987..9efdbe8 100644
103--- a/src/lib/poppler/epdf_poppler_main.cpp
104+++ b/src/lib/poppler/epdf_poppler_main.cpp
105@@ -46,24 +46,3 @@ epdf_backend_version_get (void)
106 {
107 return POPPLER_VERSION;
108 }
109-
110-Eina_Bool epdf_fonts_antialias_get (void)
111-{
112- return globalParams->getAntialias();
113-}
114-
115-void epdf_fonts_antialias_set (Eina_Bool on)
116-{
117- /* Nice API */
118- globalParams->setAntialias((char*)(on ? "yes" : "no"));
119-}
120-
121-Eina_Bool epdf_lines_antialias_get (void)
122-{
123- return globalParams->getVectorAntialias();
124-}
125-
126-void epdf_lines_antialias_set (Eina_Bool on)
127-{
128- globalParams->setVectorAntialias((char*)(on ? "yes" : "no"));
129-}
130--
1312.1.0
132
diff --git a/meta-efl/recipes-efl/efl/epdf/0002-epdf_poppler_postscript.cpp-fix-build-for-poppler-AP.patch b/meta-efl/recipes-efl/efl/epdf/0002-epdf_poppler_postscript.cpp-fix-build-for-poppler-AP.patch
new file mode 100644
index 000000000..c9adaa731
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/epdf/0002-epdf_poppler_postscript.cpp-fix-build-for-poppler-AP.patch
@@ -0,0 +1,45 @@
1From a84c16fdc606f22b993f870b1cea56dd060a35e6 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 22 Oct 2015 16:55:30 +0200
4Subject: [PATCH 2/2] epdf_poppler_postscript.cpp: fix build for poppler API
5 change
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10Poppler API was changed in [1]. The patch not only shows the change but also
11inspires how to fix.
12
13[1] http://cgit.freedesktop.org/poppler/poppler/commit/?id=9caf7525409d699c16896653528486451123b485
14
15Upstream-Status: Pending
16
17Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
18---
19 src/lib/poppler/epdf_poppler_postscript.cpp | 7 +++++--
20 1 file changed, 5 insertions(+), 2 deletions(-)
21
22diff --git a/src/lib/poppler/epdf_poppler_postscript.cpp b/src/lib/poppler/epdf_poppler_postscript.cpp
23index 0c2836b..656193b 100644
24--- a/src/lib/poppler/epdf_poppler_postscript.cpp
25+++ b/src/lib/poppler/epdf_poppler_postscript.cpp
26@@ -82,11 +82,14 @@ epdf_postscript_print (const Epdf_Postscript *postscript)
27
28 // FIXME: fix postscript title
29 #ifdef HAVE_POPPLER_0_20
30+ std::vector<int> pages;
31+ for (int i = postscript->first_page; i <= postscript->last_page; ++i) {
32+ pages.push_back(i);
33+ }
34 PSOutputDev ps_dev(postscript->filename,
35 postscript->pdfdoc,
36 (char *)"PS title",
37- postscript->first_page,
38- postscript->last_page,
39+ pages,
40 psModePS,
41 (int)postscript->width,
42 (int)postscript->height,
43--
442.1.0
45
diff --git a/meta-efl/recipes-efl/efl/epdf_svn.bb b/meta-efl/recipes-efl/efl/epdf_svn.bb
index a2adf6a20..e32a5fdb0 100644
--- a/meta-efl/recipes-efl/efl/epdf_svn.bb
+++ b/meta-efl/recipes-efl/efl/epdf_svn.bb
@@ -11,7 +11,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
11 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \ 11 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
12" 12"
13 13
14SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \ 14SRC_URI = " \
15 ${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \
16 file://0001-remove-antialias-functions-poppler-has-dropped-them-.patch \
17 file://0002-epdf_poppler_postscript.cpp-fix-build-for-poppler-AP.patch \
15" 18"
16S = "${WORKDIR}/${SRCNAME}" 19S = "${WORKDIR}/${SRCNAME}"
17 20
@@ -22,6 +25,3 @@ EXTRA_OECONF = "\
22 25
23# Some upgrade path tweaking, as in evas 26# Some upgrade path tweaking, as in evas
24AUTO_LIBNAME_PKGS = "" 27AUTO_LIBNAME_PKGS = ""
25
26# 2_0.1.0+svnr82070-r0/epdf/src/lib/poppler/epdf_poppler_main.cpp:52:24: error: 'class GlobalParams' has no member named 'getAntialias'
27PNBLACKLIST[epdf] ?= "BROKEN: fails to build with newer poppler"