diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 13:18:55 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:22:02 +0200 |
commit | 48442f26214e67567321e9091f2c43f745cfe980 (patch) | |
tree | d2e0534b16f7f67e08c3e426367965047d36d786 /meta-efl | |
parent | 7baa466291ecdce5d36fb6cfa17689d2419549ba (diff) | |
download | meta-openembedded-48442f26214e67567321e9091f2c43f745cfe980.tar.gz |
entrance: move systemd support from meta-systemd back to meta-efl
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/efl/entrance/entrance.service | 8 | ||||
-rw-r--r-- | meta-efl/recipes-efl/efl/entrance_svn.bb | 19 |
2 files changed, 26 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/entrance/entrance.service b/meta-efl/recipes-efl/efl/entrance/entrance.service new file mode 100644 index 000000000..482868695 --- /dev/null +++ b/meta-efl/recipes-efl/efl/entrance/entrance.service | |||
@@ -0,0 +1,8 @@ | |||
1 | [Unit] | ||
2 | Description=Login manager for Enlightenment | ||
3 | |||
4 | [Service] | ||
5 | ExecStart=/usr/sbin/entrance | ||
6 | |||
7 | [Install] | ||
8 | Alias=display-manager.service | ||
diff --git a/meta-efl/recipes-efl/efl/entrance_svn.bb b/meta-efl/recipes-efl/efl/entrance_svn.bb index 585d552c2..02eb64ba9 100644 --- a/meta-efl/recipes-efl/efl/entrance_svn.bb +++ b/meta-efl/recipes-efl/efl/entrance_svn.bb | |||
@@ -4,18 +4,35 @@ LICENSE = "GPLv3+" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
5 | SECTION = "e/apps" | 5 | SECTION = "e/apps" |
6 | 6 | ||
7 | inherit e gettext | 7 | inherit e gettext systemd |
8 | SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \ | 8 | SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};protocol=http;scmdata=keep \ |
9 | file://0001-pam-use-common-auth-instead-of-system-auth.patch \ | 9 | file://0001-pam-use-common-auth-instead-of-system-auth.patch \ |
10 | file://entrance.service \ | ||
10 | " | 11 | " |
11 | S = "${WORKDIR}/${SRCNAME}" | 12 | S = "${WORKDIR}/${SRCNAME}" |
12 | 13 | ||
13 | EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}" | 14 | EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}" |
14 | 15 | ||
16 | PR = "r4" | ||
15 | PV = "0.0.4+svnr${SRCPV}" | 17 | PV = "0.0.4+svnr${SRCPV}" |
16 | SRCREV = "${EFL_SRCREV}" | 18 | SRCREV = "${EFL_SRCREV}" |
17 | 19 | ||
18 | RDEPENDS_${PN} += "${PN}-themes sessreg xauth" | 20 | RDEPENDS_${PN} += "${PN}-themes sessreg xauth" |
19 | CONFFILES_${PN} += "${sysconfdir}/entrance.conf" | 21 | CONFFILES_${PN} += "${sysconfdir}/entrance.conf" |
22 | |||
20 | RCONFLICTS_${PN} += "xserver-nodm-init" | 23 | RCONFLICTS_${PN} += "xserver-nodm-init" |
21 | RREPLACES_${PN} += "xserver-nodm-init" | 24 | RREPLACES_${PN} += "xserver-nodm-init" |
25 | |||
26 | RCONFLICTS_${PN} += "xserver-nodm-init-systemd" | ||
27 | RREPLACES_${PN} += "xserver-nodm-init-systemd" | ||
28 | |||
29 | RPROVIDES_${PN} += "${PN}-systemd" | ||
30 | RREPLACES_${PN} += "${PN}-systemd" | ||
31 | RCONFLICTS_${PN} += "${PN}-systemd" | ||
32 | |||
33 | SYSTEMD_SERVICE_${PN} = "entrance.service" | ||
34 | |||
35 | do_install_append() { | ||
36 | install -d ${D}${systemd_unitdir}/system | ||
37 | install -m 0644 ${WORKDIR}/entrance.service ${D}${systemd_unitdir}/system | ||
38 | } | ||