summaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-08-25 15:26:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-27 12:49:20 +0200
commit46698617eb3ee7a5a2c638759654b6076a7bc058 (patch)
tree66e40e6653c7cb78ca83d9ec0e6c7b0367a41546 /meta-efl
parent49cb17b4978bf586311f5b8ab4b1b3810098c297 (diff)
downloadmeta-openembedded-46698617eb3ee7a5a2c638759654b6076a7bc058.tar.gz
e-wm: add git recipe with latest revision
* E19 is still in alpha stage, but I was told that many things work there better than old(ish) E18 * last announcement: https://phab.enlightenment.org/phame/live/3/post/e19_alpha2_now_with_50_more_explosions/ * but be aware that illume2 modules are gone and config mobile doesn't work without them * there is new tiling config Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/e17/e-wm.inc5
-rw-r--r--meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch29
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_0.18.8.bb6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_git.bb14
4 files changed, 48 insertions, 6 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc
index 122a60e8b..0ff26ef9c 100644
--- a/meta-efl/recipes-efl/e17/e-wm.inc
+++ b/meta-efl/recipes-efl/e17/e-wm.inc
@@ -10,6 +10,8 @@ S = "${WORKDIR}/${SRCNAME}"
10PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 10PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
11 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 11 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
12PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam" 12PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
13PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
14
13 15
14EXTRA_OECONF = "\ 16EXTRA_OECONF = "\
15 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \ 17 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
@@ -21,6 +23,7 @@ EXTRA_OECONF = "\
21 23
22do_configure_prepend() { 24do_configure_prepend() {
23 autopoint || true 25 autopoint || true
26 sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
24} 27}
25 28
26do_install_append() { 29do_install_append() {
@@ -70,6 +73,7 @@ PACKAGES =+ "\
70 ${PN}-config-netbook \ 73 ${PN}-config-netbook \
71 ${PN}-config-scaleable \ 74 ${PN}-config-scaleable \
72 ${PN}-config-standard \ 75 ${PN}-config-standard \
76 ${PN}-config-tiling \
73 ${PN}-theme-default \ 77 ${PN}-theme-default \
74 ${PN}-background-dark-gradient \ 78 ${PN}-background-dark-gradient \
75 ${PN}-background-light-gradient \ 79 ${PN}-background-light-gradient \
@@ -126,6 +130,7 @@ FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist
126FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook" 130FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
127FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable" 131FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
128FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard" 132FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
133FILES_${PN}-config-tiling = "${datadir}/enlightenment/data/config/tiling"
129FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj" 134FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
130FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj" 135FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
131FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj" 136FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"
diff --git a/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch b/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch
new file mode 100644
index 000000000..14899d514
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-wm/0001-configure.ac-add-foreign.patch
@@ -0,0 +1,29 @@
1From 8526270c418a5dc3d737a8eaff315209433f69d2 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Mon, 25 Aug 2014 16:06:03 +0200
4Subject: [PATCH] configure.ac: add foreign
5
6* fixes:
7 | configure.ac:312: error: required file './ABOUT-NLS' not found
8
9Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
10---
11 configure.ac | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/configure.ac b/configure.ac
15index 62c0f6d..49b290b 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -34,7 +34,7 @@ AH_BOTTOM([
19 #endif /* EFL_CONFIG_H__ */
20 ])
21
22-AM_INIT_AUTOMAKE([1.11 dist-bzip2 -Wno-portability])
23+AM_INIT_AUTOMAKE([1.11 dist-bzip2 -Wno-portability foreign])
24 AM_SILENT_RULES([yes])
25
26 AC_USE_SYSTEM_EXTENSIONS
27--
282.0.4
29
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb b/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
index 0d65ca0bf..6b4c9fc54 100644
--- a/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_0.18.8.bb
@@ -13,9 +13,3 @@ SRC_URI = "\
13 13
14SRC_URI[md5sum] = "79c9f524e1d0510061c62c4b038a8ece" 14SRC_URI[md5sum] = "79c9f524e1d0510061c62c4b038a8ece"
15SRC_URI[sha256sum] = "14c9bde4334d2f8b0776c6113d02b923ab159eea1cbf7013489e4f3bf37a51bb" 15SRC_URI[sha256sum] = "14c9bde4334d2f8b0776c6113d02b923ab159eea1cbf7013489e4f3bf37a51bb"
16
17do_configure_prepend() {
18 sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
19}
20
21PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
diff --git a/meta-efl/recipes-efl/e17/e-wm_git.bb b/meta-efl/recipes-efl/e17/e-wm_git.bb
new file mode 100644
index 000000000..4bf1b9693
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-wm_git.bb
@@ -0,0 +1,14 @@
1require ${BPN}.inc
2
3PV = "0.18.999+0.19-alpha2+git${SRCPV}"
4DEFAULT_PREFERENCE = "-1"
5
6SRC_URI = " \
7 git://git.enlightenment.org/core/enlightenment.git \
8 file://0001-configure.ac-add-foreign.patch \
9 file://enlightenment_start.oe \
10 file://applications.menu \
11"
12S = "${WORKDIR}/git"
13
14SRCREV = "525b963133d7168226b8e07ba26730212a8b7e82"