diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-10-18 00:56:55 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-10-18 16:04:30 +0200 |
commit | 2f837d52d3956e83389842b0e06b1f02ff5c8a77 (patch) | |
tree | 41349c3e231fb2c35a661c21eba212ccada6dd62 /meta-efl | |
parent | 359a5968f27008d6fcbaee5137c237bfcabd2579 (diff) | |
download | meta-openembedded-2f837d52d3956e83389842b0e06b1f02ff5c8a77.tar.gz |
webkit-efl: upgrade to 1.6.1
* revert.r78057.patch is not needed, because context menus were removed from eve in r59455
* we still need to force ARM mode, only the segfault is different:
| /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source/JavaScriptCore/heap/HandleTypes.h: In static member function 'static T* JSC::HandleTypes<T>::getFromSlot(JSC::HandleSlot) [with T = JSC::Structure, JSC::HandleTypes<T>::ExternalType = JSC::Structure*, JSC::HandleSlot = JSC::JSValue*]':
| /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source/JavaScriptCore/heap/Handle.h:126:79: instantiated from 'JSC::Handle<T>::ExternalType JSC::Handle<T>::get() const [with T = JSC::Structure, JSC::Handle<T>::ExternalType = JSC::Structure*]'
| /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source/JavaScriptCore/runtime/ScopeChain.h:39:75: instantiated from here
| /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source/JavaScriptCore/heap/HandleTypes.h:38:130: warning: cast from 'JSC::JSCell*' to 'JSC::HandleTypes<JSC::Structure>::ExternalType {aka JSC::Structure*}' increases required alignment of target type [-Wcast-align]
| {standard input}: Assembler messages:
| {standard input}:1116: Error: invalid immediate: 983040 is out of range
| {standard input}:1116: Error: value of 983040 too large for field of 2 bytes at 28
| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819
| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as)
| Please submit a full bug report,
| with preprocessed source if appropriate.
| See <http://gcc.gnu.org/bugs.html> for instructions.
| make[2]: *** [JavaScriptCore/CMakeFiles/javascriptcore_efl.dir/jit/JIT.cpp.o] Error 4
| make[2]: *** Waiting for unfinished jobs....
| {standard input}: Assembler messages:
| {standard input}:2059: Error: invalid immediate: 983040 is out of range
| {standard input}:2059: Error: value of 983040 too large for field of 2 bytes at 28
| /OE/shr-core/tmp/sysroots/x86_64-linux/usr/libexec/armv4t-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.6.2/as: BFD (GNU Binutils) 2.21.1 assertion fail /OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/binutils-cross-2.21.1a-r0/binutils-2.21.1/bfd/elf.c:2819
| arm-oe-linux-gnueabi-g++: internal compiler error: Segmentation fault (program as)
| Please submit a full bug report,
| with preprocessed source if appropriate.
| See <http://gcc.gnu.org/bugs.html> for instructions.
| make[2]: *** [JavaScriptCore/CMakeFiles/javascriptcore_efl.dir/jit/JITOpcodes32_64.cpp.o] Error 4
| make[2]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source'
| make[1]: *** [JavaScriptCore/CMakeFiles/javascriptcore_efl.dir/all] Error 2
| make[1]: Leaving directory `/OE/shr-core/tmp/work/armv4t-oe-linux-gnueabi/webkit-efl-1.6.1+svnr97672-r0/src/Source'
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch | 19 | ||||
-rw-r--r-- | meta-efl/recipes-efl/webkit/webkit-efl_svn.bb | 11 |
2 files changed, 2 insertions, 28 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch deleted file mode 100644 index 966a977ee..000000000 --- a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | see https://bugs.webkit.org/show_bug.cgi?id=50762 | ||
2 | fixed by: | ||
3 | http://trac.webkit.org/changeset/78047/trunk/Source/WebCore/CMakeLists.txt | ||
4 | fix reverted by: | ||
5 | http://trac.webkit.org/changeset/78057/trunk/Source/WebCore/CMakeLists.txt | ||
6 | |||
7 | so revert revert as we care about webkit-efl and don't care about WinCE | ||
8 | |||
9 | Index: Source/WebCore/CMakeLists.txt | ||
10 | =================================================================== | ||
11 | --- Source/WebCore/CMakeLists.txt (revision 78042) | ||
12 | +++ Source/WebCore/CMakeLists.txt (revision 78047) | ||
13 | @@ -1157,6 +1157,4 @@ | ||
14 | |||
15 | platform/Arena.cpp | ||
16 | - platform/ContextMenu.cpp | ||
17 | - platform/ContextMenuItem.cpp | ||
18 | platform/ContentType.cpp | ||
19 | platform/CrossThreadCopier.cpp | ||
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb index bffded788..9f02a595e 100644 --- a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb +++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb | |||
@@ -9,27 +9,20 @@ DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \ | |||
9 | libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \ | 9 | libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \ |
10 | libxml2 pango eina ecore evas edje" | 10 | libxml2 pango eina ecore evas edje" |
11 | 11 | ||
12 | SRCREV = "79192" | 12 | SRCREV = "97724" |
13 | PV = "1.3.11+svnr${SRCPV}" | 13 | PV = "1.6.1+svnr${SRCPV}" |
14 | 14 | ||
15 | SRCREV_FORMAT = "source" | 15 | SRCREV_FORMAT = "source" |
16 | 16 | ||
17 | SRC_URI = "\ | 17 | SRC_URI = "\ |
18 | svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \ | 18 | svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \ |
19 | svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ | 19 | svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \ |
20 | file://revert.r78057.patch \ | ||
21 | " | 20 | " |
22 | 21 | ||
23 | S = "${WORKDIR}/src/Source" | 22 | S = "${WORKDIR}/src/Source" |
24 | 23 | ||
25 | inherit cmake lib_package pkgconfig perlnative | 24 | inherit cmake lib_package pkgconfig perlnative |
26 | 25 | ||
27 | # Wants to jump too far for THUMB on armv4t | ||
28 | # in WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)': | ||
29 | # DocTypeStrings.cpp:(.text._ZN7WebCore18DocTypeStringsHash21doctype_hash_functionEPKcj[WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)]+0x12): relocation truncated to fit: R_ARM_THM_CALL against symbol `__gnu_thumb1_case_uhi' defined in .text section in x86_64-linux/usr/armv4t/lib/gcc/arm-oe-linux-gnueabi/4.5.2/libgcc.a(_thumb1_case_uhi.o) | ||
30 | # the same in WebCore::CSSValueKeywordsHash::value_hash_function(char const*, unsigned int)': | ||
31 | # WebCore::CSSPropertyNamesHash::propery_hash_function(char const*, unsigned int)': | ||
32 | # WebCore::ColorDataHash::colordata_hash_function(char const*, unsigned int)': | ||
33 | ARM_INSTRUCTION_SET = "arm" | 26 | ARM_INSTRUCTION_SET = "arm" |
34 | 27 | ||
35 | EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON" | 28 | EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON" |