diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-10-27 18:42:37 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-11-29 11:04:53 +0100 |
commit | 19090f5ed4c89a2229e68ca1e84a85a1d82cf426 (patch) | |
tree | 7448156cf77bd792ff9d4f10620938cfaf465885 /meta-efl | |
parent | b11ee8bc74c3b62a07a4d372cc15b32074255be9 (diff) | |
download | meta-openembedded-19090f5ed4c89a2229e68ca1e84a85a1d82cf426.tar.gz |
ecore: disable some X extensions for native recipe and add libxfixes to target DEPENDS
* at least native libxrandr libxdamage libxcursor libxcomposite
libxfixes are autodetected sometimes, leading to irreproducible builds
and failing edje_cc
/OE/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/edje_cc: error while loading shared libraries: libXcursor.so.1: cannot open shared object file: No such file or directory
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/efl/ecore.inc | 19 |
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-efl/recipes-efl/efl/ecore.inc b/meta-efl/recipes-efl/efl/ecore.inc index 7744501b8..d329f573f 100644 --- a/meta-efl/recipes-efl/efl/ecore.inc +++ b/meta-efl/recipes-efl/efl/ecore.inc | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "Ecore is the Enlightenment application framework library" | |||
2 | LICENSE = "MIT BSD" | 2 | LICENSE = "MIT BSD" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d6ff2c3c85de2faf5fd7dcd9ccfc8886" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d6ff2c3c85de2faf5fd7dcd9ccfc8886" |
4 | DEPENDS = "virtual/libiconv tslib curl eet evas glib-2.0 gnutls \ | 4 | DEPENDS = "virtual/libiconv tslib curl eet evas glib-2.0 gnutls \ |
5 | libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor" | 5 | libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxfixes" |
6 | DEPENDS_virtclass-native = "eet-native evas-native gettext-native" | 6 | DEPENDS_virtclass-native = "eet-native evas-native gettext-native" |
7 | # optional | 7 | # optional |
8 | # DEPENDS += "directfb virtual/libsdl openssl virtual/libiconv" | 8 | # DEPENDS += "directfb virtual/libsdl openssl virtual/libiconv" |
@@ -10,7 +10,7 @@ DEPENDS_virtclass-native = "eet-native evas-native gettext-native" | |||
10 | inherit efl gettext | 10 | inherit efl gettext |
11 | 11 | ||
12 | BBCLASSEXTEND = "native" | 12 | BBCLASSEXTEND = "native" |
13 | INC_PR = "r1" | 13 | INC_PR = "r2" |
14 | 14 | ||
15 | do_configure_prepend() { | 15 | do_configure_prepend() { |
16 | touch ${S}/po/Makefile.in.in || true | 16 | touch ${S}/po/Makefile.in.in || true |
@@ -96,4 +96,19 @@ EXTRA_OECONF = "${ECORE_OECONF} \ | |||
96 | EXTRA_OECONF_virtclass-native = "\ | 96 | EXTRA_OECONF_virtclass-native = "\ |
97 | ${ECORE_OECONF} \ | 97 | ${ECORE_OECONF} \ |
98 | --disable-curl \ | 98 | --disable-curl \ |
99 | --disable-ecore-x-composite \ | ||
100 | --disable-ecore-x-damage \ | ||
101 | --disable-ecore-x-dpms \ | ||
102 | --disable-ecore-x-randr \ | ||
103 | --disable-ecore-x-render \ | ||
104 | --disable-ecore-x-screensaver \ | ||
105 | --disable-ecore-x-shape \ | ||
106 | --disable-ecore-x-sync \ | ||
107 | --disable-ecore-x-xfixes \ | ||
108 | --disable-ecore-x-xinerama \ | ||
109 | --disable-ecore-x-xprint \ | ||
110 | --disable-ecore-x-xtest \ | ||
111 | --disable-ecore-x-cursor \ | ||
112 | --disable-ecore-x-input \ | ||
113 | --disable-ecore-x-dri \ | ||
99 | " | 114 | " |