diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:54 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:39 +0200 |
commit | 0d7c6151c51fc29706c2d65fa9a4ec8d17da4cb5 (patch) | |
tree | 88f8c62d51309aa55cdc53aa90f881f25b9bfaba /meta-efl/recipes-efl | |
parent | ab9f4d9ab21199278ac868378a8566eeeeac4090 (diff) | |
download | meta-openembedded-0d7c6151c51fc29706c2d65fa9a4ec8d17da4cb5.tar.gz |
meta-efl: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl')
-rw-r--r-- | meta-efl/recipes-efl/e17/e-wm.inc | 4 | ||||
-rw-r--r-- | meta-efl/recipes-efl/efl/entrance_svn.bb | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc index 45637f366..444ec8959 100644 --- a/meta-efl/recipes-efl/e17/e-wm.inc +++ b/meta-efl/recipes-efl/e17/e-wm.inc | |||
@@ -7,8 +7,8 @@ SRCNAME = "e" | |||
7 | inherit e update-alternatives gettext pkgconfig | 7 | inherit e update-alternatives gettext pkgconfig |
8 | S = "${WORKDIR}/${SRCNAME}" | 8 | S = "${WORKDIR}/${SRCNAME}" |
9 | 9 | ||
10 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ | 10 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ |
11 | ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | 11 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
12 | PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam" | 12 | PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam" |
13 | PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" | 13 | PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" |
14 | 14 | ||
diff --git a/meta-efl/recipes-efl/efl/entrance_svn.bb b/meta-efl/recipes-efl/efl/entrance_svn.bb index 337473705..2888dc8dc 100644 --- a/meta-efl/recipes-efl/efl/entrance_svn.bb +++ b/meta-efl/recipes-efl/efl/entrance_svn.bb | |||
@@ -16,7 +16,7 @@ PNBLACKLIST[entrance] ?= "broken: switch to https://git.enlightenment.org/misc/e | |||
16 | PACKAGECONFIG ??= "" | 16 | PACKAGECONFIG ??= "" |
17 | PACKAGECONFIG[consolekit] = "--enable-consolekit,--disable-consolekit,consolekit" | 17 | PACKAGECONFIG[consolekit] = "--enable-consolekit,--disable-consolekit,consolekit" |
18 | 18 | ||
19 | EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}" | 19 | EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '--disable-pam', d)}" |
20 | 20 | ||
21 | PR = "r7" | 21 | PR = "r7" |
22 | PV = "0.0.4+svnr${SRCPV}" | 22 | PV = "0.0.4+svnr${SRCPV}" |