diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-10-21 10:52:39 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-11-01 09:57:03 +0100 |
commit | 776cb915ff4123a55eb1a03fa11c705339118da3 (patch) | |
tree | 4874b720be03674c2bbeef9a2f6f172baaa38df5 /meta-efl/recipes-efl | |
parent | 56a5dd99ba764baa91e561c96aa413aa1a312c2e (diff) | |
download | meta-openembedded-776cb915ff4123a55eb1a03fa11c705339118da3.tar.gz |
e-base: bump EFL_SRCREV and refresh patches and elementary version
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl')
-rw-r--r-- | meta-efl/recipes-efl/efl/ecore/exit_uclibc.patch | 12 | ||||
-rw-r--r-- | meta-efl/recipes-efl/efl/ecore/fix-ecore-fb-initialization.patch | 44 | ||||
-rw-r--r-- | meta-efl/recipes-efl/efl/ecore_svn.bb | 1 | ||||
-rw-r--r-- | meta-efl/recipes-efl/efl/elementary_svn.bb | 3 |
4 files changed, 29 insertions, 31 deletions
diff --git a/meta-efl/recipes-efl/efl/ecore/exit_uclibc.patch b/meta-efl/recipes-efl/efl/ecore/exit_uclibc.patch deleted file mode 100644 index 3d04453eb..000000000 --- a/meta-efl/recipes-efl/efl/ecore/exit_uclibc.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | diff -uNr ecore.orig//src/lib/ecore_con/ecore_con_info.c ecore/src/lib/ecore_con/ecore_con_info.c | ||
2 | --- ecore.orig//src/lib/ecore_con/ecore_con_info.c 2010-08-13 14:31:18.000000000 +0200 | ||
3 | +++ ecore/src/lib/ecore_con/ecore_con_info.c 2010-08-13 14:49:37.000000000 +0200 | ||
4 | @@ -283,7 +283,7 @@ | ||
5 | |||
6 | err = write(fd[1], "", 1); | ||
7 | close(fd[1]); | ||
8 | -#ifdef __USE_ISOC99 | ||
9 | +#if defined(__USE_ISOC99) && !defined(__UCLIBC__) | ||
10 | _Exit(0); | ||
11 | #else | ||
12 | _exit(0); | ||
diff --git a/meta-efl/recipes-efl/efl/ecore/fix-ecore-fb-initialization.patch b/meta-efl/recipes-efl/efl/ecore/fix-ecore-fb-initialization.patch index 216b5a5bb..a2ce28526 100644 --- a/meta-efl/recipes-efl/efl/ecore/fix-ecore-fb-initialization.patch +++ b/meta-efl/recipes-efl/efl/ecore/fix-ecore-fb-initialization.patch | |||
@@ -1,25 +1,34 @@ | |||
1 | # | 1 | From c36cd1201711560b914e567922903083c3b46ff1 Mon Sep 17 00:00:00 2001 |
2 | # The whole ecore-fb init logic is somewhat flawed; with this patch we | 2 | From: Martin Jansa <Martin.Jansa@gmail.com> |
3 | # get at least a working touchscreen w/ tslib again. | 3 | Date: Sat, 29 Oct 2011 00:16:55 +0200 |
4 | # | 4 | Subject: [PATCH] ecore-fb: fix ts init |
5 | # Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de> | ||
6 | # | ||
7 | 5 | ||
8 | diff --git ecore.old/src/lib/ecore_fb/ecore_fb.c ecore/src/lib/ecore_fb/ecore_fb.c | 6 | Upstream-Status: Pending |
9 | index 77071e3..a4e1c5d 100644 | 7 | |
10 | --- ecore.old/src/lib/ecore_fb/ecore_fb.c | 8 | The whole ecore-fb init logic is somewhat flawed; with this patch we |
11 | +++ ecore/src/lib/ecore_fb/ecore_fb.c | 9 | get at least a working touchscreen w/ tslib again. |
12 | @@ -46,6 +46,9 @@ ecore_fb_init(const char *name __UNUSED__) | 10 | |
11 | Signed-off-by: Michael 'Mickey' Lauer <mlauer@vanille-media.de> | ||
12 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
13 | --- | ||
14 | src/lib/ecore_fb/ecore_fb.c | 4 ++++ | ||
15 | 1 files changed, 4 insertions(+), 0 deletions(-) | ||
16 | |||
17 | diff --git a/src/lib/ecore_fb/ecore_fb.c b/src/lib/ecore_fb/ecore_fb.c | ||
18 | index ca7d73d..5b99989 100644 | ||
19 | --- a/src/lib/ecore_fb/ecore_fb.c | ||
20 | +++ b/src/lib/ecore_fb/ecore_fb.c | ||
21 | @@ -39,6 +39,9 @@ ecore_fb_init(const char *name __UNUSED__) | ||
13 | if (!ecore_fb_vt_init()) | 22 | if (!ecore_fb_vt_init()) |
14 | return --_ecore_fb_init_count; | 23 | return --_ecore_fb_init_count; |
15 | 24 | ||
16 | + if (!ecore_fb_ts_init()) | 25 | + if (!ecore_fb_ts_init()) |
17 | + return --_ecore_fb_init_count; | 26 | + return --_ecore_fb_init_count; |
18 | + | 27 | + |
19 | ECORE_FB_EVENT_KEY_DOWN = ecore_event_type_new(); | 28 | _ecore_fb_size_get(&_ecore_fb_console_w, &_ecore_fb_console_h); |
20 | ECORE_FB_EVENT_KEY_UP = ecore_event_type_new(); | 29 | |
21 | ECORE_FB_EVENT_MOUSE_BUTTON_DOWN = ecore_event_type_new(); | 30 | return _ecore_fb_init_count; |
22 | @@ -72,6 +75,7 @@ ecore_fb_shutdown(void) | 31 | @@ -59,6 +62,7 @@ ecore_fb_shutdown(void) |
23 | if (--_ecore_fb_init_count != 0) | 32 | if (--_ecore_fb_init_count != 0) |
24 | return _ecore_fb_init_count; | 33 | return _ecore_fb_init_count; |
25 | 34 | ||
@@ -27,3 +36,6 @@ index 77071e3..a4e1c5d 100644 | |||
27 | ecore_fb_vt_shutdown(); | 36 | ecore_fb_vt_shutdown(); |
28 | 37 | ||
29 | return _ecore_fb_init_count; | 38 | return _ecore_fb_init_count; |
39 | -- | ||
40 | 1.7.7.1 | ||
41 | |||
diff --git a/meta-efl/recipes-efl/efl/ecore_svn.bb b/meta-efl/recipes-efl/efl/ecore_svn.bb index 99fb3e208..c71c1b9ec 100644 --- a/meta-efl/recipes-efl/efl/ecore_svn.bb +++ b/meta-efl/recipes-efl/efl/ecore_svn.bb | |||
@@ -7,7 +7,6 @@ DEFAULT_PREFERENCE = "-1" | |||
7 | 7 | ||
8 | SRC_URI = "\ | 8 | SRC_URI = "\ |
9 | ${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \ | 9 | ${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \ |
10 | file://exit_uclibc.patch \ | ||
11 | file://fix-ecore-fb-initialization.patch \ | 10 | file://fix-ecore-fb-initialization.patch \ |
12 | " | 11 | " |
13 | S = "${WORKDIR}/${SRCNAME}" | 12 | S = "${WORKDIR}/${SRCNAME}" |
diff --git a/meta-efl/recipes-efl/efl/elementary_svn.bb b/meta-efl/recipes-efl/efl/elementary_svn.bb index 1034e0f8e..6162abda2 100644 --- a/meta-efl/recipes-efl/efl/elementary_svn.bb +++ b/meta-efl/recipes-efl/efl/elementary_svn.bb | |||
@@ -2,8 +2,7 @@ DESCRIPTION = "EFL based widget set for mobile devices" | |||
2 | LICENSE = "LGPLv2.1" | 2 | LICENSE = "LGPLv2.1" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cdc6c12b238ccd62635a7517dfe89438" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cdc6c12b238ccd62635a7517dfe89438" |
4 | DEPENDS = "eet-native efreet evas ecore edje eet edbus ethumb" | 4 | DEPENDS = "eet-native efreet evas ecore edje eet edbus ethumb" |
5 | PV = "0.7.0+svnr${SRCPV}" | 5 | PV = "0.8.0+svnr${SRCPV}" |
6 | PR = "r12" | ||
7 | SRCREV = "${EFL_SRCREV}" | 6 | SRCREV = "${EFL_SRCREV}" |
8 | 7 | ||
9 | inherit efl gettext | 8 | inherit efl gettext |