summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-11-19 14:00:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:14 +0100
commit6153ff53f944a7c0b733bbeda78020227e37f721 (patch)
tree6e11074f00d2967ce4594350369235f2be79b221 /meta-efl/recipes-efl
parentc95e155780a0cf3a8fb59a2f86db6367d18116fc (diff)
downloadmeta-openembedded-6153ff53f944a7c0b733bbeda78020227e37f721.tar.gz
efl: upgrade from separate recipes to shared efl-1.8.5
* eina, evas, eio, efreet, edbus2, ecore, ethumb, emotion, embryo, edje are now built from single source tree * announcements: efl & friends http://sourceforge.net/mailarchive/message.php?msg_id=31733071 EFL 1.8.4 release http://sourceforge.net/mailarchive/message.php?msg_id=31826305 EFL 1.8.5 release http://sourceforge.net/mailarchive/message.php?msg_id=31895179 * be aware that upgrade-path wont probably work correctly and that you have to manually cleanup your sysroots before migrating to new shared efl recipe, for details see https://bugzilla.yoctoproject.org/show_bug.cgi?id=4102 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl')
-rw-r--r--meta-efl/recipes-efl/efl/ecore_1.7.9.bb124
-rw-r--r--meta-efl/recipes-efl/efl/edbus2.inc11
-rw-r--r--meta-efl/recipes-efl/efl/edbus2_svn.bb14
-rw-r--r--meta-efl/recipes-efl/efl/edje_1.7.9.bb72
-rw-r--r--meta-efl/recipes-efl/efl/eet_1.7.9.bb30
-rw-r--r--meta-efl/recipes-efl/efl/eeze_1.7.9.bb23
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc145
-rw-r--r--meta-efl/recipes-efl/efl/efl/0001-configure.ac-Don-t-check-for-Xprint-extension.patch27
-rw-r--r--meta-efl/recipes-efl/efl/efl_1.8.5.bb17
-rw-r--r--meta-efl/recipes-efl/efl/efreet_1.7.9.bb22
-rw-r--r--meta-efl/recipes-efl/efl/eina_1.7.9.bb19
-rw-r--r--meta-efl/recipes-efl/efl/eio_1.7.9.bb15
-rw-r--r--meta-efl/recipes-efl/efl/embryo_1.7.9.bb20
-rw-r--r--meta-efl/recipes-efl/efl/emotion_1.7.9.bb22
-rw-r--r--meta-efl/recipes-efl/efl/ethumb_1.7.9.bb27
-rw-r--r--meta-efl/recipes-efl/efl/evas/0001-evas_font_load-Fix-build-with-newer-freetype.patch26
-rw-r--r--meta-efl/recipes-efl/efl/evas_1.7.9.bb178
17 files changed, 189 insertions, 603 deletions
diff --git a/meta-efl/recipes-efl/efl/ecore_1.7.9.bb b/meta-efl/recipes-efl/efl/ecore_1.7.9.bb
deleted file mode 100644
index ef051591f..000000000
--- a/meta-efl/recipes-efl/efl/ecore_1.7.9.bb
+++ /dev/null
@@ -1,124 +0,0 @@
1SUMMARY = "Ecore is the Enlightenment application framework library"
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d6ff2c3c85de2faf5fd7dcd9ccfc8886"
4DEPENDS = "virtual/libiconv tslib curl eet evas glib-2.0 gnutls \
5 libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxfixes"
6DEPENDS_virtclass-native = "eet-native evas-native gettext-native"
7# optional
8# DEPENDS += "directfb virtual/libsdl openssl virtual/libiconv"
9
10inherit efl gettext
11
12BBCLASSEXTEND = "native"
13
14do_configure_prepend() {
15 touch ${S}/po/Makefile.in.in || true
16 sed -i -e 's: po::g' ${S}/Makefile.am
17}
18
19FILESPATHPKG =. "${BPN}-${PV}:${BPN}:"
20
21PACKAGES =+ "\
22 ${PN}-con \
23 ${PN}-config \
24 ${PN}-desktop \
25 ${PN}-directfb \
26 ${PN}-sdl \
27 ${PN}-evas \
28 ${PN}-fb \
29 ${PN}-file \
30 ${PN}-imf-evas \
31 ${PN}-imf \
32 ${PN}-ipc \
33 ${PN}-job \
34 ${PN}-txt \
35 ${PN}-x \
36 ${PN}-input \
37"
38# Some upgrade path tweaking
39AUTO_LIBNAME_PKGS = ""
40
41FILES_${PN} = "${libdir}/libecore*.so.* \
42 ${bindir} \
43"
44FILES_${PN}-con = "${libdir}/libecore_con*.so.*"
45FILES_${PN}-config = "${libdir}/libecore_config*.so.*"
46FILES_${PN}-desktop = "${libdir}/libecore_desktop*.so.*"
47FILES_${PN}-directfb = "${libdir}/libecore_directfb*.so.*"
48FILES_${PN}-sdl = "${libdir}/libecore_sdl*.so.*"
49FILES_${PN}-evas = "${libdir}/libecore_evas*.so.*"
50FILES_${PN}-fb = "${libdir}/libecore_fb*.so.*"
51FILES_${PN}-file = "${libdir}/libecore_file*.so.*"
52FILES_${PN}-imf = "${libdir}/libecore_imf*.so.* \
53 ${libdir}/ecore/immodules/*.so \
54"
55FILES_${PN}-imf-evas = "${libdir}/libecore_imf_evas*.so.*"
56FILES_${PN}-ipc = "${libdir}/libecore_ipc*.so.*"
57FILES_${PN}-job = "${libdir}/libecore_job*.so.*"
58FILES_${PN}-txt = "${libdir}/libecore_txt*.so.*"
59FILES_${PN}-x = "${libdir}/libecore_x*.so.*"
60FILES_${PN}-input = "${libdir}/libecore_input*.so.*"
61
62ECORE_OECONF = "\
63 --x-includes=${STAGING_INCDIR}/X11 \
64 --x-libraries=${STAGING_LIBDIR} \
65 --enable-simple-x11 \
66 --enable-ecore-config \
67 --enable-ecore-x \
68 --enable-ecore-job \
69 --enable-ecore-fb \
70 --enable-ecore-evas \
71 --enable-ecore-evas-software-16-x11 \
72 --enable-ecore-evas-xrender \
73 --enable-abstract-sockets \
74 --enable-ecore-con \
75 --enable-ecore-ipc \
76 --enable-ecore-file \
77 --enable-inotify \
78 --disable-ecore-desktop \
79 --disable-ecore-x-xcb \
80 --disable-ecore-x-xprint \
81 --disable-ecore-directfb \
82 --disable-ecore-sdl \
83 --enable-ecore-evas-opengl-x11 \
84 --disable-ecore-evas-dfb \
85 --disable-ecore-evas-sdl \
86 --disable-openssl \
87 --disable-poll \
88 --enable-xim \
89"
90
91EXTRA_OECONF = "${ECORE_OECONF} \
92 --enable-curl \
93"
94
95EXTRA_OECONF_virtclass-native = "\
96 ${ECORE_OECONF} \
97 --disable-curl \
98 --disable-ecore-x-composite \
99 --disable-ecore-x-damage \
100 --disable-ecore-x-dpms \
101 --disable-ecore-x-randr \
102 --disable-ecore-x-render \
103 --disable-ecore-x-screensaver \
104 --disable-ecore-x-shape \
105 --disable-ecore-x-sync \
106 --disable-ecore-x-xfixes \
107 --disable-ecore-x-xinerama \
108 --disable-ecore-x-xprint \
109 --disable-ecore-x-xtest \
110 --disable-ecore-x-cursor \
111 --disable-ecore-x-input \
112 --disable-ecore-x-dri \
113"
114
115SRC_URI = "\
116 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
117 file://fix-ecore-fb-initialization.patch \
118"
119
120PACKAGECONFIG ??= ""
121PACKAGECONFIG[wayland] = "--enable-ecore-wayland,--disable-ecore-wayland,wayland xkbcommon"
122
123SRC_URI[md5sum] = "2d5a4fb8f702628f5c7b785309be01ab"
124SRC_URI[sha256sum] = "c145cc00280d3a310c76e5e6a9fb509c81b8b173f04458c97ea4ae6bf563eaf3"
diff --git a/meta-efl/recipes-efl/efl/edbus2.inc b/meta-efl/recipes-efl/efl/edbus2.inc
deleted file mode 100644
index 9b41d8b68..000000000
--- a/meta-efl/recipes-efl/efl/edbus2.inc
+++ /dev/null
@@ -1,11 +0,0 @@
1DESCRIPTION = "DBus convenience wrappers for EFL"
2DEPENDS = "dbus ecore eina"
3LICENSE = "LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4ed65f801204783f71fedafc082038d9"
5
6inherit efl
7
8BBCLASSEXTEND = "native"
9INC_PR = "r0"
10
11SRCNAME = "edbus"
diff --git a/meta-efl/recipes-efl/efl/edbus2_svn.bb b/meta-efl/recipes-efl/efl/edbus2_svn.bb
deleted file mode 100644
index e87f14719..000000000
--- a/meta-efl/recipes-efl/efl/edbus2_svn.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1require ${BPN}.inc
2
3SRCREV = "${EFL_SRCREV}"
4PV = "1.7.99+svnr${SRCPV}"
5PR = "${INC_PR}.2"
6DEFAULT_PREFERENCE = "-1"
7
8SRC_URI = "\
9 ${E_SVN}/trunk/IN-EFL;module=${SRCNAME};protocol=http;scmdata=keep \
10"
11S = "${WORKDIR}/${SRCNAME}"
12
13PACKAGES =+ "${PN}-utils"
14FILES_${PN}-utils = "${bindir}/edbus-codegen"
diff --git a/meta-efl/recipes-efl/efl/edje_1.7.9.bb b/meta-efl/recipes-efl/efl/edje_1.7.9.bb
deleted file mode 100644
index b2e369d1a..000000000
--- a/meta-efl/recipes-efl/efl/edje_1.7.9.bb
+++ /dev/null
@@ -1,72 +0,0 @@
1SUMMARY = "Edje is the Enlightenment graphical design & layout library"
2DEPENDS = "lua5.1 eet evas ecore embryo edje-native eina libsndfile1 eio"
3DEPENDS_virtclass-native = "lua5.1-native evas-native ecore-native eet-native embryo-native eina-native"
4DEPENDS_virtclass-nativesdk = "evas-native ecore-native eet-native embryo-native eina-native"
5# GPLv2 because of epp in PN-utils
6LICENSE = "MIT BSD GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c18cc221a14a84b033db27794dc36df8"
8
9inherit efl
10
11BBCLASSEXTEND = "native nativesdk"
12
13do_configure_prepend_virtclass-native() {
14 sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
15 sed -i 's: cpp -I: /usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
16 sed -i 's:\"gcc -I:\"/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
17}
18# The new lua stuff is a bit broken...
19do_configure_append() {
20 for i in $(find "${S}" -name "Makefile") ; do
21 sed -i -e 's:-L/usr/local/lib::g' $i
22 done
23}
24
25do_compile_append() {
26 sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
27}
28
29# gain some extra performance at the expense of RAM - generally i'd say bad
30# and a possible source of bugs
31#EXTRA_OECONF = "--enable-edje-program-cache"
32
33# Since r44323 edje has a fixed-point mode
34require edje-fpu.inc
35EXTRA_OECONF += "${@get_edje_fpu_setting(bb, d)}"
36
37SNDFILE = "--enable-sndfile"
38SNDFILE_virtclass-native = "--disable-sndfile"
39SNDFILE_virtclass-nativesdk = "--disable-sndfile"
40EXTRA_OECONF += "${SNDFILE}"
41
42PACKAGES =+ "${PN}-utils"
43RDEPENDS_${PN}-utils = "cpp cpp-symlinks embryo-tests"
44
45RRECOMMENDS_${PN}-utils = "\
46 evas-saver-png \
47 evas-saver-jpeg \
48 evas-saver-eet \
49"
50
51DEBIAN_NOAUTONAME_${PN}-utils = "1"
52# Some upgrade path tweaking
53AUTO_LIBNAME_PKGS = ""
54
55FILES_${PN}-utils = "\
56 ${bindir}/edje_* \
57 ${bindir}/inkscape2edc \
58 ${libdir}/edje/utils/epp \
59 ${datadir}/edje/include/edje.inc \
60"
61
62FILES_${PN} += "${libdir}/${PN}/modules/*/*/module.so \
63 ${datadir}/mime/packages/edje.xml"
64FILES_${PN}-dev += "${libdir}/${PN}/modules/*/*/module.la"
65FILES_${PN}-dbg += "${libdir}/${PN}/modules/*/*/.debug"
66
67SRC_URI = "\
68 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
69"
70
71SRC_URI[md5sum] = "49152d8636aefcd028af0f97483391ef"
72SRC_URI[sha256sum] = "dac12e5fd81ab303151bec6742971b63f2de577ef940ed0b6af20419130300ab"
diff --git a/meta-efl/recipes-efl/efl/eet_1.7.9.bb b/meta-efl/recipes-efl/efl/eet_1.7.9.bb
deleted file mode 100644
index 6437f5f7e..000000000
--- a/meta-efl/recipes-efl/efl/eet_1.7.9.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "EET is the Enlightenment data storage library"
2DEPENDS = "pkgconfig zlib jpeg openssl eina gnutls"
3LICENSE = "MIT BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=da947f414a2ca4323245f1abb1980953"
5
6inherit efl
7
8BBCLASSEXTEND = "native"
9
10EXTRA_OECONF = "\
11 --enable-openssl \
12 --enable-cypher \
13 --enable-signature \
14 --disable-coverage \
15 --enable-old-eet-file-format \
16 --disable-assert \
17"
18
19PACKAGES =+ "${PN}-utils"
20
21FILES_${PN}-utils = "\
22 ${bindir}/${PN} \
23"
24
25SRC_URI = "\
26 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
27"
28
29SRC_URI[md5sum] = "225eadf514465be321a44a003d687a55"
30SRC_URI[sha256sum] = "3345e0889bbc29536dbe0f6236ed1ae6a9d685b8e39877d5404fa6217bd12ec6"
diff --git a/meta-efl/recipes-efl/efl/eeze_1.7.9.bb b/meta-efl/recipes-efl/efl/eeze_1.7.9.bb
deleted file mode 100644
index 65f375183..000000000
--- a/meta-efl/recipes-efl/efl/eeze_1.7.9.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Eeze is a library to simplify the use of devices"
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=315521fe061b6fd4290ef01db714a3c8"
4DEPENDS = "ecore eet udev"
5
6inherit efl
7
8BBCLASSEXTEND = "native"
9
10# Some upgrade path tweaking
11AUTO_LIBNAME_PKGS = ""
12
13FILES_${PN} += "${libdir}/enlightenment/utils/eeze_scanner"
14FILES_${PN}-dbg += "${libdir}/enlightenment/utils/.debug"
15
16RRECOMMENDS_${PN} += "eject"
17
18SRC_URI = "\
19 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
20"
21
22SRC_URI[md5sum] = "1e6119b4c12f2539ae5d191659652a89"
23SRC_URI[sha256sum] = "1b4b38943bfc564ddd18d4314a6a12af5ce656b551e69154e818ad14231050b8"
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
new file mode 100644
index 000000000..0d149660f
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -0,0 +1,145 @@
1SUMMARY = "EFL"
2LICENSE = "MIT BSD LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a1809a807e39dd48ddcf7be98477d130"
4
5DEPENDS_class-native = "lua5.1-native freetype-native libxext-native libpng-native jpeg-native tiff-native libfribidi-native glib-2.0-native dbus-native"
6DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 lua5.1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native"
7
8inherit efl gettext pkgconfig
9
10BBCLASSEXTEND = "native"
11
12PROVIDES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus"
13
14# we don't have bullet for physics
15EXTRA_OECONF = " \
16 --disable-physics \
17"
18EXTRA_OECONF_append_class-target = " \
19 --with-bin-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
20"
21EXTRA_OECONF_append_class-native = " \
22 --disable-fontconfig \
23 --disable-audio \
24 --with-x11=none \
25 --disable-image-loader-bmp \
26 --disable-image-loader-eet \
27 --disable-image-loader-generic \
28 --disable-image-loader-gif \
29 --disable-image-loader-ico \
30 --disable-image-loader-jp2k \
31 --disable-image-loader-pmaps \
32 --disable-image-loader-psd \
33 --disable-image-loader-tga \
34 --disable-image-loader-wbmp \
35 --disable-image-loader-webp \
36 --disable-image-loader-xpm \
37"
38
39PACKAGECONFIG ??= "opengl-es"
40PACKAGECONFIG_class-native = ""
41
42# sort of tri-state
43PACKAGECONFIG[opengl-full] = "--with-opengl=full,,virtual/libgl"
44PACKAGECONFIG[opengl-es] = "--with-opengl=es,,virtual/libgles2"
45PACKAGECONFIG[opengl-none] = "--with-opengl=none,,"
46# used only in ecore examples and supports only 0.10 now
47PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
48PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
49
50# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need
51do_configure_prepend_class-native() {
52 sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
53}
54
55PACKAGES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus"
56RPROVIDES_edje += "edje-utils"
57
58python populate_packages_prepend () {
59 for plugin_type in "engines loaders savers".split():
60 bb.note( "splitting packages for evas %s..." % plugin_type )
61 basedir = d.expand( '${libdir}/evas/modules/%s' % plugin_type)
62
63 do_split_packages(d, basedir, '^(.*)',
64 output_pattern = 'evas-' + plugin_type[:-1] + "-%s",
65 description = 'Evas module %s',
66 allow_dirs=True, recursive=False, extra_depends="" )
67
68 plugin_type = "cserve2"
69 bb.note( "splitting packages for evas %s..." % plugin_type )
70 basedir = d.expand( '${libdir}/evas/%s/loaders' % plugin_type)
71
72 do_split_packages(d, basedir, '^(.*)',
73 output_pattern = 'evas-' + plugin_type + "-%s",
74 description = 'Evas csever2 loader module %s',
75 allow_dirs=True, recursive=False, extra_depends="" )
76}
77
78PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*"
79
80FILES_efreet = " \
81 ${libdir}/efreet/*/efreet*create \
82 ${bindir}/efreetd \
83 ${datadir}/efreet \
84"
85FILES_eet = " \
86 ${bindir}/eet \
87"
88FILES_emotion = " \
89 ${datadir}/emotion \
90"
91FILES_embryo = " \
92 ${datadir}/embryo \
93"
94FILES_ethumb = " \
95 ${bindir}/ethumbd \
96 ${bindir}/ethumb \
97 ${libdir}/ethumb/*/*/*/module.so \
98 ${libdir}/ethumb/*/*/*/*.edj \
99 ${libdir}/ethumb_client/utils/*/ethumbd_slave \
100 ${datadir}/ethumb* \
101"
102FILES_ecore = " \
103 ${libdir}/ecore*/*/*/*/module.so \
104 ${datadir}/ecore* \
105"
106FILES_evas = " \
107 ${libdir}/evas*/*/*/*/*/module.so \
108 ${libdir}/evas*/*/*/*/*/*.edj \
109 ${libdir}/evas/cserve2/bin/*/evas_cserve2* \
110 ${datadir}/evas* \
111"
112
113FILES_eeze = " \
114 ${libdir}/eeze*/*/*/*/*/module.so \
115 ${datadir}/eeze \
116"
117FILES_edje = " \
118 ${libdir}/edje*/*/*/*/module.so \
119 ${libdir}/edje/utils/*/epp \
120 ${datadir}/edje \
121 ${datadir}/mime \
122"
123FILES_${PN}-dbg += " \
124 ${libdir}/efreet/*/.debug \
125 ${libdir}/ecore*/*/*/*/.debug \
126 ${libdir}/evas*/*/*/*/*/.debug \
127 ${libdir}/evas/cserve2/bin/*/.debug \
128 ${libdir}/eeze*/*/*/*/*/.debug \
129 ${libdir}/edje*/*/*/*/.debug \
130 ${libdir}/edje/utils/*/.debug \
131 ${libdir}/ethumb/*/*/*/.debug \
132 ${libdir}/ethumb_client/utils/*/.debug \
133"
134FILES_${PN}-dev += " \
135 ${libdir}/cmake \
136 ${libdir}/ecore*/*/*/*/module.la \
137 ${libdir}/evas*/*/*/*/*/module.la \
138 ${libdir}/ethumb*/*/*/*/module.la \
139 ${libdir}/eeze*/*/*/*/*/module.la \
140 ${libdir}/edje*/*/*/*/module.la \
141 ${datadir}/gdb/auto-load \
142 ${datadir}/eo/gdb \
143 ${bindir}/eldbus-codegen \
144 ${bindir}/eina-bench-cmp \
145"
diff --git a/meta-efl/recipes-efl/efl/efl/0001-configure.ac-Don-t-check-for-Xprint-extension.patch b/meta-efl/recipes-efl/efl/efl/0001-configure.ac-Don-t-check-for-Xprint-extension.patch
new file mode 100644
index 000000000..012810b1e
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/efl/0001-configure.ac-Don-t-check-for-Xprint-extension.patch
@@ -0,0 +1,27 @@
1From 7097b46383a6ec96662bf1bf0a04190a38d25a20 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Fri, 10 Jan 2014 17:07:13 +0100
4Subject: [PATCH] configure.ac: Don't check for Xprint extension
5
6* it's long gone
7
8Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
9---
10 configure.ac | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/configure.ac b/configure.ac
14index 0d8c4cc..0a08330 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -2769,7 +2769,6 @@ if test "x${want_x11_xlib}" = "xyes" ; then
18 ECORE_CHECK_X_EXTENSION([Xdpms], [dpms.h], [Xext], [DPMSQueryExtension])
19 ECORE_CHECK_X_EXTENSION([Xfixes], [Xfixes.h], [Xfixes], [XFixesExpandRegion])
20 ECORE_CHECK_X_EXTENSION([Xinerama], [Xinerama.h], [Xinerama], [XineramaQueryScreens])
21- ECORE_CHECK_X_EXTENSION([Xprint], [Print.h], [Xp], [XpQueryScreens])
22 ECORE_CHECK_X_EXTENSION([Xrandr], [Xrandr.h], [Xrandr], [XRRGetScreenResourcesCurrent])
23 ECORE_CHECK_X_EXTENSION([Xrender], [Xrender.h], [Xrender], [XRenderFindVisualFormat])
24 ECORE_CHECK_X_EXTENSION([Xtest], [XTest.h], [Xtst], [XTestFakeKeyEvent])
25--
261.8.5.2
27
diff --git a/meta-efl/recipes-efl/efl/efl_1.8.5.bb b/meta-efl/recipes-efl/efl/efl_1.8.5.bb
new file mode 100644
index 000000000..cacae5f7a
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/efl_1.8.5.bb
@@ -0,0 +1,17 @@
1require ${BPN}.inc
2
3SRC_URI = "\
4 ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
5"
6
7SRC_URI[md5sum] = "3d2c3ca2ff1a072b72ffab40ff598dfb"
8SRC_URI[sha256sum] = "7e514c0a972feea1c44c9074a4b58c14821d93dc91ff6f51066528f12ab42fe5"
9
10# Temporary disable until error like the one following are fixed
11# efl-native/2_1.8.4-r0/efl-1.8.4/src/lib/eet/.libs/libeet.so: file not recognized: File truncated
12# collect2: error: ld returned 1 exit status
13# x86_64-linux-libtool: install: error: relink `modules/evas/savers/tiff/module.la' with the above command before installing it
14# Makefile:11031: recipe for target 'install-savertiffpkgLTLIBRARIES' failed
15PARALLEL_MAKE = ""
16
17SRC_URI += "file://0001-configure.ac-Don-t-check-for-Xprint-extension.patch"
diff --git a/meta-efl/recipes-efl/efl/efreet_1.7.9.bb b/meta-efl/recipes-efl/efl/efreet_1.7.9.bb
deleted file mode 100644
index 9688c68f8..000000000
--- a/meta-efl/recipes-efl/efl/efreet_1.7.9.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "The Enlightenment freedesktop.org library"
2DEPENDS = "ecore"
3LICENSE = "MIT BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9594ec75c5a57e71fccedcbe10dd3ef4"
5
6inherit efl gettext
7
8PACKAGES =+ "${PN}-mime ${PN}-trash"
9FILES_${PN}-mime = "${libdir}/libefreet_mime.so.*"
10FILES_${PN}-trash = "${libdir}/libefreet_trash.so.*"
11
12# efreet_desktop_cache_create is needed for e-wm start, don't include it in -tests
13FILES_${PN} += "${libdir}/efreet/efreet_desktop_cache_create \
14 ${libdir}/efreet/efreet_icon_cache_create \
15"
16
17SRC_URI = "\
18 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
19"
20
21SRC_URI[md5sum] = "5972833cf78ca93440403b94ed4ed74d"
22SRC_URI[sha256sum] = "d5037c04ac8130879bf87d924e6b83cf479e7dee8235321ed1a49f97083b611b"
diff --git a/meta-efl/recipes-efl/efl/eina_1.7.9.bb b/meta-efl/recipes-efl/efl/eina_1.7.9.bb
deleted file mode 100644
index aa6200dc1..000000000
--- a/meta-efl/recipes-efl/efl/eina_1.7.9.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "Eina is the Enlightenment data library"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=9cc092d35d7bbfcd986232cde130a551"
4
5BBCLASSEXTEND = "native"
6
7inherit efl
8
9# Some upgrade path tweaking
10AUTO_LIBNAME_PKGS = ""
11
12FILES_${PN} += "${libdir}/eina"
13
14SRC_URI = "\
15 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
16"
17
18SRC_URI[md5sum] = "cddf2755e20bfb3f90764fd2b689b888"
19SRC_URI[sha256sum] = "b7fe26d98b80479d0f72be47b2584dfa243e4d18774cb824acc398354a45d520"
diff --git a/meta-efl/recipes-efl/efl/eio_1.7.9.bb b/meta-efl/recipes-efl/efl/eio_1.7.9.bb
deleted file mode 100644
index 186e9bfab..000000000
--- a/meta-efl/recipes-efl/efl/eio_1.7.9.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1SUMMARY = "Enlightenment Input Output Library"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=180fca752525726bd6ba021689509a08"
4DEPENDS = "ecore eina"
5
6inherit efl
7
8BBCLASSEXTEND = "native"
9
10SRC_URI = "\
11 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
12"
13
14SRC_URI[md5sum] = "f4d6cbd216a9ae5983fa8ee8dadf04cb"
15SRC_URI[sha256sum] = "35ce08ecf6afd5faa4fe857764537e15aede2b0d2c37922e55e97e2dff3352de"
diff --git a/meta-efl/recipes-efl/efl/embryo_1.7.9.bb b/meta-efl/recipes-efl/efl/embryo_1.7.9.bb
deleted file mode 100644
index 332fa5183..000000000
--- a/meta-efl/recipes-efl/efl/embryo_1.7.9.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "The Enlightenment C-like scripting language for Edje"
2
3inherit efl
4
5LICENSE = "MIT BSD CompuPhase"
6LIC_FILES_CHKSUM = "file://COPYING;md5=220a7f1107df42c62428d8ebe559ed14"
7
8BBCLASSEXTEND = "native"
9
10DEPENDS += "eina"
11
12# Some upgrade path tweaking
13AUTO_LIBNAME_PKGS = ""
14
15SRC_URI = "\
16 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
17"
18
19SRC_URI[md5sum] = "98614ec48376ff6d3a39187504b70ed4"
20SRC_URI[sha256sum] = "6b2739a53c3ab2fcf44edfb9c3a4c56d11aba91e27e556a9e70116a161201e34"
diff --git a/meta-efl/recipes-efl/efl/emotion_1.7.9.bb b/meta-efl/recipes-efl/efl/emotion_1.7.9.bb
deleted file mode 100644
index ac9e36331..000000000
--- a/meta-efl/recipes-efl/efl/emotion_1.7.9.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "The Enlightenment multimedia library"
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=69f44058245ce5c596d56bb622d5dabd"
4# we no longer build the libxine backend, since the gstreamer backend seems more promising
5DEPENDS = "eet eeze evas ecore edje gstreamer gst-plugins-base eio"
6
7inherit efl
8
9EXTRA_OECONF = "--disable-xine --disable-generic-vlc --enable-gstreamer --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
10
11PACKAGES =+ "emotion-backend-gstreamer"
12FILES_emotion-backend-gstreamer = "${libdir}/emotion/*.so"
13RRECOMMENDS_${PN} = "emotion-backend-gstreamer"
14# upgrade path from libemotion0 to libemotion1
15RREPLACES_${PN} = "libemotion0"
16
17SRC_URI = "\
18 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
19"
20
21SRC_URI[md5sum] = "171bbc41a5e5d202d0dc57c34e318c14"
22SRC_URI[sha256sum] = "ff72204490e740adaa7980bad1a060dae8113c308c6083e5bcee380a11dad1f4"
diff --git a/meta-efl/recipes-efl/efl/ethumb_1.7.9.bb b/meta-efl/recipes-efl/efl/ethumb_1.7.9.bb
deleted file mode 100644
index ad1fe7b28..000000000
--- a/meta-efl/recipes-efl/efl/ethumb_1.7.9.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "EFL based thumbnail generation library"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=e6a6db9e80255adbafa16e817d9a4d8c"
4DEPENDS = "libexif eet-native evas ecore edje eet edbus emotion epdf"
5
6inherit efl
7
8EXTRA_OECONF = "\
9 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
10 --with-eet-eet=${STAGING_BINDIR_NATIVE}/eet \
11 --disable-docs \
12"
13
14# Some upgrade path tweaking, as in evas
15AUTO_LIBNAME_PKGS = ""
16
17FILES_${PN} += "\
18 ${bindir}/ethumbd \
19 ${libexecdir}/ethumbd_slave \
20"
21
22SRC_URI = "\
23 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
24"
25
26SRC_URI[md5sum] = "d71a6fbcce2c6a8f46ea9b9b9d53cbab"
27SRC_URI[sha256sum] = "a97c39a9184ec7e1b352a7f251d97992b8082e3a0d6735ea1f34e4e40129a12f"
diff --git a/meta-efl/recipes-efl/efl/evas/0001-evas_font_load-Fix-build-with-newer-freetype.patch b/meta-efl/recipes-efl/efl/evas/0001-evas_font_load-Fix-build-with-newer-freetype.patch
deleted file mode 100644
index 0197f1c4d..000000000
--- a/meta-efl/recipes-efl/efl/evas/0001-evas_font_load-Fix-build-with-newer-freetype.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From ff5e8aa48d223401497dbaad1ffdc81977b2c09d Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Wed, 1 Jan 2014 13:03:48 +0100
4Subject: [PATCH] evas_font_load: Fix build with newer freetype
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 src/lib/engines/common/evas_font_load.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/lib/engines/common/evas_font_load.c b/src/lib/engines/common/evas_font_load.c
12index 805eaf8..6650816 100644
13--- a/src/lib/engines/common/evas_font_load.c
14+++ b/src/lib/engines/common/evas_font_load.c
15@@ -5,7 +5,7 @@
16
17 #include "evas_font_private.h" /* for Frame-Queuing support */
18 #include "evas_font_ot.h"
19-#include <freetype/tttables.h> /* Freetype2 OS/2 font table. */
20+#include <freetype2/tttables.h> /* Freetype2 OS/2 font table. */
21
22 #ifdef EVAS_CSERVE2
23 # include "../../cserve2/evas_cs2_private.h"
24--
251.8.4.3
26
diff --git a/meta-efl/recipes-efl/efl/evas_1.7.9.bb b/meta-efl/recipes-efl/efl/evas_1.7.9.bb
deleted file mode 100644
index a94719377..000000000
--- a/meta-efl/recipes-efl/efl/evas_1.7.9.bb
+++ /dev/null
@@ -1,178 +0,0 @@
1SUMMARY = "Evas is the Enlightenment canvas API"
2LICENSE = "MIT BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b9b25b03d63aa496552658c7e78b11a1"
4# can also depend on valgrind, libsdl-x11, directfb
5DEPENDS = "librsvg eina eet freetype jpeg libpng tiff virtual/libx11 libxext libxrender fontconfig libfribidi giflib"
6DEPENDS_virtclass-native = "freetype-native libxext-native libpng-native jpeg-native tiff-native eet-native eina-native libfribidi-native"
7
8inherit efl
9
10BBCLASSEXTEND = "native"
11FILESPATHPKG =. "${BPN}-${PV}:${BPN}:"
12
13python populate_packages_prepend () {
14 for plugin_type in "engines loaders savers".split():
15 bb.note( "splitting packages for evas %s..." % plugin_type )
16 basedir = d.expand( '${libdir}/evas/modules/%s' % plugin_type)
17
18 do_split_packages(d, basedir, '^(.*)',
19 output_pattern = 'evas-' + plugin_type[:-1] + "-%s",
20 description = 'Evas module %s',
21 allow_dirs=True, recursive=False, extra_depends="" )
22
23 plugin_type = "cserve2"
24 bb.note( "splitting packages for evas %s..." % plugin_type )
25 basedir = d.expand( '${libdir}/evas/%s/loaders' % plugin_type)
26
27 do_split_packages(d, basedir, '^(.*)',
28 output_pattern = 'evas-' + plugin_type + "-%s",
29 description = 'Evas csever2 loader module %s',
30 allow_dirs=True, recursive=False, extra_depends="" )
31}
32
33do_install_append() {
34 find "${D}" -name .debug -type d -exec rm -rf {} \;
35}
36
37FILES_${PN}-dev += "${libdir}/evas/modules/*/*/*/*.a ${libdir}/evas/modules/*/*/*/*.la"
38FILES_${PN}-dbg += "${libdir}/evas/modules/*/*/*/.debug/ ${libdir}/evas/cserve2/loaders/*/*/.debug/"
39FILES_${PN}-cserve2 += "${libexecdir}/evas_cserve2* ${libexecdir}/dummy_slave"
40
41PACKAGES += "${PN}-cserve2"
42PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*"
43
44# evas-loader-svg is gone as we don't have esvg and probably won't have anytime soon
45# http://www.intesis.hr/news/16-esvg-source
46# http://blog.gmane.org/gmane.comp.window-managers.enlightenment.user/page=3
47RRECOMMENDS_${PN} += "evas-loader-generic evas-generic-loader-svn"
48
49RRECOMMENDS_${PN} += " \
50 evas-engine-fb \
51 evas-engine-software-generic \
52 evas-engine-software-x11 \
53 evas-engine-software-16 \
54 evas-engine-software-16-x11 \
55 evas-engine-xrender-x11 \
56 \
57 evas-loader-png \
58 evas-loader-jpeg \
59 evas-loader-gif \
60 evas-loader-svg \
61"
62
63# Some upgrade path tweaking
64AUTO_LIBNAME_PKGS = ""
65
66EVAS_CPU_TWEAKS = ""
67# Disabled for now, see http://thread.gmane.org/gmane.comp.window-managers.enlightenment.devel/25194
68EVAS_CPU_TWEAKS_armv7a = "--disable-cpu-neon"
69
70# common options
71EVAS_OECONF = " \
72 --x-includes=${STAGING_INCDIR}/X11 \
73 --x-libraries=${STAGING_LIBDIR} \
74 --enable-evas-magic-debug \
75 --enable-fb \
76 --disable-directfb \
77 --disable-sdl \
78 --enable-buffer=static \
79 --enable-static-software-generic \
80 --disable-software-ddraw \
81 --disable-software-qtopia \
82 --disable-software-xcb \
83 --disable-xrender-xcb \
84 --disable-glitz-x11 \
85 --enable-image-loader-eet=static \
86 --disable-image-loader-edb \
87 --enable-image-loader-png \
88 --enable-image-loader-jpeg \
89 --enable-image-loader-tiff \
90 --enable-image-loader-xpm \
91 --enable-cpu-c \
92 --enable-fontconfig \
93 --enable-font-loader-eet \
94 --enable-scale-sample \
95 --enable-scale-smooth \
96 --enable-convert-yuv \
97 --enable-small-dither-mask \
98 --disable-no-dither-mask \
99 --disable-convert-8-rgb-332 \
100 --disable-convert-8-rgb-666 \
101 --disable-convert-8-rgb-232 \
102 --disable-convert-8-rgb-222 \
103 --disable-convert-8-rgb-221 \
104 --disable-convert-8-rgb-121 \
105 --disable-convert-8-rgb-111 \
106 --enable-convert-16-rgb-565 \
107 --disable-convert-16-rgb-555 \
108 --disable-convert-16-rgb-444 \
109 --disable-convert-16-rgb-ipq \
110 --enable-convert-16-rgb-rot-0 \
111 --enable-convert-16-rgb-rot-90 \
112 --disable-convert-16-rgb-rot-180 \
113 --enable-convert-16-rgb-rot-270 \
114"
115
116# either sgx or 6410 atm
117GLES ?= "sgx"
118
119# This is a hack to get openGL|ES 2.x support enabled for people that have the SDK headers in staging.
120# We put this in the main recipe, since it will just not build the gl stuff when the headers are missing
121
122# If the above sentence confuse you: everything is built and configured as before if you don't have the SDK
123
124EXTRA_OECONF = "${EVAS_OECONF} \
125 ${EVAS_CPU_TWEAKS} \
126 --enable-pthreads \
127 --enable-async-events \
128 --enable-async-preload \
129 --enable-simple-x11 \
130 --enable-software-x11 \
131 --enable-xrender-x11 \
132 --enable-software-16-x11 \
133 --enable-image-loader-gif \
134 --enable-image-loader-svg \
135 --enable-convert-24-rgb-888 \
136 --enable-convert-24-bgr-888 \
137 --enable-convert-32-rgb-8888 \
138 --enable-convert-32-rgbx-8888 \
139 --enable-convert-32-bgr-8888 \
140 --enable-convert-32-bgrx-8888 \
141 --enable-convert-32-rgb-rot-0 \
142 --enable-convert-32-rgb-rot-90 \
143 --disable-convert-32-rgb-rot-180 \
144 --enable-convert-32-rgb-rot-270 \
145 --enable-gl-x11 \
146 --enable-gl-xlib \
147 --enable-gl-flavor-gles \
148 --enable-gles-variety-${GLES} \
149"
150EXTRA_OECONF_virtclass-native = "${EVAS_OECONF} \
151 --disable-software-x11 \
152 --disable-software-16-x11 \
153 --disable-gl-x11 \
154 --disable-gl-xlib \
155 --disable-xrender-x11 \
156 --disable-image-loader-gif \
157 --disable-image-loader-svg \
158 --disable-convert-24-rgb-888 \
159 --disable-convert-24-bgr-888 \
160 --disable-convert-32-rgb-8888 \
161 --disable-convert-32-rgbx-8888 \
162 --disable-convert-32-bgr-8888 \
163 --disable-convert-32-bgrx-8888 \
164 --disable-convert-32-rgb-rot-0 \
165 --disable-convert-32-rgb-rot-90 \
166 --disable-convert-32-rgb-rot-270 \
167"
168
169PACKAGECONFIG ??= ""
170PACKAGECONFIG[harfbuzz] = "--enable-harfbuzz,--disable-harfbuzz,harfbuzz"
171
172SRC_URI = "\
173 ${E_MIRROR}/${SRCNAME}-${SRCVER}.tar.gz \
174 file://0001-evas_font_load-Fix-build-with-newer-freetype.patch \
175"
176
177SRC_URI[md5sum] = "c96a23ede14cd0adb7e8e549e8acdee1"
178SRC_URI[sha256sum] = "1fd687e43ebe3031be4ac7628043eae1aafca83ce6d1d1f06ff3b59fb4c027f0"