summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/efl.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-08-13 14:00:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-23 13:36:20 +0200
commita8d31694852bc0d0d4069b4fb9f4fde6625e47f7 (patch)
tree0673bd226f21ad53f0e3c6d38697d0ee15fed312 /meta-efl/recipes-efl/efl/efl.inc
parentfaf83c51dd4e79419e5dd1abfba96c26a09ac982 (diff)
downloadmeta-openembedded-a8d31694852bc0d0d4069b4fb9f4fde6625e47f7.tar.gz
efl: upgrade to 1.11.0
* announcement: https://phab.enlightenment.org/phame/post/view/74/ https://phab.enlightenment.org/phame/post/view/77/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/efl/efl.inc')
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
index 648c5b6fb..c82780b99 100644
--- a/meta-efl/recipes-efl/efl/efl.inc
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -19,7 +19,7 @@ PROVIDES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldb
19# your own in terms of ensuring everything works if you do this 19# your own in terms of ensuring everything works if you do this
20EXTRA_OECONF = " \ 20EXTRA_OECONF = " \
21 --disable-physics \ 21 --disable-physics \
22 --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aaa \ 22 --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba \
23" 23"
24EXTRA_OECONF_append_class-target = " \ 24EXTRA_OECONF_append_class-target = " \
25 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \ 25 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
@@ -53,20 +53,23 @@ PACKAGECONFIG[opengl-es] = "--with-opengl=es,,virtual/libgles2"
53PACKAGECONFIG[opengl-none] = "--with-opengl=none,," 53PACKAGECONFIG[opengl-none] = "--with-opengl=none,,"
54# be aware when enabling this for efl-native, we don't provide gcc-native so you need to make 54# be aware when enabling this for efl-native, we don't provide gcc-native so you need to make
55# sure that all your builders have g++ which supports -std=gnu++11 55# sure that all your builders have g++ which supports -std=gnu++11
56PACKAGECONFIG[c++11] = "--enable-c++11,--disable-c++11" 56PACKAGECONFIG[c++11] = "--enable-cxx-bindings,--disable-cxx-bindings"
57PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer" 57PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
58PACKAGECONFIG[gstreamer1] = "--enable-gstreamer1,--disable-gstreamer1,gstreamer1.0 gstreamer1.0-plugins-base" 58PACKAGECONFIG[gstreamer1] = "--enable-gstreamer1,--disable-gstreamer1,gstreamer1.0 gstreamer1.0-plugins-base"
59PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" 59PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
60PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" 60PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
61PACKAGECONFIG[luajit] = "--disable-lua-old,--enable-lua-old,luajit" 61PACKAGECONFIG[luajit] = "--disable-lua-old,--enable-lua-old,luajit"
62PACKAGECONFIG[lua-old] = "--enable-lua-old,--disable-lua-old,lua" 62PACKAGECONFIG[lua-old] = "--enable-lua-old,--disable-lua-old,lua"
63PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
64# currently we don't provide doxygen-native
65PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,doxygen-native"
63 66
64# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need 67# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need
65do_configure_prepend_class-native() { 68do_configure_prepend_class-native() {
66 sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac 69 sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
67} 70}
68 71
69PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus" 72PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus elua"
70 73
71# upgrade path from 1.7 74# upgrade path from 1.7
72DEBIAN_NOAUTONAME_ecore-audio = "1" 75DEBIAN_NOAUTONAME_ecore-audio = "1"
@@ -153,6 +156,7 @@ FILES_ecore-ipc = "\
153" 156"
154FILES_ecore-x = "\ 157FILES_ecore-x = "\
155 ${libdir}/libecore_x${SOLIBS} \ 158 ${libdir}/libecore_x${SOLIBS} \
159 ${libdir}/ecore_x/bin/v-*/ecore_x_vsync \
156" 160"
157FILES_ecore-evas = "\ 161FILES_ecore-evas = "\
158 ${libdir}/libecore_evas${SOLIBS} \ 162 ${libdir}/libecore_evas${SOLIBS} \
@@ -241,9 +245,14 @@ FILES_edje = " \
241 ${datadir}/edje \ 245 ${datadir}/edje \
242 ${datadir}/mime \ 246 ${datadir}/mime \
243" 247"
248FILES_elua = " \
249 ${bindir}/elua \
250 ${datadir}/elua \
251"
244FILES_${PN}-dbg += " \ 252FILES_${PN}-dbg += " \
245 ${libdir}/efreet/*/.debug \ 253 ${libdir}/efreet/*/.debug \
246 ${libdir}/ecore*/*/*/*/.debug \ 254 ${libdir}/ecore*/*/*/*/.debug \
255 ${libdir}/ecore*/*/*/.debug \
247 ${libdir}/evas*/*/*/*/*/.debug \ 256 ${libdir}/evas*/*/*/*/*/.debug \
248 ${libdir}/evas/cserve2/bin/*/.debug \ 257 ${libdir}/evas/cserve2/bin/*/.debug \
249 ${libdir}/eeze*/*/*/*/*/.debug \ 258 ${libdir}/eeze*/*/*/*/*/.debug \