summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/efl.inc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-efl/recipes-efl/efl/efl.inc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-efl/recipes-efl/efl/efl.inc')
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc276
1 files changed, 276 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
new file mode 100644
index 000000000..82f8dfe5b
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -0,0 +1,276 @@
1SUMMARY = "EFL"
2LICENSE = "MIT BSD LGPL-2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a1809a807e39dd48ddcf7be98477d130"
4
5DEPENDS_class-native = "freetype-native libxext-native libpng-native jpeg-native tiff-native libfribidi-native glib-2.0-native dbus-native"
6DEPENDS = "virtual/libiconv tslib curl glib-2.0 gnutls pkgconfig zlib jpeg openssl libsndfile1 dbus libexif librsvg freetype libpng tiff libxext virtual/libx11 libxdamage libxrender fontconfig libfribidi giflib udev libxcursor libxcomposite libxinerama libxrandr libxtst libxscrnsaver efl-native"
7
8inherit efl gettext pkgconfig
9
10BBCLASSEXTEND = "native"
11
12PROVIDES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus"
13
14# we don't have bullet for physics
15# You have chosen to disable physics support. This disables lots of
16# core functionality and is effectively never tested. You are going
17# to find features that suddenly don't work and as a result cause
18# a series of breakages. This is simply not tested so you are on
19# your own in terms of ensuring everything works if you do this
20EXTRA_OECONF = " \
21 --disable-physics \
22 --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba \
23"
24EXTRA_OECONF_append_class-target = " \
25 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
26 --with-eolian-gen=${STAGING_BINDIR_NATIVE}/eolian_gen \
27 --with-eolian-cxx=${STAGING_BINDIR_NATIVE}/eolian_cxx \
28"
29EXTRA_OECONF_append_class-native = " \
30 --disable-fontconfig \
31 --disable-audio \
32 --with-x11=none \
33 --disable-image-loader-bmp \
34 --disable-image-loader-eet \
35 --disable-image-loader-generic \
36 --disable-image-loader-gif \
37 --disable-image-loader-ico \
38 --disable-image-loader-jp2k \
39 --disable-image-loader-pmaps \
40 --disable-image-loader-psd \
41 --disable-image-loader-tga \
42 --disable-image-loader-wbmp \
43 --disable-image-loader-webp \
44 --disable-image-loader-xpm \
45"
46
47PACKAGECONFIG ?= "opengl-es gstreamer1 pulseaudio luajit"
48PACKAGECONFIG_class-native = "luajit"
49
50# sort of tri-state
51PACKAGECONFIG[opengl-full] = "--with-opengl=full,,virtual/libgl"
52PACKAGECONFIG[opengl-es] = "--with-opengl=es,,virtual/libgles2"
53PACKAGECONFIG[opengl-none] = "--with-opengl=none,,"
54# be aware when enabling this for efl-native, we don't provide gcc-native so you need to make
55# sure that all your builders have g++ which supports -std=gnu++11
56PACKAGECONFIG[c++11] = "--enable-cxx-bindings,--disable-cxx-bindings"
57PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
58PACKAGECONFIG[gstreamer1] = "--enable-gstreamer1,--disable-gstreamer1,gstreamer1.0 gstreamer1.0-plugins-base"
59PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
60PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
61PACKAGECONFIG[luajit] = "--disable-lua-old,--enable-lua-old,luajit"
62PACKAGECONFIG[lua-old] = "--enable-lua-old,--disable-lua-old,lua"
63PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
64# currently we don't provide doxygen-native
65PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,doxygen-native"
66
67# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need
68do_configure_prepend_class-native() {
69 sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
70}
71
72PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus elua"
73
74# upgrade path from 1.7
75DEBIAN_NOAUTONAME_ecore-audio = "1"
76DEBIAN_NOAUTONAME_ecore-input-evas = "1"
77DEBIAN_NOAUTONAME_ecore-input = "1"
78DEBIAN_NOAUTONAME_ecore-imf-evas = "1"
79DEBIAN_NOAUTONAME_ecore-imf = "1"
80DEBIAN_NOAUTONAME_ecore-file = "1"
81DEBIAN_NOAUTONAME_ecore-con = "1"
82DEBIAN_NOAUTONAME_ecore-ipc = "1"
83DEBIAN_NOAUTONAME_ecore-x = "1"
84DEBIAN_NOAUTONAME_ecore-evas = "1"
85DEBIAN_NOAUTONAME_embryo = "1"
86
87ALLOW_EMPTY_ecore = "1"
88RDEPENDS_ecore = "ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas"
89
90python populate_packages_prepend () {
91 for plugin_type in "engines loaders savers".split():
92 bb.note( "splitting packages for evas %s..." % plugin_type )
93 basedir = d.expand( '${libdir}/evas/modules/%s' % plugin_type)
94
95 do_split_packages(d, basedir, '^(.*)',
96 output_pattern = 'evas-' + plugin_type[:-1] + "-%s",
97 description = 'Evas module %s',
98 allow_dirs=True, recursive=False, extra_depends="" )
99
100 plugin_type = "cserve2"
101 bb.note( "splitting packages for evas %s..." % plugin_type )
102 basedir = d.expand( '${libdir}/evas/%s/loaders' % plugin_type)
103
104 do_split_packages(d, basedir, '^(.*)',
105 output_pattern = 'evas-' + plugin_type + "-%s",
106 description = 'Evas csever2 loader module %s',
107 allow_dirs=True, recursive=False, extra_depends="" )
108}
109
110PACKAGES += "evas-loader-png evas-engine-software-generic evas-engine-fb"
111PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*"
112
113# PACKAGES_DYNAMIC + do_split_packages isn't used for all libe libs,
114# because PACKAGES_DYNAMIC would be catching too many patterns
115# (or need to list all possible prefixes) and not all original packages
116# were splitted like that, so it would need RCONFLICTS/RPROVIDES/RREPLACES
117# combos at least in few places for upgrade path.
118
119FILES_efreet-trash = " \
120 ${libdir}/libefreet_trash${SOLIBS} \
121"
122FILES_efreet-mime = " \
123 ${libdir}/libefreet_mime${SOLIBS} \
124"
125FILES_libeet = " \
126 ${libdir}/libeet${SOLIBS} \
127"
128FILES_libefreet = " \
129 ${libdir}/libefreet${SOLIBS} \
130"
131FILES_ecore-audio = "\
132 ${libdir}/libecore_audio${SOLIBS} \
133"
134FILES_ecore-input-evas = "\
135 ${libdir}/libecore_input_evas${SOLIBS} \
136"
137FILES_ecore-input = "\
138 ${libdir}/libecore_input${SOLIBS} \
139"
140FILES_ecore-imf-evas = "\
141 ${libdir}/libecore_imf_evas${SOLIBS} \
142 ${libdir}/ecore-imf/modules/*/*/module.so \
143"
144FILES_ecore-imf = "\
145 ${libdir}/libecore_imf${SOLIBS} \
146"
147
148FILES_ecore-file = "\
149 ${libdir}/libecore_file${SOLIBS} \
150"
151FILES_ecore-con = "\
152 ${libdir}/libecore_con${SOLIBS} \
153"
154FILES_ecore-ipc = "\
155 ${libdir}/libecore_ipc${SOLIBS} \
156"
157FILES_ecore-x = "\
158 ${libdir}/libecore_x${SOLIBS} \
159 ${libdir}/ecore_x/bin/v-*/ecore_x_vsync \
160"
161FILES_ecore-evas = "\
162 ${libdir}/libecore_evas${SOLIBS} \
163 ${libdir}/ecore-evas/engines/*/*/module.so \
164"
165FILES_eio = "\
166 ${libdir}/libeio${SOLIBS} \
167"
168FILES_eina = "\
169 ${libdir}/libeina${SOLIBS} \
170 ${bindir}/eina-bench-cmp \
171"
172FILES_edje-utils = "\
173 ${bindir}/edje_* \
174 ${datadir}/edje/include/edje.inc \
175"
176FILES_eldbus = "\
177 ${libdir}/libeldbus${SOLIBS} \
178"
179FILES_eo = "\
180 ${libdir}/libeo${SOLIBS} \
181"
182FILES_libemotion = "\
183 ${libdir}/libemotion${SOLIBS} \
184"
185FILES_efreet = " \
186 ${datadir}/dbus-1/services/*Efreet* \
187 ${libdir}/efreet/*/efreet*create \
188 ${bindir}/efreetd \
189 ${datadir}/efreet \
190"
191FILES_eet = " \
192 ${bindir}/eet \
193 ${bindir}/vieet \
194 ${libdir}/libeet${SOLIBS} \
195"
196FILES_emotion = " \
197 ${datadir}/emotion \
198 ${libdir}/emotion/modules/gstreamer1/*/module.so \
199"
200FILES_embryo-tests = " \
201 ${datadir}/embryo/ \
202"
203FILES_embryo-utils = " \
204 ${binddir}/embryo_* \
205"
206FILES_embryo = " \
207 ${libdir}/libembryo${SOLIBS} \
208"
209FILES_ethumb = " \
210 ${datadir}/dbus-1/services/*Ethumb* \
211 ${libdir}/libethumb${SOLIBS} \
212 ${libdir}/libethumb_client${SOLIBS} \
213 ${bindir}/ethumbd \
214 ${bindir}/ethumbd_client \
215 ${bindir}/ethumb \
216 ${libdir}/ethumb/*/*/*/module.so \
217 ${libdir}/ethumb/*/*/*/*.edj \
218 ${libdir}/ethumb_client/utils/*/ethumbd_slave \
219 ${datadir}/ethumb* \
220"
221FILES_ecore = " \
222 ${libdir}/libecore${SOLIBS} \
223 ${libdir}/ecore*/*/*/*/module.so \
224 ${datadir}/ecore* \
225"
226FILES_evas = " \
227 ${libdir}/libevas${SOLIBS} \
228 ${libdir}/evas*/*/*/*/*/module.so \
229 ${libdir}/evas*/*/*/*/*/*.edj \
230 ${libdir}/evas/cserve2/bin/*/evas_cserve2* \
231 ${datadir}/evas* \
232 ${bindir}/evas_cserve2_* \
233"
234
235FILES_eeze = " \
236 ${libdir}/libeeze${SOLIBS} \
237 ${libdir}/eeze*/*/*/*/*/module.so \
238 ${datadir}/eeze \
239 ${bindir}/eeze_* \
240"
241FILES_edje = " \
242 ${libdir}/libedje${SOLIBS} \
243 ${libdir}/edje*/*/*/*/module.so \
244 ${libdir}/edje/utils/*/epp \
245 ${datadir}/edje \
246 ${datadir}/mime \
247"
248FILES_elua = " \
249 ${bindir}/elua \
250 ${datadir}/elua \
251"
252FILES_${PN}-dbg += " \
253 ${libdir}/efreet/*/.debug \
254 ${libdir}/ecore*/*/*/*/.debug \
255 ${libdir}/ecore*/*/*/.debug \
256 ${libdir}/evas*/*/*/*/*/.debug \
257 ${libdir}/evas/cserve2/bin/*/.debug \
258 ${libdir}/eeze*/*/*/*/*/.debug \
259 ${libdir}/edje*/*/*/*/.debug \
260 ${libdir}/edje/utils/*/.debug \
261 ${libdir}/ethumb/*/*/*/.debug \
262 ${libdir}/ethumb_client/utils/*/.debug \
263 ${libdir}/emotion/modules/gstreamer1/*/.debug \
264"
265FILES_${PN}-dev += " \
266 ${libdir}/cmake \
267 ${libdir}/ecore*/*/*/*/module.la \
268 ${libdir}/evas*/*/*/*/*/module.la \
269 ${libdir}/ethumb*/*/*/*/module.la \
270 ${libdir}/eeze*/*/*/*/*/module.la \
271 ${libdir}/edje*/*/*/*/module.la \
272 ${libdir}/emotion/modules/gstreamer1/*/module.la \
273 ${datadir}/gdb/auto-load \
274 ${datadir}/eo/gdb \
275 ${bindir}/eldbus-codegen \
276"