diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-20 17:53:54 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-23 23:21:15 +0100 |
commit | f696e1bdb10f7b2cb139bf9048e478d9f10c5e17 (patch) | |
tree | 9396813287e6628763db21469033e458595446a5 /meta-efl/recipes-efl/e17 | |
parent | 62526723c7d8bd2687ebd02bcc3ecb48769d9c8c (diff) | |
download | meta-openembedded-f696e1bdb10f7b2cb139bf9048e478d9f10c5e17.tar.gz |
e-wm: Add recipe for 0.18.2
* keep old 0.17.* around because new enlightenment is more picky on where it
will run (compositor is now mandatory)
* 0.18.2 release:
http://sourceforge.net/mailarchive/message.php?msg_id=31789335
* 0.18.3 release:
http://sourceforge.net/mailarchive/message.php?msg_id=31895179
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/e17')
-rw-r--r-- | meta-efl/recipes-efl/e17/e-wm.inc | 14 | ||||
-rw-r--r-- | meta-efl/recipes-efl/e17/e-wm_0.17.5.bb | 12 | ||||
-rw-r--r-- | meta-efl/recipes-efl/e17/e-wm_0.18.3.bb | 20 |
3 files changed, 35 insertions, 11 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc index 3f24b62c5..08fe25fce 100644 --- a/meta-efl/recipes-efl/e17/e-wm.inc +++ b/meta-efl/recipes-efl/e17/e-wm.inc | |||
@@ -7,7 +7,8 @@ SRCNAME = "e" | |||
7 | inherit e update-alternatives gettext | 7 | inherit e update-alternatives gettext |
8 | S = "${WORKDIR}/${SRCNAME}" | 8 | S = "${WORKDIR}/${SRCNAME}" |
9 | 9 | ||
10 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" | 10 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ |
11 | ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | ||
11 | PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam" | 12 | PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam" |
12 | 13 | ||
13 | EXTRA_OECONF = "\ | 14 | EXTRA_OECONF = "\ |
@@ -30,16 +31,6 @@ do_install_append() { | |||
30 | # xinit[418]: ERROR: CONFIGURATION FILE HAS BAD PERMISSIONS | 31 | # xinit[418]: ERROR: CONFIGURATION FILE HAS BAD PERMISSIONS |
31 | chmod 600 ${D}/${sysconfdir}/enlightenment/sysactions.conf | 32 | chmod 600 ${D}/${sysconfdir}/enlightenment/sysactions.conf |
32 | 33 | ||
33 | install -d ${D}/${datadir}/applications/ | ||
34 | install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop | ||
35 | sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop | ||
36 | echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop | ||
37 | echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop | ||
38 | echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop | ||
39 | echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop | ||
40 | install -d ${D}/${datadir}/icons/ | ||
41 | install -m 644 ${S}/data/themes/img/O/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png | ||
42 | |||
43 | install -d ${D}/${sysconfdir}/xdg/menus | 34 | install -d ${D}/${sysconfdir}/xdg/menus |
44 | install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/ | 35 | install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/ |
45 | for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done | 36 | for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done |
@@ -124,6 +115,7 @@ FILES_${PN} = "\ | |||
124 | ${datadir}/enlightenment/COPYING \ | 115 | ${datadir}/enlightenment/COPYING \ |
125 | ${datadir}/xsessions/enlightenment.desktop \ | 116 | ${datadir}/xsessions/enlightenment.desktop \ |
126 | ${sysconfdir}/xdg \ | 117 | ${sysconfdir}/xdg \ |
118 | ${systemd_unitdir} \ | ||
127 | " | 119 | " |
128 | 120 | ||
129 | FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default" | 121 | FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default" |
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb b/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb index 57eefdb4d..d374680fb 100644 --- a/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb +++ b/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb | |||
@@ -12,3 +12,15 @@ SRC_URI = "\ | |||
12 | 12 | ||
13 | SRC_URI[md5sum] = "5aefb55df0b1a0a0ae0cf9d0610cf7c7" | 13 | SRC_URI[md5sum] = "5aefb55df0b1a0a0ae0cf9d0610cf7c7" |
14 | SRC_URI[sha256sum] = "25d4967277cf27d4efb474a9b8eceb1200aa813a51c248b61cc23f69291bff0f" | 14 | SRC_URI[sha256sum] = "25d4967277cf27d4efb474a9b8eceb1200aa813a51c248b61cc23f69291bff0f" |
15 | |||
16 | do_install_append() { | ||
17 | install -d ${D}/${datadir}/applications/ | ||
18 | install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop | ||
19 | sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop | ||
20 | echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop | ||
21 | echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop | ||
22 | echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop | ||
23 | echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop | ||
24 | install -d ${D}/${datadir}/icons/ | ||
25 | install -m 644 ${S}/data/themes/img/O/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png | ||
26 | } | ||
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb b/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb new file mode 100644 index 000000000..ae21cc14e --- /dev/null +++ b/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | require ${BPN}.inc | ||
2 | |||
3 | SRCNAME = "enlightenment" | ||
4 | |||
5 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
6 | |||
7 | SRC_URI = "\ | ||
8 | ${E_RELEASES}/apps/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \ | ||
9 | file://enlightenment_start.oe \ | ||
10 | file://applications.menu \ | ||
11 | " | ||
12 | |||
13 | SRC_URI[md5sum] = "9f6e6c296b88b038ac05415006c678fd" | ||
14 | SRC_URI[sha256sum] = "17d207246bf10dec5a5fa854da5763e0e6dd61decde3474ff5fedffbb9dc8629" | ||
15 | |||
16 | do_configure_prepend() { | ||
17 | sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac | ||
18 | } | ||
19 | |||
20 | PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" | ||