summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/exalt_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/e17/exalt_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/e17/exalt_svn.bb')
-rw-r--r--meta-efl/recipes-efl/e17/exalt_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/exalt_svn.bb b/meta-efl/recipes-efl/e17/exalt_svn.bb
new file mode 100644
index 000000000..712204fba
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/exalt_svn.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
2HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
3
4LICENSE = "LGPLv2"
5DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
6RDEPENDS_${PN} = "vpnc wpa-supplicant"
7
8PV = "0.9+svnr${SRCPV}"
9SRCREV = "${EFL_SRCREV}"
10PR = "r1"
11
12inherit e
13SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
14S = "${WORKDIR}/${SRCNAME}"
15
16EXTRA_OECONF = " \
17--with-wpa_supplicant=${sbindir}/wpa_supplicant \
18--with-vpnc=${sbindir}/vpnc \
19--with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
20"
21
22do_install_append() {
23 # install dbus config file
24 install -d ${D}${sysconfdir}/dbus-1/system.d/
25 install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
26
27 # install dbus service file
28 install -d ${D}${datadir}/dbus-1/system-services/
29 install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
30}
31
32FILES_${PN} += "${datadir}/dbus-1"
33