summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/enjoy_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-31 21:18:57 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:16 +0100
commitf88e671b36b86d9ff43a3c38f7ebb800d69eadf0 (patch)
tree9309ffeeace4ef3bf58a68e051079cc553a0658b /meta-efl/recipes-efl/e17/enjoy_git.bb
parentf696e1bdb10f7b2cb139bf9048e478d9f10c5e17 (diff)
downloadmeta-openembedded-f88e671b36b86d9ff43a3c38f7ebb800d69eadf0.tar.gz
enjoy: switch from svn to newer git and update dependency from edbus2 to eldbus
* edbus2 was renamed to eldbus and is now included in efl source tree Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/e17/enjoy_git.bb')
-rw-r--r--meta-efl/recipes-efl/e17/enjoy_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/enjoy_git.bb b/meta-efl/recipes-efl/e17/enjoy_git.bb
new file mode 100644
index 000000000..bc3168e6a
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/enjoy_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Enjoy music player"
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
4DEPENDS = "evas ecore edje elementary emotion lightmediascanner eldbus gst-plugins-good"
5
6SRCREV = "aa8fec69e885eec048a849c2b34059ec58404e02"
7PV = "0.1.0+gitr${SRCPV}"
8
9#1st needed for all formats
10#2nd needed for mp3 playback
11#3d needed for ogg playback
12#4th needed for flac playback
13#5th needed binary to create db
14RDEPENDS_${PN} += "\
15 gst-plugins-base-typefindfunctions gst-plugins-base-playbin gst-plugins-base-volume gst-plugins-base-decodebin2 gst-plugins-good-autodetect \
16 gst-plugins-base-ogg gst-plugins-base-ivorbisdec \
17 gst-plugins-good-flac \
18 lightmediascanner-test \
19"
20
21inherit e gettext
22SRC_URI = " \
23 git://git.enlightenment.org/apps/enjoy.git \
24 file://0001-always-use-position-as-percent-and-define-a-1-second.patch \
25"
26S = "${WORKDIR}/git"
27
28FILES_${PN} += "${datadir}/icons/"
29
30EXTRA_OECONF = "\
31 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
32"
33
34PACKAGECONFIG[mad] = ",,gst-plugins-ugly,gst-plugins-ugly-mad"
35PACKAGECONFIG[id3demux] = ",,,gst-plugins-good-id3demux"
36
37do_configure_prepend() {
38 autopoint || touch config.rpath
39}
40
41pkg_postinst_${PN} () {
42 echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
43 echo "enjoy: Meanwhile please run:"
44 echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
45 echo "enjoy:"
46 echo "enjoy: Use test-lms -P to see available formats that can be scanned"
47}