summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/e-tasks_git.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-efl/recipes-efl/e17/e-tasks_git.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-efl/recipes-efl/e17/e-tasks_git.bb')
-rw-r--r--meta-efl/recipes-efl/e17/e-tasks_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/e-tasks_git.bb b/meta-efl/recipes-efl/e17/e-tasks_git.bb
new file mode 100644
index 000000000..606515783
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-tasks_git.bb
@@ -0,0 +1,32 @@
1SUMMARY = "e-tasks is a todo program for Openmoko phones"
2HOMEPAGE = "http://code.google.com/p/e-tasks/"
3AUTHOR = "cchandel"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
6SECTION = "e/apps"
7DEPENDS = "elementary eina eldbus sqlite3"
8
9inherit autotools
10
11SRCREV = "890f5ee37d1a5fd1ceb2495950d15151d4cf756b"
12PV = "0.0.2+gitr${SRCPV}"
13
14SRC_URI = "git://github.com/shr-project/e-tasks.git"
15SRC_URI += "file://0001-dbus-stuff-Convert-to-eldbus.patch"
16
17S = "${WORKDIR}/git"
18
19do_install_append() {
20 install -d "${D}/${datadir}/pixmaps"
21 install -m 0644 "${S}/resources/e-tasks.png" "${D}/${datadir}/pixmaps"
22 install -d "${D}/${datadir}/applications"
23 install -m 0644 "${S}/resources/e-tasks.desktop" "${D}/${datadir}/applications"
24 install -d "${D}/${datadir}/e-tasks"
25 for ico in "${S}/resources/"*.png; do
26 if [ "$(basename $ico)" != "e-tasks.png" ]; then
27 install -m 0644 $ico "${D}/${datadir}/e-tasks"
28 fi
29 done
30}
31
32FILES_${PN} += "/usr/share/e-tasks/* /usr/share/applications/* /usr/share/pixmaps/*"