diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-12-13 09:49:07 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-12-20 14:53:58 +0100 |
commit | 458f724d9bdb716b6907ea797a92fe0f67f1f72b (patch) | |
tree | e18337d08518cf6aa916823e238d52b14671bd37 /meta-efl/recipes-devtools/python | |
parent | 5b1dff8b4f52873060b75813eeba864d64a70083 (diff) | |
download | meta-openembedded-458f724d9bdb716b6907ea797a92fe0f67f1f72b.tar.gz |
e-base: bump EFL_SRCREV remove EFL_SRCREV_1.* and applied patches from libeflvala, elsa and python-elementary
* elementary (Evas_GL) and e-wm (backlight) depends on trunk again..
10:06:36 < JaMa> shouldn't elementary and e17 depend only on efl-1.1? | ./Elementary.h:372:21: fatal error: Evas_GL.h: No such file or directory and e/src/bin/e_backlight.c:43: undefined reference to
`ecore_x_randr_output_backlight_available'
10:07:32 < JaMa> but I'll recheck my configs
10:08:20 < moa> hum, that evas_gl.h would be a problem indeed
10:08:36 < moa> for e, i don't know
10:08:57 <@raster> elm requires svn evas
10:09:02 <@raster> thats unfortunately how it is
10:09:12 <@raster> requires evas_gl
10:09:35 < JaMa> maybe this is missing in 1.1 branch for e17? r65838
10:09:42 <@raster> yes
10:09:46 <@raster> its missing
10:09:50 <@raster> as its in trunk
10:09:53 <@raster> its a "new feature"
10:09:58 <@raster> not in stable
10:10:15 <@raster> uy'd have to patch out the support to make elm from svn build
10:10:42 < JaMa> raster: ok then I just didn't understand the dependency on "only" efl-1.1 right.. I'll update the rest of efl to same rev (instead of keeping them on 1.1 release)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools/python')
-rw-r--r-- | meta-efl/recipes-devtools/python/python-elementary/0001-python-elementary-temporary-fix-for-build-breakage.patch | 49 | ||||
-rw-r--r-- | meta-efl/recipes-devtools/python/python-elementary_svn.bb | 2 |
2 files changed, 0 insertions, 51 deletions
diff --git a/meta-efl/recipes-devtools/python/python-elementary/0001-python-elementary-temporary-fix-for-build-breakage.patch b/meta-efl/recipes-devtools/python/python-elementary/0001-python-elementary-temporary-fix-for-build-breakage.patch deleted file mode 100644 index ef61c991c..000000000 --- a/meta-efl/recipes-devtools/python/python-elementary/0001-python-elementary-temporary-fix-for-build-breakage.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 61b8233c582bcb1786bfcafa984abfd523fedcca Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Thu, 1 Dec 2011 22:07:38 +0100 | ||
4 | Subject: [PATCH] python-elementary: temporary fix for build breakage | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | .../include/elementary/c_elementary.pxd | 8 ++++---- | ||
9 | 1 files changed, 4 insertions(+), 4 deletions(-) | ||
10 | |||
11 | diff --git a/include/elementary/c_elementary.pxd b/include/elementary/c_elementary.pxd | ||
12 | index 16535c5..09986f8 100644 | ||
13 | --- a/include/elementary/c_elementary.pxd | ||
14 | +++ b/include/elementary/c_elementary.pxd | ||
15 | @@ -169,13 +169,13 @@ cdef extern from "Elementary.h": | ||
16 | evas.c_evas.Eina_Bool hover_top | ||
17 | evas.c_evas.Eina_Bool hover_bottom | ||
18 | |||
19 | - ctypedef char *(*GenlistItemLabelGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
20 | + ctypedef char *(*GenlistItemTextGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
21 | ctypedef evas.c_evas.Evas_Object *(*GenlistItemIconGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
22 | ctypedef evas.c_evas.Eina_Bool (*GenlistItemStateGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
23 | ctypedef void (*GenlistItemDelFunc)(void *data, evas.c_evas.Evas_Object *obj) | ||
24 | |||
25 | ctypedef struct Elm_Genlist_Item_Class_Func: | ||
26 | - GenlistItemLabelGetFunc label_get | ||
27 | + GenlistItemTextGetFunc text_get | ||
28 | GenlistItemIconGetFunc content_get | ||
29 | GenlistItemStateGetFunc state_get | ||
30 | GenlistItemDelFunc del_ "del" | ||
31 | @@ -184,13 +184,13 @@ cdef extern from "Elementary.h": | ||
32 | char *item_style | ||
33 | Elm_Genlist_Item_Class_Func func | ||
34 | |||
35 | - ctypedef char *(*GengridItemLabelGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
36 | + ctypedef char *(*GengridItemTextGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
37 | ctypedef evas.c_evas.Evas_Object *(*GengridItemIconGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
38 | ctypedef evas.c_evas.Eina_Bool (*GengridItemStateGetFunc)(void *data, evas.c_evas.Evas_Object *obj, const_char_ptr part) | ||
39 | ctypedef void (*GengridItemDelFunc)(void *data, evas.c_evas.Evas_Object *obj) | ||
40 | |||
41 | ctypedef struct Elm_Gengrid_Item_Class_Func: | ||
42 | - GengridItemLabelGetFunc label_get | ||
43 | + GengridItemTextGetFunc text_get | ||
44 | GengridItemIconGetFunc content_get | ||
45 | GengridItemStateGetFunc state_get | ||
46 | GengridItemDelFunc del_ "del" | ||
47 | -- | ||
48 | 1.7.8.rc4 | ||
49 | |||
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb index 37a8ffae4..6d8b0b8ea 100644 --- a/meta-efl/recipes-devtools/python/python-elementary_svn.bb +++ b/meta-efl/recipes-devtools/python/python-elementary_svn.bb | |||
@@ -5,5 +5,3 @@ PR = "${INC_PR}.2" | |||
5 | SRCREV = "${EFL_SRCREV}" | 5 | SRCREV = "${EFL_SRCREV}" |
6 | DEPENDS += "elementary python-evas" | 6 | DEPENDS += "elementary python-evas" |
7 | RDEPENDS_${PN} += "python-evas python-ecore python-edje" | 7 | RDEPENDS_${PN} += "python-evas python-ecore python-edje" |
8 | |||
9 | SRC_URI += " file://0001-python-elementary-temporary-fix-for-build-breakage.patch" | ||