summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:04:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commitec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch)
treee16d2a838f4561d5538928a58f805e5f1373225a /meta-efl/recipes-devtools/python
parent6775acb048dabd624c5c8197b683aba45ed91569 (diff)
downloadmeta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools/python')
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc46
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc71
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_1.15.0.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-efl_git.bb11
5 files changed, 0 insertions, 142 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
deleted file mode 100644
index cc6008387..000000000
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ /dev/null
@@ -1,46 +0,0 @@
1DESCRIPTION = "${PN} bindings"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
5# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
6# we need to build pyrex otherwise cython doesn't get called to build
7# the extension modules.
8DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
9RDEPENDS_${PN} += "python-lang python-dbus"
10
11inherit e-base autotools pkgconfig distutils-base
12
13SRCNAME = "python-e_dbus"
14SRCVER = "${PV}"
15
16SRC_URI = "\
17 ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
18"
19S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
20
21
22do_configure_prepend() {
23 # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
24 sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
25}
26
27do_install_append() {
28 if [ -e examples ]; then
29 for i in `find examples -name "*.edc"`; do
30 cd ${S}/`dirname $i`
31 echo "Generating .edj file for $i..."
32 edje_cc `basename $i`
33 echo "Removing sources in this directory..."
34 rm -f *.edc *.png *.ttf *.jpeg
35 done
36 cd ${S}
37 install -d ${D}${datadir}/${PN}/
38 cp -R --no-dereference --preserve=mode,links -v examples ${D}${datadir}/${PN}/
39 find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
40 fi
41}
42
43FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
44
45PACKAGES += "${PN}-examples"
46FILES_${PN}-examples = "${datadir}/${PN}/examples"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb b/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
deleted file mode 100644
index bfacf897f..000000000
--- a/meta-efl/recipes-devtools/python/python-edbus_1.7.0.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1require ${BPN}.inc
2
3PR = "r1"
4
5SRC_URI[md5sum] = "40b479444bb06147429a276127981890"
6SRC_URI[sha256sum] = "78e5ca334ee25185748660b4e612f984f4d3bced018f062278701429868f117b"
7
8PNBLACKLIST[python-edbus] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130600/ - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
deleted file mode 100644
index 6837dab9f..000000000
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ /dev/null
@@ -1,71 +0,0 @@
1DESCRIPTION = "${PN} bindings"
2
3LICENSE = "LGPL-3.0"
4LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
5# there is also GPLv3.0 in COPYING;md5=d32239bcb673463ab874e80d47fae504 but no file seems to use that
6
7AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
8# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
9# we need to build pyrex otherwise cython doesn't get called to build
10# the extension modules.
11DEPENDS = "python-cython-native python-pyrex-native python-numeric python-dbus lua efl elementary"
12RDEPENDS_${PN} += "python-lang"
13
14PROVIDES = "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas"
15
16inherit e-base distutils pkgconfig
17
18SRCVER = "${PV}"
19
20SRC_URI = "\
21 ${E_RELEASES}/bindings/python/${SRCNAME}-${SRCVER}.tar.gz \
22"
23S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
24
25do_install_append() {
26 # drop all .pyo, pyc files
27 find ${D}${libdir}/${PYTHON_DIR}/site-packages -name \*.pyo -o -name \*.pyc | xargs rm -f
28}
29
30PACKAGES += "python-ecore python-eldbus python-edje python-elementary python-emotion python-evas python-ethumb ${PN}-examples"
31
32FILES_${PN} = " \
33 ${libdir}/${PYTHON_DIR}/site-packages/python_efl*egg-info \
34 ${libdir}/${PYTHON_DIR}/site-packages/efl/eo.so \
35 ${libdir}/${PYTHON_DIR}/site-packages/efl/utils \
36 ${libdir}/${PYTHON_DIR}/site-packages/efl/__init__.py \
37"
38FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
39FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/*/*.la"
40
41FILES_${PN}-examples = "${datadir}/${PN}/examples"
42
43FILES_python-ecore = " \
44 ${libdir}/${PYTHON_DIR}/site-packages/ecore/ \
45 ${libdir}/${PYTHON_DIR}/site-packages/efl/ecore*.so \
46 ${libdir}/${PYTHON_DIR}/site-packages/efl/ecore \
47"
48FILES_python-eldbus = " \
49 ${libdir}/${PYTHON_DIR}/site-packages/e_dbus/ \
50 ${libdir}/${PYTHON_DIR}/site-packages/efl/dbus_mainloop.so \
51"
52FILES_python-edje = " \
53 ${libdir}/${PYTHON_DIR}/site-packages/edje/ \
54 ${libdir}/${PYTHON_DIR}/site-packages/efl/edje*.so \
55"
56FILES_python-elementary = " \
57 ${libdir}/${PYTHON_DIR}/site-packages/elementary/ \
58 ${libdir}/${PYTHON_DIR}/site-packages/efl/elementary/ \
59"
60FILES_python-emotion = " \
61 ${libdir}/${PYTHON_DIR}/site-packages/emotion/ \
62 ${libdir}/${PYTHON_DIR}/site-packages/efl/emotion.so \
63"
64FILES_python-evas = " \
65 ${libdir}/${PYTHON_DIR}/site-packages/evas/ \
66 ${libdir}/${PYTHON_DIR}/site-packages/efl/evas.so \
67"
68FILES_python-ethumb = " \
69 ${libdir}/${PYTHON_DIR}/site-packages/ethumb/ \
70 ${libdir}/${PYTHON_DIR}/site-packages/efl/ethumb*so \
71"
diff --git a/meta-efl/recipes-devtools/python/python-efl_1.15.0.bb b/meta-efl/recipes-devtools/python/python-efl_1.15.0.bb
deleted file mode 100644
index e9a79b252..000000000
--- a/meta-efl/recipes-devtools/python/python-efl_1.15.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require ${BPN}.inc
2
3SRC_URI[md5sum] = "f7c5d557336ea9df69bcca09c420711a"
4SRC_URI[sha256sum] = "11e607b465cb66dafe05c66e02d61e09335b370fe9fd2a74d88282b3ee597bcc"
5
6PNBLACKLIST[python-efl] ?= "Depends on blacklisted elementary - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-efl/recipes-devtools/python/python-efl_git.bb b/meta-efl/recipes-devtools/python/python-efl_git.bb
deleted file mode 100644
index 292b9eb87..000000000
--- a/meta-efl/recipes-devtools/python/python-efl_git.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1require ${BPN}.inc
2
3SRCREV = "71ed20ebf662a7b72e60913df94ce6933236bf09"
4PV = "1.12.0+git${SRCPV}"
5DEFAULT_PREFERENCE = "-1"
6
7SRC_URI = "git://git.enlightenment.org/bindings/python/${BPN}.git;branch=python-efl-1.12"
8
9S = "${WORKDIR}/git"
10
11PNBLACKLIST[python-efl] ?= "Depends on blacklisted elementary - the recipe will be removed on 2017-09-01 unless the issue is fixed"