diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-31 21:11:52 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-23 23:21:14 +0100 |
commit | 9234bcb0d30e66db7b8fcfd867086185649ecbae (patch) | |
tree | faddf5d0a24254d5e6121f92aa83b901c14ff450 /meta-efl/recipes-devtools/python/python-edbus.inc | |
parent | 29a37034c1205cd468815be33c69dcb560e77b67 (diff) | |
download | meta-openembedded-9234bcb0d30e66db7b8fcfd867086185649ecbae.tar.gz |
python-efl: upgrade from separate recipes to shared python-efl-1.8.1
* python-ecore, python-edbus, python-edje, python-elementary,
python-emotion, python-evas are now built from single source tree
* announcements:
1.8.0:
http://sourceforge.net/mailarchive/message.php?msg_id=31728838
1.8.1:
http://sourceforge.net/mailarchive/message.php?msg_id=31862842
* be aware that upgrade-path wont probably work correctly
and that you have to manually cleanup your sysroots before
migrating to new shared efl recipe, for details see
https://bugzilla.yoctoproject.org/show_bug.cgi?id=4102
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools/python/python-edbus.inc')
-rw-r--r-- | meta-efl/recipes-devtools/python/python-edbus.inc | 50 |
1 files changed, 47 insertions, 3 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc index 86ae77343..1d8098f60 100644 --- a/meta-efl/recipes-devtools/python/python-edbus.inc +++ b/meta-efl/recipes-devtools/python/python-edbus.inc | |||
@@ -1,6 +1,50 @@ | |||
1 | require python-efl.inc | 1 | DESCRIPTION = "${PN} bindings" |
2 | LICENSE = "LGPLv2.1" | 2 | LICENSE = "LGPLv2.1" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
4 | DEPENDS += "edbus python-dbus" | 4 | AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>" |
5 | RDEPENDS_${PN} += "python-dbus" | 5 | # NOTE: Due to a bug in distutils, even if we don't use pyrex but cython, |
6 | # we need to build pyrex otherwise cython doesn't get called to build | ||
7 | # the extension modules. | ||
8 | DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus" | ||
9 | RDEPENDS_${PN} += "python-lang python-dbus" | ||
10 | |||
11 | # necessary to let the call for python-config succeed | ||
12 | export BUILD_SYS | ||
13 | export HOST_SYS | ||
14 | |||
15 | inherit e-base autotools pkgconfig distutils-base | ||
16 | |||
6 | SRCNAME = "python-e_dbus" | 17 | SRCNAME = "python-e_dbus" |
18 | SRCVER = "${PV}" | ||
19 | |||
20 | SRC_URI = "\ | ||
21 | ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \ | ||
22 | " | ||
23 | S = "${WORKDIR}/${SRCNAME}-${SRCVER}" | ||
24 | |||
25 | |||
26 | do_configure_prepend() { | ||
27 | # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly | ||
28 | sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac | ||
29 | } | ||
30 | |||
31 | do_install_append() { | ||
32 | if [ -e examples ]; then | ||
33 | for i in `find examples -name "*.edc"`; do | ||
34 | cd ${S}/`dirname $i` | ||
35 | echo "Generating .edj file for $i..." | ||
36 | edje_cc `basename $i` | ||
37 | echo "Removing sources in this directory..." | ||
38 | rm -f *.edc *.png *.ttf *.jpeg | ||
39 | done | ||
40 | cd ${S} | ||
41 | install -d ${D}${datadir}/${PN}/ | ||
42 | cp -a examples ${D}${datadir}/${PN}/ | ||
43 | find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf | ||
44 | fi | ||
45 | } | ||
46 | |||
47 | FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug" | ||
48 | |||
49 | PACKAGES += "${PN}-examples" | ||
50 | FILES_${PN}-examples = "${datadir}/${PN}/examples" | ||