summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSipke Vriend <sipke.vriend@gmail.com>2018-05-10 09:12:24 +1000
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:23:24 -0700
commitf90318b625a90993c4e20c981201602e37f89481 (patch)
treef4a9dbb98d490c403266ffe0ef4305df87351a07
parent676b1771438d1b71e95165102a625b40fb4d17fb (diff)
downloadmeta-openembedded-f90318b625a90993c4e20c981201602e37f89481.tar.gz
python-robotframework: Add runtime dependencies to robot framework
Add the runtime dependencies robot framework has so they are available on images including it. python-robotframework.inc is included by both python3 and python robot framework. python3 includes zlib by default so include python-zlib as a runtime dependency in the python-robotframework recipe and not in the python3-robotframework. Signed-off-by: Sipke Vriend <sipke.vriend@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb4
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-robotframework.inc b/meta-python/recipes-devtools/python/python-robotframework.inc
index cc20d6477..78bbbc6de 100644
--- a/meta-python/recipes-devtools/python/python-robotframework.inc
+++ b/meta-python/recipes-devtools/python/python-robotframework.inc
@@ -13,3 +13,14 @@ inherit pypi
13 13
14SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa" 14SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa"
15SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7" 15SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7"
16
17RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-shell \
19 ${PYTHON_PN}-pprint \
20 ${PYTHON_PN}-xml \
21 ${PYTHON_PN}-difflib \
22 ${PYTHON_PN}-threading \
23 ${PYTHON_PN}-html \
24 ${PYTHON_PN}-docutils \
25 ${PYTHON_PN}-ctypes \
26"
diff --git a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
index 16eaa78cd..ff7dedb55 100644
--- a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
+++ b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
@@ -1,2 +1,6 @@
1inherit setuptools 1inherit setuptools
2require python-robotframework.inc 2require python-robotframework.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-zlib \
6"