summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Bresticker <abrestic@waymo.com>2018-09-14 16:57:27 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:02:18 -0700
commitea2ee9c7acbfc23b39eb57301dd66c80b389200d (patch)
tree8e7dbea2aab017dec39bd632dcd7a664c1e81af3
parentdcd9887931a2ab10309599935ddec1256b07e942 (diff)
downloadmeta-openembedded-ea2ee9c7acbfc23b39eb57301dd66c80b389200d.tar.gz
libdevmapper: Install dmsetup
Commit 6aa1dd223a140 ("lvm2/libdevmapper: fix invoking lvcreate failed") moved installation of dmsetup back to lvm2 from libdevmapper, but dmsetup had intentionally been moved to libdevmapper in commit 269d009a81d4 ("lvm2: libdevicemapper package needs udev rules and dmsetup"). Add it back to libdevmapper by explicitly installing it in do_install(), and refresh explicitly-do-not-install-libdm.patch so that we also explicitly do not install dmsetup as part of lvm2. Signed-off-by: Andrew Bresticker <abrestic@waymo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb1
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch28
2 files changed, 23 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
index f3f11ef64..26af3275d 100644
--- a/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
+++ b/meta-oe/recipes-support/lvm2/libdevmapper_2.02.180.bb
@@ -9,6 +9,7 @@ TARGET_CC_ARCH += "${LDFLAGS}"
9 9
10do_install() { 10do_install() {
11 oe_runmake 'DESTDIR=${D}' -C libdm install 11 oe_runmake 'DESTDIR=${D}' -C libdm install
12 oe_runmake 'DESTDIR=${D}' -C tools install_device-mapper
12} 13}
13 14
14RRECOMMENDS_${PN}_append_class-target = " lvm2-udevrules" 15RRECOMMENDS_${PN}_append_class-target = " lvm2-udevrules"
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
index e85818dbd..7f5dd9334 100644
--- a/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
+++ b/meta-oe/recipes-support/lvm2/lvm2/0001-explicitly-do-not-install-libdm.patch
@@ -1,4 +1,4 @@
1From 0a8e466fcf99622896e070c5133165e4278e8cfb Mon Sep 17 00:00:00 2001 1From 5a3e13ae94318c2bed60f875bb3852c45ce0113c Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 25 May 2017 05:27:11 -0400 3Date: Thu, 25 May 2017 05:27:11 -0400
4Subject: [PATCH] explicitly do not install libdm 4Subject: [PATCH] explicitly do not install libdm
@@ -9,12 +9,14 @@ explicitly do not do the installation here.
9Upstream-Status: Inappropriate [meta-oe specific] 9Upstream-Status: Inappropriate [meta-oe specific]
10 10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12Signed-off-by: Andrew Bresticker <abrestic@waymo.com>
12--- 13---
13 libdm/Makefile.in | 6 ++++-- 14 libdm/Makefile.in | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-) 15 tools/Makefile.in | 3 ++-
16 2 files changed, 6 insertions(+), 3 deletions(-)
15 17
16diff --git a/libdm/Makefile.in b/libdm/Makefile.in 18diff --git a/libdm/Makefile.in b/libdm/Makefile.in
17index 3c9a4ce..45c91c6 100644 19index 66ec39513..c779c9d86 100644
18--- a/libdm/Makefile.in 20--- a/libdm/Makefile.in
19+++ b/libdm/Makefile.in 21+++ b/libdm/Makefile.in
20@@ -77,9 +77,11 @@ ifeq ("@PKGCONFIG@", "yes") 22@@ -77,9 +77,11 @@ ifeq ("@PKGCONFIG@", "yes")
@@ -23,14 +25,28 @@ index 3c9a4ce..45c91c6 100644
23 25
24-install: $(INSTALL_TYPE) install_include 26-install: $(INSTALL_TYPE) install_include
25+install: 27+install:
26+ echo "Do not install device mappler in lvm2" 28+ echo "Do not install device mapper in lvm2"
27 29
28-install_device-mapper: install 30-install_device-mapper: install
29+install_device-mapper: 31+install_device-mapper:
30+ echo "Do not install device mappler in lvm2" 32+ echo "Do not install device mapper in lvm2"
31 33
32 install_include: $(srcdir)/libdevmapper.h 34 install_include: $(srcdir)/libdevmapper.h
33 $(INSTALL_DATA) -D $< $(includedir)/$(<F) 35 $(INSTALL_DATA) -D $< $(includedir)/$(<F)
36diff --git a/tools/Makefile.in b/tools/Makefile.in
37index 103b76732..63ba7fc04 100644
38--- a/tools/Makefile.in
39+++ b/tools/Makefile.in
40@@ -267,7 +267,8 @@ install_dmsetup_static: dmsetup.static
41 $(Q) $(INSTALL_PROGRAM) -D $< $(staticdir)/$(<F)
42 $(Q) $(LN_S) -f $(<F) $(staticdir)/dmstats
43
44-install_device-mapper: $(INSTALL_DMSETUP_TARGETS)
45+install_device-mapper:
46+ echo "Do not install device mapper in lvm2"
47
48 install_lvm2: $(INSTALL_LVM_TARGETS)
49
34-- 50--
352.8.1 512.19.0.397.gdd90340f6a-goog
36 52