summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2018-09-12 10:09:13 +0200
committerKhem Raj <raj.khem@gmail.com>2018-09-12 07:08:49 -0700
commitdca2a7f628854235608c4c05081dc66ba0f94690 (patch)
treecfb5fc97114da5710486ef3717ba8beac564d4ab
parent376eb385a519875683665760bcf4f83b940890a4 (diff)
downloadmeta-openembedded-dca2a7f628854235608c4c05081dc66ba0f94690.tar.gz
networkd-dispatcher: new package
This adds a recipe for networkd-dispatcher. It's a simple package containing a python script that needs to be installed together with a systemd service and an example config file. There's nothing to build. Tested with current poky & meta-openembedded master branches. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher.bb
new file mode 100644
index 000000000..050a93824
--- /dev/null
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher.bb
@@ -0,0 +1,34 @@
1python __anonymous() {
2 features = d.getVar('DISTRO_FEATURES')
3 if not features or 'systemd' not in features:
4 raise bb.parse.SkipPackage('networkd-dispatcher needs systemd in DISTRO_FEATURES')
5}
6
7SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
8DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
9more limited in the types of events it supports due to the limited nature of \
10systemd-networkd(8)."
11AUTHOR = "Clayton Craft and others"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
15
16RDEPENDS_${PN} = "systemd python3 python3-pygobject python3-dbus"
17
18SRC_URI = "git://gitlab.com/craftyguy/networkd-dispatcher.git;protocol=https"
19SRCREV = "c7e25623a161b64618ea778541c064d2a1df086b"
20PV = "1.7+git${SRCPV}"
21
22S = "${WORKDIR}/git"
23
24# Nothing to build, just a python script to install
25do_configure[noexec] = "1"
26do_compile[noexec] = "1"
27
28do_install() {
29 install -D -m 0755 ${S}/networkd-dispatcher ${D}${sbindir}/networkd-dispatcher
30 install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
31 install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
32}
33
34FILES_${PN} += "${systemd_system_unitdir}/networkd-dispatcher.service"