summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reichel <sebastian.reichel@collabora.co.uk>2018-02-28 17:31:08 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:14:25 -0700
commitdc4fc199f5adeaef98e789b58c213529f81cf175 (patch)
tree11192299516d6c4540d874ff1369923e357f4c4f
parent2918d4dcf77c1acfaf32b5d2e1f0c3bce38b87ee (diff)
downloadmeta-openembedded-dc4fc199f5adeaef98e789b58c213529f81cf175.tar.gz
fvwm: add new recipe
Add recipe for a minimal built of fvwm. Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.co.uk> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch69
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm/0002-Avoid-absolute-symlinks.patch27
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb114
3 files changed, 210 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch b/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch
new file mode 100644
index 000000000..5a7647455
--- /dev/null
+++ b/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch
@@ -0,0 +1,69 @@
1From 60c17eb49121bf2aa485acd30750b2fc6c8eb61f Mon Sep 17 00:00:00 2001
2From: Jarmo Jaakkola <jarmo.jaakkola@vincit.fi>
3Date: Mon, 19 Jun 2017 16:41:36 +0300
4Subject: [PATCH] Fix compilation for Helix.
5
6Gnome support, including GNOME_INIT_HOOK, has been removed, but it was
7still being called.
8
9COMPAT_OLD_KEYSYMDEF is a check for a legacy system, which our system
10most definitely is not. It is accomplished by trying to execute
11a program, which does not work when cross compiling.
12
13The fvwm(1) man page is created from Docbook XML which is set for
14a Windows code page that is not available when compiling. Easiest is
15to just not create the man page as those are not needed on the monitor.
16
17Upstream-Status: inappropriate [OE specific]
18Signed-off-by: Jarmo Jaakkola <jarmo.jaakkola@vincit.fi>
19Signed-off-by: Riku Hämäläinen <riku.hamalainen@ge.com>
20Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.co.uk>
21---
22 configure.ac | 20 ++++----------------
23 doc/fvwm/Makefile.am | 2 +-
24 3 files changed, 7 insertions(+), 17 deletions(-)
25
26diff --git a/configure.ac b/configure.ac
27index 48ce264..fab7b44 100644
28--- a/configure.ac
29+++ b/configure.ac
30@@ -1413,23 +1413,7 @@ else
31 problem_gdkimlib=": Failed on gdk-imlib, see config.log"
32 fi
33
34-GNOME_INIT_HOOK
35-
36-# Unfortunately we have 2 gnome supports: WM hints and gnome libs.
37-# The $with_gnomehints below refers to the first, not GNOME_INIT_HOOK.
38-if test ! x"$enable_gnome_hints" = xno; then
39- with_gnomehints=yes
40- problem_gnomehints=""
41-else
42- with_gnomehints=no
43- problem_gnomehints=": Explicitly disabled"
44-fi
45-
46 # Define some compatibility macros needed for config.h.
47-mg_DEFINE_IF_NOT([#include <X11/keysym.h>],
48- [defined XK_Page_Up && defined XK_Page_Down],
49- [COMPAT_OLD_KEYSYMDEF], [$X_CFLAGS],
50- [Old AIX systems (3.2.5) don't define some common keysyms.])
51 AH_VERBATIM([_COMPAT_OLD_KEYSYMDEF],
52 [#ifdef COMPAT_OLD_KEYSYMDEF
53 # define XK_Page_Up XK_Prior
54diff --git a/doc/fvwm/Makefile.am b/doc/fvwm/Makefile.am
55index cddb102..ff00149 100755
56--- a/doc/fvwm/Makefile.am
57+++ b/doc/fvwm/Makefile.am
58@@ -10,7 +10,7 @@ XSL_PROFILE = $(srcdir)/../docbook-xsl/profiling/profile.xsl
59 HTML_FILES = fvwm.man.html
60 XML_FILES = @DOC_SECTIONS_XML_PATH@
61 EXTRA_DIST = @DOC_SECTIONS_XML@ $(man_MANS) sections
62-man_MANS = fvwm.1
63+man_MANS =
64
65 if FVWM_BUILD_HTMLDOC
66 doc_DATA = $(HTML_FILES)
67--
681.9.1
69
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm/0002-Avoid-absolute-symlinks.patch b/meta-oe/recipes-graphics/fvwm/fvwm/0002-Avoid-absolute-symlinks.patch
new file mode 100644
index 000000000..756cc86e8
--- /dev/null
+++ b/meta-oe/recipes-graphics/fvwm/fvwm/0002-Avoid-absolute-symlinks.patch
@@ -0,0 +1,27 @@
1From: Sebastian Reichel <sebastian.reichel@collabora.co.uk>
2Date: Tue, 29 Auf 2017 16:08:42 +0200
3Subject: [PATCH] Avoid absolute symlinks
4
5Avoid usage of absolute symlinks, which breaks yocto builds
6since pyro.
7
8Upstream-Status: Pending
9Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.co.uk>
10
11diff --git a/default-config/Makefile.am b/default-config/Makefile.am
12index 5e16d095a137..5404145a742c 100644
13--- a/default-config/Makefile.am
14+++ b/default-config/Makefile.am
15@@ -17,9 +17,9 @@ EXTRA_DIST = images \
16
17 install-data-hook:
18 cp -r $(srcdir)/images $(inst_location)
19- ln -sf $(inst_location)/FvwmScript-DateTime $(inst_location)/..
20- ln -sf $(inst_location)/FvwmScript-ConfirmQuit $(inst_location)/..
21- ln -sf $(inst_location)/FvwmScript-ConfirmCopyConfig $(inst_location)/..
22+ ln -sf default-config/FvwmScript-DateTime $(inst_location)/..
23+ ln -sf default-config/FvwmScript-ConfirmQuit $(inst_location)/..
24+ ln -sf default-config/FvwmScript-ConfirmCopyConfig $(inst_location)/..
25
26 uninstall-hook:
27 rm -fr $(DESTDIR)/$(configdir)
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb
new file mode 100644
index 000000000..cb851bfd9
--- /dev/null
+++ b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb
@@ -0,0 +1,114 @@
1SUMMARY = "F Virtual Window Manager "
2HOMEPAGE = "http://www.fvwm.org/"
3SECTION = "x11/wm"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=363fbcfb59124689af72c914560eaf6e"
6
7DEPENDS = " \
8 bison-native \
9 flex-native \
10 freetype-native \
11 gettext-native \
12 libxslt-native \
13 fontconfig \
14 libice \
15 libpng \
16 librsvg \
17 libsm \
18 libxau \
19 libxcb \
20 libxcursor \
21 libxdmcp \
22 libxext \
23 libxfixes \
24 libxft \
25 libxinerama \
26 libxml2 \
27 libxrender \
28 libxt \
29 virtual/libx11 \
30 xrandr \
31 zlib \
32"
33
34PV = "2.6.7+git${SRCPV}"
35
36SRC_URI = " \
37 git://github.com/fvwmorg/fvwm.git;protocol=https \
38 file://0001-Fix-compilation-for-disabled-gnome.patch \
39 file://0002-Avoid-absolute-symlinks.patch \
40"
41
42SRCREV = "597a4e296da4f21e71a17facab297e016a3a80a8"
43
44S = "${WORKDIR}/git"
45
46inherit autotools gettext update-alternatives pkgconfig pythonnative perlnative distro_features_check
47# depends on virtual/libx11
48REQUIRED_DISTRO_FEATURES = "x11"
49
50ALTERNATIVE_${PN} = "x-window-manager"
51ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm"
52ALTERNATIVE_PRIORITY[x-window-manager] = "20"
53
54EXTRA_OECONF = " \
55 --disable-bidi \
56 --disable-fontconfigtest \
57 --disable-freetypetest \
58 --disable-htmldoc \
59 --disable-imlibtest \
60 --disable-mandoc \
61 --disable-nls \
62 --disable-perllib \
63 --disable-rsvg \
64 --disable-shape \
65 --disable-sm \
66 --disable-xfttest \
67 --with-imlib-exec-prefix=/nonexistent \
68 --with-imlib-prefix=/nonexistent \
69 --without-ncurses-library \
70 --without-readline-library \
71 --without-rplay-library \
72 --without-stroke-library \
73 --without-termcap-library \
74 --without-xpm-library \
75 ac_cv_func_mkstemp=no \
76 has_safety_mkstemp=yes \
77"
78
79# show the exact commands in the log file
80EXTRA_OEMAKE = " \
81 V=1 \
82"
83
84do_install_append() {
85 install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm
86 # You can install the config file here
87
88 install -d -m 0755 ${D}/${datadir}/fvwm
89 touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
90}
91
92# the only needed packages (note: locale packages are automatically generated
93# as well)
94PACKAGES = " \
95 ${PN} \
96 ${PN}-dbg \
97"
98
99# minimal set of binaries
100FILES_${PN} = " \
101 ${bindir}/fvwm \
102 ${bindir}/fvwm-root \
103 ${datadir}/fvwm/ConfigFvwmDefaults \
104"
105
106RDEPENDS_${PN} = " \
107 xuser-account \
108"
109
110# by default a lot of stuff is installed and it's not easy to control what to
111# install, so install everything, but skip the check
112INSANE_SKIP_${PN} = " \
113 installed-vs-shipped \
114"