summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-09-14 18:09:59 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:02:24 -0700
commita6dbefafd7b1aa89a040b330db223a449e4dd536 (patch)
treeed2b9e58220d1c7fe7ce71db688a8da42c0cf870
parentea2ee9c7acbfc23b39eb57301dd66c80b389200d (diff)
downloadmeta-openembedded-a6dbefafd7b1aa89a040b330db223a449e4dd536.tar.gz
stunnel: update 5.35 -> 5.49
- Update LIC_FILES_CHKSUM due to change in COPYING copyright year - Fix dependency on libnsl2 (previously provided indirectly by tcp-wrappers) - Drop obsolete dependency on zlib - Add PACKAGECONFIG control for libwrap - Move legacy stunnel3 wrapper (and its perl dependency) into separate package For a full list of changes between stunnel 5.35 and 5.49 see: https://www.stunnel.org/sdf_ChangeLog.html Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/stunnel/stunnel_5.35.bb26
-rw-r--r--meta-networking/recipes-support/stunnel/stunnel_5.49.bb37
2 files changed, 37 insertions, 26 deletions
diff --git a/meta-networking/recipes-support/stunnel/stunnel_5.35.bb b/meta-networking/recipes-support/stunnel/stunnel_5.35.bb
deleted file mode 100644
index 427c8dd7b..000000000
--- a/meta-networking/recipes-support/stunnel/stunnel_5.35.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2HOMEPAGE = "http://www.stunnel.org/"
3DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
4SECTION = "net"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=866cdc7459d91e092b174388fab8d283"
7DEPENDS = "openssl zlib tcp-wrappers"
8
9RDEPENDS_${PN} += "perl"
10
11SRC_URI = "ftp://ftp.stunnel.org/stunnel/archive/5.x/${BP}.tar.gz \
12 file://fix-openssl-no-des.patch \
13"
14
15SRC_URI[md5sum] = "9079f5fafbccaf88b7d92b227d78249a"
16SRC_URI[sha256sum] = "ffa386ae4c825f35f35157c285e7402a6d58779ad8c3822f74a9d355b54aba1d"
17
18inherit autotools
19
20EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
21# When cross compiling, configure defaults to nobody, but provides no option to change it.
22EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)}"
25PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
26PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-networking/recipes-support/stunnel/stunnel_5.49.bb b/meta-networking/recipes-support/stunnel/stunnel_5.49.bb
new file mode 100644
index 000000000..eca77cf84
--- /dev/null
+++ b/meta-networking/recipes-support/stunnel/stunnel_5.49.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Program for providing universal TLS/SSL tunneling service"
2DESCRIPTION = "SSL encryption wrapper between remote client and local (inetd-startable) or remote server."
3HOMEPAGE = "https://www.stunnel.org/"
4SECTION = "net"
5# Note: Linking stunnel statically or dynamically with other modules is making
6# a combined work based on stunnel. Thus, the terms and conditions of the GNU
7# General Public License cover the whole combination.
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=f6b7fe7379c9c2d7db6c80f7bd41e06d"
10
11DEPENDS = "autoconf-archive libnsl2 openssl"
12
13SRC_URI = "ftp://ftp.stunnel.org/stunnel/archive/5.x/${BP}.tar.gz \
14 file://fix-openssl-no-des.patch \
15"
16
17SRC_URI[md5sum] = "0b41240e5585ec7d55ca343feed5530f"
18SRC_URI[sha256sum] = "3d6641213a82175c19f23fde1c3d1c841738385289eb7ca1554f4a58b96d955e"
19
20inherit autotools
21
22PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} libwrap"
23
24PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
25PACKAGECONFIG[libwrap] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
26PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
27
28EXTRA_OECONF += "--with-ssl='${STAGING_EXECPREFIXDIR}' --disable-fips"
29
30# When cross compiling, configure defaults to nobody, but provides no option to change it.
31EXTRA_OEMAKE += "DEFAULT_GROUP='nogroup'"
32
33# stunnel3 is a Perl wrapper to allow use of the legacy stunnel 3.x commandline
34# syntax with stunnel >= 4.05
35PACKAGES =+ "stunnel3"
36FILES_stunnel3 = "${bindir}/stunnel3"
37RDEPENDS_stunnel3 += "${PN} perl"