summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-13 14:13:11 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-14 19:01:41 -0700
commit8baaf208809ed9995f200c59866bcf123938a8a9 (patch)
treeeae5035a63e7790ef8b3f9bd92e75bdfc5af56f9
parent6e9c34d6a1285e487dcfeb804b1a4b4b853f0c63 (diff)
downloadmeta-openembedded-8baaf208809ed9995f200c59866bcf123938a8a9.tar.gz
thrift: Refresh patches
Make devtool happy patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch6
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch8
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch14
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch17
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0005-THRIFT-3878-Compile-error-in-TSSLSocket.cpp-with-new.patch6
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0006-THRIFT-3736-C++-library-build-fails-if-OpenSSL-does-.patch13
6 files changed, 36 insertions, 28 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch
index fcc2f0821..a77cd284b 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch
@@ -1,9 +1,10 @@
1From b3da0d8677b7e8467367a303c18551c56ed20e15 Mon Sep 17 00:00:00 2001 1From a5544d8e543436e413379422b702f6f56ac7eb8e Mon Sep 17 00:00:00 2001
2From: Philip Balister <philip@balister.org> 2From: Philip Balister <philip@balister.org>
3Date: Tue, 12 Apr 2016 17:30:15 -0400 3Date: Tue, 12 Apr 2016 17:30:15 -0400
4Subject: [PATCH] Forcibly disable check for Qt5. 4Subject: [PATCH] Forcibly disable check for Qt5.
5 5
6Signed-off-by: Philip Balister <philip@balister.org> 6Signed-off-by: Philip Balister <philip@balister.org>
7
7--- 8---
8 build/cmake/DefineOptions.cmake | 3 --- 9 build/cmake/DefineOptions.cmake | 3 ---
9 1 file changed, 3 deletions(-) 10 1 file changed, 3 deletions(-)
@@ -22,6 +23,3 @@ index 62e240f..f8b4493 100644
22 if(${WITH_QT4} AND ${WITH_QT5} AND ${CMAKE_MAJOR_VERSION} LESS 3) 23 if(${WITH_QT4} AND ${WITH_QT5} AND ${CMAKE_MAJOR_VERSION} LESS 3)
23 # cmake < 3.0.0 causes conflict when building both Qt4 and Qt5 24 # cmake < 3.0.0 causes conflict when building both Qt4 and Qt5
24 set(WITH_QT4 OFF) 25 set(WITH_QT4 OFF)
25--
262.5.5
27
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch
index 7cc8d1739..182eacc0e 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch
@@ -1,7 +1,7 @@
1From bc577820ad25795543b31f123e309cdaebc7d6c6 Mon Sep 17 00:00:00 2001 1From b8e254a2f4ba49412e541598c72159869a7770f8 Mon Sep 17 00:00:00 2001
2From: Cody P Schafer <dev@codyps.com> 2From: Cody P Schafer <dev@codyps.com>
3Date: Mon, 16 May 2016 15:21:10 -0400 3Date: Mon, 16 May 2016 15:21:10 -0400
4Subject: [PATCH 1/2] THRIFT-3828 In cmake avoid use of both quoted paths and 4Subject: [PATCH] THRIFT-3828 In cmake avoid use of both quoted paths and
5 SYSTEM with include_directories() 5 SYSTEM with include_directories()
6 6
7This allows us to avoid issues where there are no paths to be added to 7This allows us to avoid issues where there are no paths to be added to
@@ -11,6 +11,7 @@ string).
11Specifically, gcc-6 requires that libraries stop passing paths like 11Specifically, gcc-6 requires that libraries stop passing paths like
12'/usr/include' (or they will get libstdc++ build errors), so these paths 12'/usr/include' (or they will get libstdc++ build errors), so these paths
13will be empty more often in the future. 13will be empty more often in the future.
14
14--- 15---
15 lib/cpp/CMakeLists.txt | 8 ++++---- 16 lib/cpp/CMakeLists.txt | 8 ++++----
16 lib/cpp/test/CMakeLists.txt | 2 +- 17 lib/cpp/test/CMakeLists.txt | 2 +-
@@ -105,6 +106,3 @@ index 2b0c143..5ecae17 100644
105 106
106 #Make sure gen-cpp files can be included 107 #Make sure gen-cpp files can be included
107 include_directories("${CMAKE_CURRENT_BINARY_DIR}") 108 include_directories("${CMAKE_CURRENT_BINARY_DIR}")
108--
1092.9.3
110
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch
index f13adbb6b..37715c281 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch
@@ -1,7 +1,7 @@
1From f6cad0580e5391c37af7f60adddb71bf1a403dc4 Mon Sep 17 00:00:00 2001 1From 7b05a74432f08ef34d0f8743dd6438ad012e3b5e Mon Sep 17 00:00:00 2001
2From: Cody P Schafer <dev@codyps.com> 2From: Cody P Schafer <dev@codyps.com>
3Date: Fri, 9 Sep 2016 15:50:26 -0400 3Date: Fri, 9 Sep 2016 15:50:26 -0400
4Subject: [PATCH 2/2] THRIFT-3831 in test/cpp explicitly use `signed char` 4Subject: [PATCH] THRIFT-3831 in test/cpp explicitly use `signed char`
5 5
6`char`'s signed-ness is implimentation dependent, and in the case where 6`char`'s signed-ness is implimentation dependent, and in the case where
7`char` was not signed, we previously recieved errors like 7`char` was not signed, we previously recieved errors like
@@ -9,15 +9,16 @@ Subject: [PATCH 2/2] THRIFT-3831 in test/cpp explicitly use `signed char`
9 thrift/0.9.3-r0/git/test/cpp/src/TestClient.cpp:404:15: error: narrowing conversion of '-127' from 'int' to 'char' inside { } [-Wnarrowing] 9 thrift/0.9.3-r0/git/test/cpp/src/TestClient.cpp:404:15: error: narrowing conversion of '-127' from 'int' to 'char' inside { } [-Wnarrowing]
10 10
11(This example from gcc-6 on arm) 11(This example from gcc-6 on arm)
12
12--- 13---
13 test/cpp/src/TestClient.cpp | 4 ++-- 14 test/cpp/src/TestClient.cpp | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-) 15 1 file changed, 2 insertions(+), 2 deletions(-)
15 16
16diff --git a/test/cpp/src/TestClient.cpp b/test/cpp/src/TestClient.cpp 17diff --git a/test/cpp/src/TestClient.cpp b/test/cpp/src/TestClient.cpp
17index e709899..4a961f8 100644 18index 7c425a9..7145ebb 100644
18--- a/test/cpp/src/TestClient.cpp 19--- a/test/cpp/src/TestClient.cpp
19+++ b/test/cpp/src/TestClient.cpp 20+++ b/test/cpp/src/TestClient.cpp
20@@ -383,7 +383,7 @@ int main(int argc, char** argv) { 21@@ -381,7 +381,7 @@ int main(int argc, char** argv) {
21 * BINARY TEST 22 * BINARY TEST
22 */ 23 */
23 printf("testBinary([-128..127]) = {"); 24 printf("testBinary([-128..127]) = {");
@@ -26,7 +27,7 @@ index e709899..4a961f8 100644
26 = {-128, -127, -126, -125, -124, -123, -122, -121, -120, -119, -118, -117, -116, -115, -114, 27 = {-128, -127, -126, -125, -124, -123, -122, -121, -120, -119, -118, -117, -116, -115, -114,
27 -113, -112, -111, -110, -109, -108, -107, -106, -105, -104, -103, -102, -101, -100, -99, 28 -113, -112, -111, -110, -109, -108, -107, -106, -105, -104, -103, -102, -101, -100, -99,
28 -98, -97, -96, -95, -94, -93, -92, -91, -90, -89, -88, -87, -86, -85, -84, 29 -98, -97, -96, -95, -94, -93, -92, -91, -90, -89, -88, -87, -86, -85, -84,
29@@ -404,7 +404,7 @@ int main(int argc, char** argv) { 30@@ -402,7 +402,7 @@ int main(int argc, char** argv) {
30 127}; 31 127};
31 try { 32 try {
32 string bin_result; 33 string bin_result;
@@ -35,6 +36,3 @@ index e709899..4a961f8 100644
35 if (bin_result.size() != 256) { 36 if (bin_result.size() != 256) {
36 printf("}\n*** FAILED ***\n"); 37 printf("}\n*** FAILED ***\n");
37 printf("invalid length: %lu\n", bin_result.size()); 38 printf("invalid length: %lu\n", bin_result.size());
38--
392.9.3
40
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch
index 44764359c..500cfab62 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch
@@ -1,5 +1,15 @@
1From 5f2c7e50b99d72177250c44236c41b99bfc161b5 Mon Sep 17 00:00:00 2001
2From: Andrej Valek <andrej.valek@siemens.com>
3Date: Thu, 7 Jun 2018 15:21:06 +0200
4Subject: [PATCH 4/6] %% original patch:
5 0004-THRIFT-3207-enable-build-with-OpenSSL-1.1.0-series.patch
6
7---
8 lib/cpp/src/thrift/transport/TSSLSocket.cpp | 6 ++++++
9 1 file changed, 6 insertions(+)
10
1diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 11diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
2index 68e475d..19132ff 100644 12index 98c5326..3da9e45 100644
3--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp 13--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp
4+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 14+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
5@@ -39,6 +39,7 @@ 15@@ -39,6 +39,7 @@
@@ -10,7 +20,7 @@ index 68e475d..19132ff 100644
10 20
11 using namespace std; 21 using namespace std;
12 using namespace apache::thrift::concurrency; 22 using namespace apache::thrift::concurrency;
13@@ -148,10 +149,15 @@ SSLContext::SSLContext(const SSLProtocol& protocol) { 23@@ -143,10 +144,15 @@ SSLContext::SSLContext(const SSLProtocol& protocol) {
14 ctx_ = SSL_CTX_new(SSLv3_method()); 24 ctx_ = SSL_CTX_new(SSLv3_method());
15 } else if (protocol == TLSv1_0) { 25 } else if (protocol == TLSv1_0) {
16 ctx_ = SSL_CTX_new(TLSv1_method()); 26 ctx_ = SSL_CTX_new(TLSv1_method());
@@ -26,3 +36,6 @@ index 68e475d..19132ff 100644
26 } else { 36 } else {
27 /// UNKNOWN PROTOCOL! 37 /// UNKNOWN PROTOCOL!
28 throw TSSLException("SSL_CTX_new: Unknown protocol"); 38 throw TSSLException("SSL_CTX_new: Unknown protocol");
39--
402.19.0
41
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0005-THRIFT-3878-Compile-error-in-TSSLSocket.cpp-with-new.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0005-THRIFT-3878-Compile-error-in-TSSLSocket.cpp-with-new.patch
index 8d7105667..f4482b109 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0005-THRIFT-3878-Compile-error-in-TSSLSocket.cpp-with-new.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0005-THRIFT-3878-Compile-error-in-TSSLSocket.cpp-with-new.patch
@@ -1,4 +1,4 @@
1From cc4f32db13ddc62fbd1e316127c5a60f4080a2d3 Mon Sep 17 00:00:00 2001 1From 81f36e7174097a1f1f3e7f94a97574b2ec68577f Mon Sep 17 00:00:00 2001
2From: "James E. King, III" <jim.king@simplivity.com> 2From: "James E. King, III" <jim.king@simplivity.com>
3Date: Thu, 29 Sep 2016 15:04:09 -0400 3Date: Thu, 29 Sep 2016 15:04:09 -0400
4Subject: [PATCH] THRIFT-3878: fix interop with newer OpenSSL libraries 4Subject: [PATCH] THRIFT-3878: fix interop with newer OpenSSL libraries
@@ -8,10 +8,10 @@ Subject: [PATCH] THRIFT-3878: fix interop with newer OpenSSL libraries
8 1 file changed, 5 insertions(+) 8 1 file changed, 5 insertions(+)
9 9
10diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 10diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
11index 517151f714..1efb9f7a47 100644 11index 3da9e45..0a3a124 100644
12--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp 12--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp
13+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 13+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
14@@ -108,7 +108,12 @@ void initializeOpenSSL() { 14@@ -97,7 +97,12 @@ void initializeOpenSSL() {
15 SSL_library_init(); 15 SSL_library_init();
16 SSL_load_error_strings(); 16 SSL_load_error_strings();
17 // static locking 17 // static locking
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0006-THRIFT-3736-C++-library-build-fails-if-OpenSSL-does-.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0006-THRIFT-3736-C++-library-build-fails-if-OpenSSL-does-.patch
index 9c18171f1..dfaa2fbda 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0006-THRIFT-3736-C++-library-build-fails-if-OpenSSL-does-.patch
+++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0006-THRIFT-3736-C++-library-build-fails-if-OpenSSL-does-.patch
@@ -1,7 +1,8 @@
1From 53dc6e255bec2e4cd8bae85d14bec1cf28310d3f Mon Sep 17 00:00:00 2001 1From 4cd49f470ca983369451d1141acc80fe1115cab4 Mon Sep 17 00:00:00 2001
2From: Nobuaki Sukegawa <nsuke@apache.org> 2From: Nobuaki Sukegawa <nsuke@apache.org>
3Date: Sun, 13 Mar 2016 08:55:38 +0900 3Date: Sun, 13 Mar 2016 08:55:38 +0900
4Subject: [PATCH] THRIFT-3736 C++ library build fails if OpenSSL does not 4Subject: [PATCH] THRIFT-3736 C++ library build fails if OpenSSL does not
5
5 surrpot SSLv3 6 surrpot SSLv3
6 7
7--- 8---
@@ -10,10 +11,10 @@ Subject: [PATCH] THRIFT-3736 C++ library build fails if OpenSSL does not
10 2 files changed, 10 insertions(+) 11 2 files changed, 10 insertions(+)
11 12
12diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 13diff --git a/lib/cpp/src/thrift/transport/TSSLSocket.cpp b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
13index bd13160260..517151f714 100644 14index 0a3a124..3e79354 100644
14--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp 15--- a/lib/cpp/src/thrift/transport/TSSLSocket.cpp
15+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp 16+++ b/lib/cpp/src/thrift/transport/TSSLSocket.cpp
16@@ -151,8 +151,10 @@ static char uppercase(char c); 17@@ -145,8 +145,10 @@ static char uppercase(char c);
17 SSLContext::SSLContext(const SSLProtocol& protocol) { 18 SSLContext::SSLContext(const SSLProtocol& protocol) {
18 if (protocol == SSLTLS) { 19 if (protocol == SSLTLS) {
19 ctx_ = SSL_CTX_new(SSLv23_method()); 20 ctx_ = SSL_CTX_new(SSLv23_method());
@@ -23,12 +24,12 @@ index bd13160260..517151f714 100644
23+#endif 24+#endif
24 } else if (protocol == TLSv1_0) { 25 } else if (protocol == TLSv1_0) {
25 ctx_ = SSL_CTX_new(TLSv1_method()); 26 ctx_ = SSL_CTX_new(TLSv1_method());
26 } else if (protocol == TLSv1_1) { 27 #if (OPENSSL_VERSION_NUMBER >= OPENSSL_VERSION_WITH_TLSv1_1_AND_TLSv1_2)
27diff --git a/lib/cpp/test/SecurityTest.cpp b/lib/cpp/test/SecurityTest.cpp 28diff --git a/lib/cpp/test/SecurityTest.cpp b/lib/cpp/test/SecurityTest.cpp
28index 9968e2c478..23650d6280 100644 29index 213efd4..08110e7 100644
29--- a/lib/cpp/test/SecurityTest.cpp 30--- a/lib/cpp/test/SecurityTest.cpp
30+++ b/lib/cpp/test/SecurityTest.cpp 31+++ b/lib/cpp/test/SecurityTest.cpp
31@@ -240,6 +240,14 @@ BOOST_AUTO_TEST_CASE(ssl_security_matrix) 32@@ -239,6 +239,14 @@ BOOST_AUTO_TEST_CASE(ssl_security_matrix)
32 continue; 33 continue;
33 } 34 }
34 35