summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-02 00:01:44 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:12:26 -0700
commit77411fa4a945d34147288192eb1eb7a59a1e8433 (patch)
treec0565f40fb222001f3a270df5fc994fc03b5fb80
parent0c906a04d8b69d07ab15360f2be5735cc3ee25b7 (diff)
downloadmeta-openembedded-77411fa4a945d34147288192eb1eb7a59a1e8433.tar.gz
menulibre: update 2.1.3 -> 2.1.5
Patches: * 0001../0003..: They were stolen from Fedora and don't apply no more due to major code changes. Fedora has removed them too. * 0002..: Does not apply no more. Replaced by sed in do_install Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch37
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch40
-rw-r--r--meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch36
-rw-r--r--meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb (renamed from meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb)21
4 files changed, 12 insertions, 122 deletions
diff --git a/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch b/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch
deleted file mode 100644
index fb2dfc90a..000000000
--- a/meta-xfce/recipes-apps/menulibre/files/0001-add_launcher-Exit-early-if-no-row-is-selected.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 1060e7ac8a63b93d56006718f0e9b1d9382b2226 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 08:33:16 +0100
4Subject: [PATCH] add_launcher: Exit early if no row is selected
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Stolen from [1]
10
11[1] http://pkgs.fedoraproject.org/cgit/rpms/menulibre.git/tree/menulibre-add-launcher-none-check.patch
12
13Upstream-Status: Pending
14
15Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
16---
17 menulibre/MenulibreApplication.py | 4 ++++
18 1 file changed, 4 insertions(+)
19
20diff --git a/menulibre/MenulibreApplication.py b/menulibre/MenulibreApplication.py
21index e234800..ac73b03 100644
22--- a/menulibre/MenulibreApplication.py
23+++ b/menulibre/MenulibreApplication.py
24@@ -1418,6 +1418,10 @@ class MenulibreWindow(Gtk.ApplicationWindow):
25 model, parent_data = self.treeview.get_parent_row_data()
26 model, row_data = self.treeview.get_selected_row_data()
27
28+ # Exit early if no row is selected
29+ if not row_data:
30+ return
31+
32 # Currently selected item is a directory, take its categories.
33 if row_data[2] == MenuItemTypes.DIRECTORY:
34 self.treeview.add_child(new_row_data)
35--
362.5.5
37
diff --git a/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch b/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch
deleted file mode 100644
index b63d4dc3b..000000000
--- a/meta-xfce/recipes-apps/menulibre/files/0002-setup.py-avoid-usr-share-share-paths.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From 99788b4557543c490493ce1b827538c49142c25d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 09:08:51 +0100
4Subject: [PATCH] setup.py: avoid /usr/share/share paths
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 setup.py | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index 5fc237d..c4fbf7c 100644
18--- a/setup.py
19+++ b/setup.py
20@@ -143,7 +143,7 @@ class InstallAndUpdateDataDirectory(DistUtilsExtra.auto.install_auto):
21
22 if self.root:
23 target_data = os.path.relpath(self.install_data, self.root) + os.sep
24- target_pkgdata = os.path.join(target_data, 'share', 'menulibre', '')
25+ target_pkgdata = os.path.join(target_data, 'menulibre', '')
26 target_scripts = os.path.join(self.install_scripts, '')
27
28 data_dir = os.path.join(self.prefix, 'share', 'menulibre', '')
29@@ -152,7 +152,7 @@ class InstallAndUpdateDataDirectory(DistUtilsExtra.auto.install_auto):
30 # --user install
31 self.root = ''
32 target_data = os.path.relpath(self.install_data) + os.sep
33- target_pkgdata = os.path.join(target_data, 'share', 'menulibre', '')
34+ target_pkgdata = os.path.join(target_data, 'menulibre', '')
35 target_scripts = os.path.join(self.install_scripts, '')
36
37 # Use absolute paths
38--
392.5.5
40
diff --git a/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch b/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch
deleted file mode 100644
index 1e92088e1..000000000
--- a/meta-xfce/recipes-apps/menulibre/files/0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 90098d835b62b38ac396d55b80a684770dbaacde Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Mon, 31 Oct 2016 15:50:52 +0100
4Subject: [PATCH] MenulibreXdg.py: fix loading of desktop files
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9fixes:
10| UnicodeDecodeError: 'ascii' codec can't decode byet 0xd9 in position 235: ordinal not in range(128)
11
12and information display not properly filled.
13
14Upstream-Status: Pending
15
16Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
17---
18 menulibre/MenulibreXdg.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/menulibre/MenulibreXdg.py b/menulibre/MenulibreXdg.py
22index e04c5e6..14b2593 100644
23--- a/menulibre/MenulibreXdg.py
24+++ b/menulibre/MenulibreXdg.py
25@@ -74,7 +74,7 @@ class MenulibreDesktopEntry:
26
27 def load_properties(self, filename):
28 """Load the properties."""
29- input_file = open(filename)
30+ input_file = open(filename, 'rt', encoding='utf-8')
31 self.load_properties_from_text(input_file.read())
32 input_file.close()
33
34--
352.5.5
36
diff --git a/meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb
index 69e52fe4a..cc7b29164 100644
--- a/meta-xfce/recipes-apps/menulibre/menulibre_2.1.3.bb
+++ b/meta-xfce/recipes-apps/menulibre/menulibre_2.1.5.bb
@@ -4,21 +4,23 @@ SECTION = "x11/graphics"
4LICENSE = "GPLv3" 4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6 6
7DEPENDS = "python3-distutils-extra-native intltool-native" 7DEPENDS = " \
8 python3-distutils-extra-native \
9 intltool-native \
10"
8 11
9inherit distutils3 gtk-icon-cache 12inherit distutils3 gtk-icon-cache
10 13
11SRC_URI = " \ 14SRC_URI = "https://launchpad.net/menulibre/2.1/${PV}/+download/${PN}-${PV}.tar.gz"
12 https://launchpad.net/menulibre/2.1/${PV}/+download/${PN}-${PV}.tar.gz \ 15SRC_URI[md5sum] = "efc7edb49bb0e5fea49e158b40573334"
13 file://0001-add_launcher-Exit-early-if-no-row-is-selected.patch \ 16SRC_URI[sha256sum] = "ef05b2722bab2acb7070d6c8ed0e7bd58bd4a4540bf498af9e889944f9da08b5"
14 file://0002-setup.py-avoid-usr-share-share-paths.patch \ 17
15 file://0003-MenulibreXdg.py-fix-loading-of-desktop-files.patch \ 18do_compile() {
16" 19}
17SRC_URI[md5sum] = "19d9d3337322eb5513454bb8cdfb739b"
18SRC_URI[sha256sum] = "bdd69740119902f1b1f8c7831155f4428403792a0a6c4287bcbb395c4e71fb31"
19 20
20do_install_append() { 21do_install_append() {
21 sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop 22 sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop
23 sed -i 's:share/share:share:g' ${D}${PYTHON_SITEPACKAGES_DIR}/menulibre_lib/menulibreconfig.py
22} 24}
23 25
24FILES_${PN} += " \ 26FILES_${PN} += " \
@@ -29,6 +31,7 @@ FILES_${PN} += " \
29 31
30RDEPENDS_${PN} += " \ 32RDEPENDS_${PN} += " \
31 gtk+3 \ 33 gtk+3 \
34 gtksourceview3 \
32 python3-pygobject \ 35 python3-pygobject \
33 gnome-menus3 \ 36 gnome-menus3 \
34 python3-unixadmin \ 37 python3-unixadmin \