summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Conlon <ccflyer@gmail.com>2018-12-06 13:26:29 -0700
committerKhem Raj <raj.khem@gmail.com>2018-12-06 17:06:39 -0800
commit5f9bcfcd3b9159eb09b7ba9b1821ab76b5116d85 (patch)
tree5155c8a4b034613725afe7072a67de73b6ac797e
parent0bb29681c49516d83a448dae383d7870e265805d (diff)
downloadmeta-openembedded-5f9bcfcd3b9159eb09b7ba9b1821ab76b5116d85.tar.gz
wolfssl: Update version to 3.15.5
This patch updates wolfSSL to the current 3.15.5 version. It removes a previous patch for generating cyassl/options.h, as wolfSSL proper now does that as part of the Autoconf configure step. It also removes the ipv6 PACKAGECONFIG usage. wolfSSL is IP neutral and the --enable-ipv6 configure option only affects the wolfSSL example client/server. As these examples are not compiled as part of this recipe, the PACKAGECONFIG is unnecessary. Signed-off-by: Chris Conlon <chris@wolfssl.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/wolfssl/files/0001-fix-no-rule-to-make-cyassl-options.h.patch27
-rw-r--r--meta-networking/recipes-connectivity/wolfssl/wolfssl_3.14.4.bb24
-rw-r--r--meta-networking/recipes-connectivity/wolfssl/wolfssl_3.15.5.bb21
3 files changed, 21 insertions, 51 deletions
diff --git a/meta-networking/recipes-connectivity/wolfssl/files/0001-fix-no-rule-to-make-cyassl-options.h.patch b/meta-networking/recipes-connectivity/wolfssl/files/0001-fix-no-rule-to-make-cyassl-options.h.patch
deleted file mode 100644
index f304d933d..000000000
--- a/meta-networking/recipes-connectivity/wolfssl/files/0001-fix-no-rule-to-make-cyassl-options.h.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From fb490136cf8f2456cfe13b0b4f796e6c155e75dc Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 30 Aug 2017 03:02:32 -0400
4Subject: [PATCH] fix no rule to make cyassl/options.h
5
6Upstream-Status: Pending
7
8Signed-off-by: Dengke Du <dengke.du@windriver.com>
9---
10 configure.ac | 1 +
11 1 file changed, 1 insertion(+)
12
13diff --git a/configure.ac b/configure.ac
14index 395d75d..d4a3880 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -3684,6 +3684,7 @@ AC_CONFIG_FILES([wolfssl/options.h])
18 #fi
19 AC_CONFIG_FILES([support/wolfssl.pc])
20 AC_CONFIG_FILES([rpm/spec])
21+AC_CONFIG_FILES([cyassl/options.h])
22
23 AX_CREATE_GENERIC_CONFIG
24 AX_AM_JOBSERVER([yes])
25--
262.8.1
27
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.14.4.bb b/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.14.4.bb
deleted file mode 100644
index dc9094d8b..000000000
--- a/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.14.4.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "wolfSSL Lightweight, Embedded SSL Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written in C and \
3 optimized for embedded and RTOS environments. It can be \
4 Up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS 1.2 client and server."
6HOMEPAGE = "http://www.wolfssl.com/yaSSL/Products-wolfssl.html"
7BUGTRACKER = "http://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
15S = "${WORKDIR}/git"
16SRCREV = "1196a3b64d9fabffc8273b87f6f69ac0e75d2eb7"
17SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https; \
18 file://0001-fix-no-rule-to-make-cyassl-options.h.patch \
19 "
20
21inherit autotools
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
24PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.15.5.bb b/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.15.5.bb
new file mode 100644
index 000000000..37ba4aa32
--- /dev/null
+++ b/meta-networking/recipes-connectivity/wolfssl/wolfssl_3.15.5.bb
@@ -0,0 +1,21 @@
1SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
15SRC_URI[md5sum] = "bc2dff70ba6e91aa3748d36ae6c6bc3d"
16SRC_URI[sha256sum] = "f6c04c25355b340373931f43f8041b3cef78b61122e8a8edf9ee63c07b7a58be"
17SRC_URI = "https://www.wolfssl.com/wolfssl-3.15.5.zip"
18
19inherit autotools
20
21BBCLASSEXTEND += "native nativesdk"