summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-03 11:40:11 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-04 10:00:48 -0800
commit5acd169e4133aa9b0569bc3cbcb3666190ee4783 (patch)
treed11d441de5f07a15e351aba81dd42eeee8b3c7e8
parent7327e8aeea39e2255622699450f0f77b286efb8c (diff)
downloadmeta-openembedded-5acd169e4133aa9b0569bc3cbcb3666190ee4783.tar.gz
freerdp: Update to 2.0.0-rc4
Drop backports which are now upstream Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch27
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch13
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp_git.bb4
3 files changed, 7 insertions, 37 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch b/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
deleted file mode 100644
index a567cba92..000000000
--- a/meta-oe/recipes-support/freerdp/freerdp/0001-Fix-gstreamer-1.0-detection.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 368989526c32cdf9d680a397fede3cb773fa2609 Mon Sep 17 00:00:00 2001
2From: Mike Gilbert <floppym@gentoo.org>
3Date: Fri, 28 Jul 2017 16:31:41 -0400
4Subject: [PATCH] Fix gstreamer-1.0 detection
5
6Upstream State: Backport
7
8---
9 cmake/FindGStreamer_1_0.cmake | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/cmake/FindGStreamer_1_0.cmake b/cmake/FindGStreamer_1_0.cmake
13index 3aa8fc6..6fbc0ec 100644
14--- a/cmake/FindGStreamer_1_0.cmake
15+++ b/cmake/FindGStreamer_1_0.cmake
16@@ -59,7 +59,7 @@ macro(FIND_GSTREAMER_COMPONENT _component_prefix _pkgconfig_name _library)
17
18 string(REGEX MATCH "(.*)>=(.*)" _dummy "${_pkgconfig_name}")
19 if ("${CMAKE_MATCH_2}" STREQUAL "")
20- pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GStreamer_FIND_VERSION}")
21+ pkg_check_modules(PC_${_component_prefix} "${_pkgconfig_name} >= ${GSTREAMER_1_0_MINIMUM_VERSION}")
22 else ()
23 pkg_check_modules(PC_${_component_prefix} ${_pkgconfig_name})
24 endif ()
25--
262.7.4
27
diff --git a/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch b/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch
index 0d7dcc28d..0f6f575d0 100644
--- a/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch
+++ b/meta-oe/recipes-support/freerdp/freerdp/winpr-makecert-Build-with-install-RPATH.patch
@@ -12,13 +12,13 @@ Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
12 winpr/tools/makecert-cli/CMakeLists.txt | 3 +++ 12 winpr/tools/makecert-cli/CMakeLists.txt | 3 +++
13 1 file changed, 3 insertions(+) 13 1 file changed, 3 insertions(+)
14 14
15diff --git a/winpr/tools/makecert-cli/CMakeLists.txt b/winpr/tools/makecert-cli/CMakeLists.txt 15Index: git/winpr/tools/makecert-cli/CMakeLists.txt
16index 74afa09..8d00ef1 100644 16===================================================================
17--- a/winpr/tools/makecert-cli/CMakeLists.txt 17--- git.orig/winpr/tools/makecert-cli/CMakeLists.txt
18+++ b/winpr/tools/makecert-cli/CMakeLists.txt 18+++ git/winpr/tools/makecert-cli/CMakeLists.txt
19@@ -44,6 +44,9 @@ set(${MODULE_PREFIX}_LIBS winpr-tools) 19@@ -44,6 +44,9 @@ set(${MODULE_PREFIX}_LIBS winpr-tools)
20 20
21 target_link_libraries(${MODULE_NAME} ${${MODULE_PREFIX}_LIBS}) 21 target_link_libraries(${MODULE_NAME} ${${MODULE_PREFIX}_LIBS} winpr)
22 22
23+set_target_properties(${MODULE_NAME} PROPERTIES 23+set_target_properties(${MODULE_NAME} PROPERTIES
24+ BUILD_WITH_INSTALL_RPATH 1) 24+ BUILD_WITH_INSTALL_RPATH 1)
@@ -26,6 +26,3 @@ index 74afa09..8d00ef1 100644
26 set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Tools") 26 set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Tools")
27 27
28 install(TARGETS ${MODULE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT tools EXPORT WinPRTargets) 28 install(TARGETS ${MODULE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT tools EXPORT WinPRTargets)
29--
302.7.4
31
diff --git a/meta-oe/recipes-support/freerdp/freerdp_git.bb b/meta-oe/recipes-support/freerdp/freerdp_git.bb
index 88aec9c41..373c4979f 100644
--- a/meta-oe/recipes-support/freerdp/freerdp_git.bb
+++ b/meta-oe/recipes-support/freerdp/freerdp_git.bb
@@ -13,10 +13,10 @@ inherit pkgconfig cmake gitpkgv
13PV = "2.0.0+gitr${SRCPV}" 13PV = "2.0.0+gitr${SRCPV}"
14PKGV = "${GITPKGVTAG}" 14PKGV = "${GITPKGVTAG}"
15 15
16SRCREV = "1648deb435ad52206f7aa2afe4b4dff71d9329bc" 16# 2.0.0-rc4
17SRCREV = "e21b72c95f857817b4b32b5ef5406355c005a9e8"
17SRC_URI = "git://github.com/FreeRDP/FreeRDP.git \ 18SRC_URI = "git://github.com/FreeRDP/FreeRDP.git \
18 file://winpr-makecert-Build-with-install-RPATH.patch \ 19 file://winpr-makecert-Build-with-install-RPATH.patch \
19 file://0001-Fix-gstreamer-1.0-detection.patch \
20" 20"
21 21
22S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"