summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWei Lin Guay <wguay@graphcore.ai>2018-05-15 14:44:17 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:31:11 -0700
commit556b9edf97d092d04c1d05b4f2bb28506d800fb4 (patch)
tree4cf4db661bd12826d3201d1095e4f6065c373a67
parentda9138fd7feb4f764bfdcbcc8954269a8eba69c4 (diff)
downloadmeta-openembedded-556b9edf97d092d04c1d05b4f2bb28506d800fb4.tar.gz
rdma-core: add new recipe
RDMA core is the userspace components for the Linux Kernel's InfiniBand/RoCE subsystem. This component contains the userspace libraries for libibverbs (and its associated providers libraries), librdmacm and libibumad. Besides, it also provides additional service daemons such as ibacm and srp_daemon. Signed-off-by: Wei Lin Guay <wguay@graphcore.ai> Reviewed-by: Harald Høeg <hhoeg@graphcore.ai> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/rdma-core/rdma-core_17.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core_17.bb b/meta-networking/recipes-support/rdma-core/rdma-core_17.bb
new file mode 100644
index 000000000..5d0329919
--- /dev/null
+++ b/meta-networking/recipes-support/rdma-core/rdma-core_17.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Userspace support for InfiniBand/RDMA verbs"
2DESCRIPTION = "This is the userspace components for the Linux Kernel's drivers Infiniband/RDMA subsystem."
3SECTION = "libs"
4
5DEPENDS = "libnl"
6RDEPENDS_${PN} = "bash perl"
7
8SRC_URI = "git://github.com/linux-rdma/rdma-core.git;protocol=http"
9SRCREV ="5ce12bd51ebb0a4db35dea382b1ebdc701bab224"
10S = "${WORKDIR}/git"
11
12#Default Dual License https://github.com/linux-rdma/rdma-core/blob/master/COPYING.md
13LICENSE = "BSD-2-Clause | GPLv2"
14LIC_FILES_CHKSUM = "file://COPYING.BSD_FB;md5=0ec18bae1a9df92c8d6ae01f94a289ae \
15 file://COPYING.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263"
16
17
18FILES_SOLIBSDEV = ""
19FILES_${PN} += "${libdir}/*"
20INSANE_SKIP_${PN} += "dev-so"
21
22inherit cmake
23
24OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"