summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dragomir <daniel.dragomir@windriver.com>2018-03-08 18:54:58 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:27:54 -0700
commit492c7efc36ec94dc6a05e65df5a6a302f9283314 (patch)
tree01ce2e34a56937ffc0c166ab4cf9af250ef7ba82
parentd0239ec5cd18fea7380bb94b004ace2789f9f3ff (diff)
downloadmeta-openembedded-492c7efc36ec94dc6a05e65df5a6a302f9283314.tar.gz
python-robotframework: add recipe for 3.0.2 version
Robot Framework is a generic open source test automation framework for acceptance testing and acceptance test-driven development (ATDD). It has easy-to-use tabular test data syntax and it utilizes the keyword-driven testing approach. Its testing capabilities can be extended by test libraries implemented either with Python or Java, and users can create new higher-level keywords from existing ones using the same syntax that is used for creating test cases. Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb2
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-robotframework.inc b/meta-python/recipes-devtools/python/python-robotframework.inc
new file mode 100644
index 000000000..cc20d6477
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-robotframework.inc
@@ -0,0 +1,15 @@
1SUMMARY = "A Python generic test automation framework"
2DESCRIPTION = "Generic open source test atomation framework for acceptance\
3testing and acceptance test-driven development (ATDD). It has easy-to-use\
4tabular test data syntax and it utilizes the keyword-driven testing approach.\
5Its testing capabilities can be extended by test libraries implemented either\
6with Python or Java, and users can create new higher-level keywords from\
7existing ones using the same syntax that is used for creating test cases."
8HOMEPAGE = "http://robotframework.org"
9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
11
12inherit pypi
13
14SRC_URI[md5sum] = "ea49a54b9d7e38302712194e85c37eaa"
15SRC_URI[sha256sum] = "2018f233568227f9af8c366f93e243a157b742f3baf5b649ecc9750ac0ee1ff7"
diff --git a/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
new file mode 100644
index 000000000..16eaa78cd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-robotframework_3.0.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools
2require python-robotframework.inc
diff --git a/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb b/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb
new file mode 100644
index 000000000..8f613c386
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-robotframework_3.0.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-robotframework.inc