summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2018-09-12 05:09:10 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-12 07:08:11 -0700
commit376eb385a519875683665760bcf4f83b940890a4 (patch)
tree30e78142d15776ed4da568133e5fdd8f1ab213bc
parentb0ece93cbd17a135bfd15ad8aac67803c9cc0d4e (diff)
downloadmeta-openembedded-376eb385a519875683665760bcf4f83b940890a4.tar.gz
snappy: modify cmake variable to generate shared library
FILES_${PN}-xxx under packages-split/ depend on FILES_${PN}. But the FILES_${PN} is empty. This is because snappy doesn't generate shared library by default. So we should modify cmake variable to generate shared library. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/snappy/snappy_1.1.7.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb
index 70223be49..9f37c5fc2 100644
--- a/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb
+++ b/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb
@@ -20,3 +20,6 @@ inherit cmake pkgconfig
20PACKAGECONFIG ??= "" 20PACKAGECONFIG ??= ""
21PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo," 21PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo,"
22TARGET_CFLAGS += "-fPIC" 22TARGET_CFLAGS += "-fPIC"
23
24EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" \
25 '